Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » Download what files?
Download what files? [message #64133] Sun, 06 January 2008 10:21 Go to next message
Eclipse UserFriend
Originally posted by: Jens.Geier.b-w.com

Hello,

i am a newcommer with eclipse.

I do not find the right files for downloading the eclipse develpment tool
where i can write software for PHP scripts.

I hope someone can help me with this question.

Kind Regards
Jens Geier
Re: Download what files? [message #64180 is a reply to message #64133] Sun, 06 January 2008 15:22 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: pobox.verysmall.org

Jens Geier wrote:
> I do not find the right files for downloading the eclipse develpment tool
> where i can write software for PHP scripts.

Go to www.eclipse.org, click on the big orange Download Eclipse button
and download Eclipse Classic 3.3.1.1 for your platform.

It would be best if you make sure you have the latest Java.

Run the Eclipse, click on Help > Software Updates > Find and Install,
select Search for new features to install and click Next.

Click on New Remote Site, and give it as a name PDT and as URI
http://download.eclipse.org/tools/pdt/updates/. This will add new remote
site and the check box will be checked. Check (!) as well the check box
in front of Europa Discovery site and click finish. Then you can accept
the suggested mirrors, just click OK.

When you get the search results, check the check box in front of the PDT
entry. At this moment you will get a red error on top of the window for
missing dependencies. In this moment open (!) the list of Europa
Discovery Site by clicking the small triangle and then (!) click the
Select Required button. This will select the required dependencies.

Go on and all should be fine. PDT sometimes gives an error on install,
if you get messed up, start new by unzipping Eclipse.

After all is done, Eclipse will ask you to restart.

Then click on the small icon in front of the word Java on top right,
choose Other and choose the PHP perspective.

This will get you started.

Iv
Re: Download what files? [message #64236 is a reply to message #64180] Mon, 07 January 2008 10:25 Go to previous messageGo to next message
John is currently offline JohnFriend
Messages: 4
Registered: July 2009
Junior Member
Here's another (pretty much the same) method :

-- How to Install and "Configure" PDT on a WinXP machine --

Installation de PDT-Eclipse

1. Download the latest stable PDTAllInOne paquet.

Check the PDT main page for updates:
http://www.eclipse.org/pdt/index.php

Look for the "What's new" section and go to the Downloads page :
http://download.eclipse.org/tools/pdt/downloads/?release=3DS 20071213-M1
(I used "December 16th - PDT 1.0.2 Milestone 1 is Ready!" link)

2. Modify ECLIPSE_ROOT/eclipse.ini with this :

-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
-vm C:\Program Files\Java\jre1.5.0_14\bin\javaw.exe
-vmargs -XX:+UseParallelGC
-Xms128m
-Xmx768m

This enables a "good" memory management (it works for me : 2GB RAM).
If you have a Dual Core machine, use the "-XX:+UseParallelGC" option.

3. Modify the Win shorcut for your Eclipse/PDT install :

"C:\Program Files\eclipse\eclipse.exe" -vm "C:\Program =

Files\Java\jre1.5.0_14\bin\javaw.exe"

This way you tell Eclipse to use the JRE 5.0.

4. Enjoy !


John J. Garcia
Re: Download what files? [message #64329 is a reply to message #64133] Tue, 08 January 2008 20:29 Go to previous messageGo to next message
Piotr Przybylski is currently offline Piotr PrzybylskiFriend
Messages: 3
Registered: July 2009
Junior Member
Go to Zend's website and download the all in one package:
http://www.zend.com/en/community/pdt

Jens Geier pisze:
> Hello,
>
> i am a newcommer with eclipse.
>
> I do not find the right files for downloading the eclipse develpment tool
> where i can write software for PHP scripts.
>
> I hope someone can help me with this question.
>
> Kind Regards
> Jens Geier
>
>
Re: Download what files? [message #64465 is a reply to message #64329] Sun, 13 January 2008 14:00 Go to previous message
Eclipse UserFriend
Originally posted by: pobox.verysmall.org

Piotr Przybylski wrote:
> Go to Zend's website and download the all in one package:
> http://www.zend.com/en/community/pdt

I somehow never liked this all-in-one. Since 3.3 the management of
Eclipse components (at leas of the PDT) is quite easy, and if one can do
it using the Update Manager, one gets experience how to add other
components, such as version control, etc.

But, of course, to quickly start and try it, without fight, the
all-in-one (if working well) can be a good thing in some situations.

Iv

--
Previous Topic:syntax highlighting problem with include files
Next Topic:Profiling code with xdebug
Goto Forum:
  


Current Time: Wed Feb 08 07:39:45 GMT 2023

Powered by FUDForum. Page generated in 0.02022 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top