Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Buckminster dev » [buckminster-dev] Buckminster questions
[buckminster-dev] Buckminster questions [message #630717] Mon, 04 October 2010 16:38
Wim Jongman is currently offline Wim JongmanFriend
Messages: 423
Registered: July 2009
Senior Member
--0015175d676280a2390491cd2c19
Content-Type: text/plain; charset=ISO-8859-1

Hi Folks,

I would like to use buckminster for the complete CI cycle but I run into
problems. I would really appreciate some help.

I am doing the chapter 16 in the book to get my head around all aspects of
Buckminster and here are some questions.

Why does the cquery "resolve and materialize", materialize to the workspace.
Is that the default?
A- source bundles go to workspace non source go to Target platform

After the resolve I get this warning/error

Resetting target platform Buckminster Default TP
ERROR [0001] : Resource '/.buckminster/tp' is not local.
Resource '/.buckminster/tp' is not local.
TAG-ID 0001 = Query for
org.eclipse.buckminster.tutorial.mailapp.product.feature:ecl ipse.feature

A: this is the default target workspace and is not created until first
materialization?

--------------
The RMAP in this chapter filters for the useBuild property. How is the
related to the use.build property in the rmap? Is this another way of naming
the property?


---
When executing the examples to create a product I ran into similar problems
as described in this thread:
http://www.eclipse.org/forums/index.php?t=msg&goto=50734 5&

which was supposedly resolved with:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=299711

my log:

[ant] Software being installed: Mailapp test build 1.0.0
(org.eclipse.buckminster.tutorial.mailapp.product 1.0.0)
[ant] Missing requirement: Equinox Provisioning Platform Update Support
1.0.100.v20100513 (org.eclipse.equinox.p2.ui.sdk 1.0.100.v20100513) requires
'bundle org.eclipse.compare 0.0.0' but it could not be found
[ant] Application failed, log file location: C:\Program
Files\Eclipse\3.6\Build\eclipse\configuration\1286206760482. log

To be able to continue, I removed the p2.user.ui requirement from the
product feature.

----
There are no launcher artifacts created (e.g. application.exe). Is there
something that needs to be done in addition to create.product?

--
Can buckminster make use of the already existing .product file?


Thanks for helping.

Best regards,

Wim

--0015175d676280a2390491cd2c19
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Hi Folks,<div><br></div><div>I would like to use buckminster for the comple=
te CI cycle but I run into problems. I would really appreciate some help.=
=A0<div><div><br></div><div>I am doing the chapter 16 in the book to get my=
head around all aspects of Buckminster and here are some questions.</div>
<div><br></div><div>Why does the cquery &quot;resolve and materialize&quot;=
, materialize to the workspace. Is that the default?=A0</div>
<div>=A0=A0A- source bundles go to workspace non source go to Target platfo=
rm</div><div><br></div><div>After the resolve I get this warning/error</div=
><div><br></div><div><div>Resetting target platform Buckminster Default TP<=
/div>
<div>ERROR =A0 [0001] : Resource &#39;/.buckminster/tp&#39; is not local.</=
div>
<div>Resource &#39;/.buckminster/tp&#39; is not local.</div><div>TAG-ID 000=
1 =3D Query for org.eclipse.buckminster.tutorial.mailapp.product.feature:ec=
lipse.feature</div></div><div><br></div><div>A: this is the default target =
workspace and is not created until first materialization?=A0</div>
<div><br></div><div>--------------</div><div>The RMAP in this chapter filte=
rs for the useBuild property. How is the related to the use.build property =
in the rmap? Is this another way of naming the property?</div><div><br>
</div><div><br></div><div>---</div><div>When executing the examples to crea=
te a product I ran into=A0similar=A0problems as described in this thread:=
=A0</div><div><a href=3D"http://www.eclipse.org/forums/index.php?t=3Dmsg&am=
p;goto=3D507345&amp;">http://www.eclipse.org/forums/index.php?t=3Dmsg&amp;g=
oto=3D507345&amp;</a></div>
<div><br></div><div>which was supposedly resolved with:</div><div><br></div=
><div><a href=3D"https://bugs.eclipse.org/bugs/show_bug.cgi?id=3D299711">ht=
tps://bugs.eclipse.org/bugs/show_bug.cgi?id=3D299711</a></div><div><br></di=
v>
<div>my log:</div><div><br></div><div><div>[ant] =A0Software being installe=
d: Mailapp test build 1.0.0 (org.eclipse.buckminster.tutorial.mailapp.produ=
ct 1.0.0)</div><div>[ant] =A0Missing requirement: Equinox Provisioning Plat=
form Update Support 1.0.100.v20100513 (org.eclipse.equinox.p2.ui.sdk 1.0.10=
0.v20100513) requires &#39;bundle org.eclipse.compare 0.0.0&#39; but it cou=
ld not be found</div>
<div>[ant] Application failed, log file location: C:\Program Files\Eclipse\=
3.6\Build\eclipse\configuration\1286206760482.log</div></div ><div><br></div=
><div>To be able to continue, I removed the p2.user.ui requirement from the=
product feature.</div>
<div><br></div><div>----</div><div>There are no launcher artifacts created =
(e.g. application.exe). Is there something that needs to be done in additio=
n to create.product?=A0</div><div><br></div><div>--</div><div >Can buckminst=
er make use of the already existing .product file?</div>
<div><br></div><div><br></div><div>Thanks for helping.</div><div><br></div>=
<div>Best regards,</div><div><br></div><div>Wim</div><div><br ></div><div><b=
r></div><div><br></div><div><br></div>
<div><br></div><div><br></div>
</div></div>

--0015175d676280a2390491cd2c19--
Previous Topic:Re: [buckminster-dev] Silent NPE
Next Topic:[buckminster-dev] Project meta data is out of date for tools.buckminster
Goto Forum:
  


Current Time: Fri Jun 22 23:15:38 GMT 2018

Powered by FUDForum. Page generated in 0.02427 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top