Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » CDO Errors after installation
CDO Errors after installation [message #63319] Thu, 30 November 2006 16:25 Go to next message
Eclipse UserFriend
Originally posted by: andreas_morf.bluewin.ch

Hi all CDO-Folks
I have a problem after installing CDO/Net4j - something is wrong with the
plugin.
Accessing the Preference-Page or pressing CDO-Buttons the following errors
appear in the log:

-Could not create action delegate for id:
org.eclipse.emf.cdo.test.client.CreateResourceAction
-Plug-in org.eclipse.emf.cdo.examples.library.ui was unable to load class
org.eclipse.emf.cdo.examples.library.ui.internal.actions.Cre ateResourceAction
-Plug-in org.eclipse.net4j.examples.prov.client.ui was unable to load class
org.eclipse.net4j.examples.prov.client.ui.actions.Provisioni ngDialogAction
-Could not create action delegate for id:
org.eclipse.net4j.examples.prov.client.ui.actions.Provisioni ngDialogAction

In the Product configuration both, the CDO and Net4j SDK's 0.7.1 appear
without any error markers

Anyone an idea?
Greets, Andreas
Re: CDO Errors after installation [message #63342 is a reply to message #63319] Thu, 30 November 2006 16:31 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: merks.ca.ibm.com

Andreas,

Hopefully someone has an idea because Eike is on vacation until Dec
6th.... You did eclipse.exe -clean after installing?


Andreas Morf wrote:
> Hi all CDO-Folks
> I have a problem after installing CDO/Net4j - something is wrong with the
> plugin.
> Accessing the Preference-Page or pressing CDO-Buttons the following errors
> appear in the log:
>
> -Could not create action delegate for id:
> org.eclipse.emf.cdo.test.client.CreateResourceAction
> -Plug-in org.eclipse.emf.cdo.examples.library.ui was unable to load class
> org.eclipse.emf.cdo.examples.library.ui.internal.actions.Cre ateResourceAction
> -Plug-in org.eclipse.net4j.examples.prov.client.ui was unable to load class
> org.eclipse.net4j.examples.prov.client.ui.actions.Provisioni ngDialogAction
> -Could not create action delegate for id:
> org.eclipse.net4j.examples.prov.client.ui.actions.Provisioni ngDialogAction
>
> In the Product configuration both, the CDO and Net4j SDK's 0.7.1 appear
> without any error markers
>
> Anyone an idea?
> Greets, Andreas
>
>
>
Re: CDO Errors after installation [message #63433 is a reply to message #63342] Fri, 01 December 2006 09:56 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: andreas_morf.bluewin.ch

Ed,
Did it just before: same as before...
I'm wondering why eclipse is not able to load the classes even if the plugin
is loaded (as stated in the configuration-details page) and the plugin-jar
contains the according class-file?


"Ed Merks" <merks@ca.ibm.com> wrote in message
news:ekn11i$qe4$1@utils.eclipse.org...
> Andreas,
>
> Hopefully someone has an idea because Eike is on vacation until Dec
> 6th.... You did eclipse.exe -clean after installing?
>
>
> Andreas Morf wrote:
>> Hi all CDO-Folks
>> I have a problem after installing CDO/Net4j - something is wrong with the
>> plugin.
>> Accessing the Preference-Page or pressing CDO-Buttons the following
>> errors appear in the log:
>>
>> -Could not create action delegate for id:
>> org.eclipse.emf.cdo.test.client.CreateResourceAction
>> -Plug-in org.eclipse.emf.cdo.examples.library.ui was unable to load class
>> org.eclipse.emf.cdo.examples.library.ui.internal.actions.Cre ateResourceAction
>> -Plug-in org.eclipse.net4j.examples.prov.client.ui was unable to load
>> class
>> org.eclipse.net4j.examples.prov.client.ui.actions.Provisioni ngDialogAction
>> -Could not create action delegate for id:
>> org.eclipse.net4j.examples.prov.client.ui.actions.Provisioni ngDialogAction
>>
>> In the Product configuration both, the CDO and Net4j SDK's 0.7.1 appear
>> without any error markers
>>
>> Anyone an idea?
>> Greets, Andreas
>>
>>
Re: CDO Errors after installation [message #64635 is a reply to message #63433] Sat, 16 December 2006 09:46 Go to previous message
Eclipse UserFriend
Originally posted by: stepper.sympedia.de

Andreas,

Sorry for the delay due to my vacation.

I believe the configuration dialog is not an indication that a plugin is
properly loaded (that is "started"). It can only indicate whether a
feature with all its plugins is properly installed. Can you please
verify that the plugin is not started in the Plugins view? This is not
possible in the runtime workbench mode!

Could you also please give me the release versions of your Eclipse and EMF?

Cheers
/Eike



Andreas Morf schrieb:
> Ed,
> Did it just before: same as before...
> I'm wondering why eclipse is not able to load the classes even if the plugin
> is loaded (as stated in the configuration-details page) and the plugin-jar
> contains the according class-file?
>
>
> "Ed Merks" <merks@ca.ibm.com> wrote in message
> news:ekn11i$qe4$1@utils.eclipse.org...
>
>> Andreas,
>>
>> Hopefully someone has an idea because Eike is on vacation until Dec
>> 6th.... You did eclipse.exe -clean after installing?
>>
>>
>> Andreas Morf wrote:
>>
>>> Hi all CDO-Folks
>>> I have a problem after installing CDO/Net4j - something is wrong with the
>>> plugin.
>>> Accessing the Preference-Page or pressing CDO-Buttons the following
>>> errors appear in the log:
>>>
>>> -Could not create action delegate for id:
>>> org.eclipse.emf.cdo.test.client.CreateResourceAction
>>> -Plug-in org.eclipse.emf.cdo.examples.library.ui was unable to load class
>>> org.eclipse.emf.cdo.examples.library.ui.internal.actions.Cre ateResourceAction
>>> -Plug-in org.eclipse.net4j.examples.prov.client.ui was unable to load
>>> class
>>> org.eclipse.net4j.examples.prov.client.ui.actions.Provisioni ngDialogAction
>>> -Could not create action delegate for id:
>>> org.eclipse.net4j.examples.prov.client.ui.actions.Provisioni ngDialogAction
>>>
>>> In the Product configuration both, the CDO and Net4j SDK's 0.7.1 appear
>>> without any error markers
>>>
>>> Anyone an idea?
>>> Greets, Andreas
>>>
>>>
>>>
>
>
>
Re: CDO Errors after installation [message #596370 is a reply to message #63319] Thu, 30 November 2006 16:31 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 31770
Registered: July 2009
Senior Member
Andreas,

Hopefully someone has an idea because Eike is on vacation until Dec
6th.... You did eclipse.exe -clean after installing?


Andreas Morf wrote:
> Hi all CDO-Folks
> I have a problem after installing CDO/Net4j - something is wrong with the
> plugin.
> Accessing the Preference-Page or pressing CDO-Buttons the following errors
> appear in the log:
>
> -Could not create action delegate for id:
> org.eclipse.emf.cdo.test.client.CreateResourceAction
> -Plug-in org.eclipse.emf.cdo.examples.library.ui was unable to load class
> org.eclipse.emf.cdo.examples.library.ui.internal.actions.Cre ateResourceAction
> -Plug-in org.eclipse.net4j.examples.prov.client.ui was unable to load class
> org.eclipse.net4j.examples.prov.client.ui.actions.Provisioni ngDialogAction
> -Could not create action delegate for id:
> org.eclipse.net4j.examples.prov.client.ui.actions.Provisioni ngDialogAction
>
> In the Product configuration both, the CDO and Net4j SDK's 0.7.1 appear
> without any error markers
>
> Anyone an idea?
> Greets, Andreas
>
>
>


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: CDO Errors after installation [message #596411 is a reply to message #63342] Fri, 01 December 2006 09:56 Go to previous message
Andreas Morf is currently offline Andreas MorfFriend
Messages: 14
Registered: July 2009
Junior Member
Ed,
Did it just before: same as before...
I'm wondering why eclipse is not able to load the classes even if the plugin
is loaded (as stated in the configuration-details page) and the plugin-jar
contains the according class-file?


"Ed Merks" <merks@ca.ibm.com> wrote in message
news:ekn11i$qe4$1@utils.eclipse.org...
> Andreas,
>
> Hopefully someone has an idea because Eike is on vacation until Dec
> 6th.... You did eclipse.exe -clean after installing?
>
>
> Andreas Morf wrote:
>> Hi all CDO-Folks
>> I have a problem after installing CDO/Net4j - something is wrong with the
>> plugin.
>> Accessing the Preference-Page or pressing CDO-Buttons the following
>> errors appear in the log:
>>
>> -Could not create action delegate for id:
>> org.eclipse.emf.cdo.test.client.CreateResourceAction
>> -Plug-in org.eclipse.emf.cdo.examples.library.ui was unable to load class
>> org.eclipse.emf.cdo.examples.library.ui.internal.actions.Cre ateResourceAction
>> -Plug-in org.eclipse.net4j.examples.prov.client.ui was unable to load
>> class
>> org.eclipse.net4j.examples.prov.client.ui.actions.Provisioni ngDialogAction
>> -Could not create action delegate for id:
>> org.eclipse.net4j.examples.prov.client.ui.actions.Provisioni ngDialogAction
>>
>> In the Product configuration both, the CDO and Net4j SDK's 0.7.1 appear
>> without any error markers
>>
>> Anyone an idea?
>> Greets, Andreas
>>
>>
Re: CDO Errors after installation [message #596970 is a reply to message #63433] Sat, 16 December 2006 09:46 Go to previous message
Eike Stepper is currently offline Eike StepperFriend
Messages: 6538
Registered: July 2009
Senior Member
Andreas,

Sorry for the delay due to my vacation.

I believe the configuration dialog is not an indication that a plugin is
properly loaded (that is "started"). It can only indicate whether a
feature with all its plugins is properly installed. Can you please
verify that the plugin is not started in the Plugins view? This is not
possible in the runtime workbench mode!

Could you also please give me the release versions of your Eclipse and EMF?

Cheers
/Eike



Andreas Morf schrieb:
> Ed,
> Did it just before: same as before...
> I'm wondering why eclipse is not able to load the classes even if the plugin
> is loaded (as stated in the configuration-details page) and the plugin-jar
> contains the according class-file?
>
>
> "Ed Merks" <merks@ca.ibm.com> wrote in message
> news:ekn11i$qe4$1@utils.eclipse.org...
>
>> Andreas,
>>
>> Hopefully someone has an idea because Eike is on vacation until Dec
>> 6th.... You did eclipse.exe -clean after installing?
>>
>>
>> Andreas Morf wrote:
>>
>>> Hi all CDO-Folks
>>> I have a problem after installing CDO/Net4j - something is wrong with the
>>> plugin.
>>> Accessing the Preference-Page or pressing CDO-Buttons the following
>>> errors appear in the log:
>>>
>>> -Could not create action delegate for id:
>>> org.eclipse.emf.cdo.test.client.CreateResourceAction
>>> -Plug-in org.eclipse.emf.cdo.examples.library.ui was unable to load class
>>> org.eclipse.emf.cdo.examples.library.ui.internal.actions.Cre ateResourceAction
>>> -Plug-in org.eclipse.net4j.examples.prov.client.ui was unable to load
>>> class
>>> org.eclipse.net4j.examples.prov.client.ui.actions.Provisioni ngDialogAction
>>> -Could not create action delegate for id:
>>> org.eclipse.net4j.examples.prov.client.ui.actions.Provisioni ngDialogAction
>>>
>>> In the Product configuration both, the CDO and Net4j SDK's 0.7.1 appear
>>> without any error markers
>>>
>>> Anyone an idea?
>>> Greets, Andreas
>>>
>>>
>>>
>
>
>


Previous Topic:teneo - Usage of assert
Next Topic:teneo - when will EMF2.3 (i.e., the Java 5.0 features) be supported?
Goto Forum:
  


Current Time: Sat Feb 27 22:54:38 GMT 2021

Powered by FUDForum. Page generated in 0.01724 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top