Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 » Re: Loading a Resource fails
Re: Loading a Resource fails [message #627054] Mon, 20 October 2008 16:09
Ed Merks is currently offline Ed MerksFriend
Messages: 31032
Registered: July 2009
Senior Member
This is a multi-part message in MIME format.
--------------020602040301090903040609
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit

Timothy,

These are really questions to direct to the UML2 newsgroup because I
just can't answer them from an EMF perspective. I'm not sure there is
any way in the IDE, given just an Ecore model, to create an instance of
UML's GenModel...


Timothy Marc wrote:
> But it is really strange, because obviously, the
> DerivedUnionEObjectList-Type is used... so, why is this Liste-Type
> used, but not the SubsetSuperset-one?
>
> "Timothy Marc" <timothymarc@freenet.de
> <mailto:timothymarc@freenet.de>> schrieb im Newsbeitrag
> news:gdi15h$9re$1@build.eclipse.org...
> Okay, and how can i use it explicitly. I didn't found any tutorial
> for it. Do you know some?
>
> "Ed Merks" <Ed.Merks@gmail.com <mailto:Ed.Merks@gmail.com>>
> schrieb im Newsbeitrag news:gdi10t$5nk$1@build.eclipse.org...
> Timothy,
>
> In order to generate the right things, you really have to be
> using UML's extended GenModel, which you'll only get if you
> specify your model using UML2 and import it. So it's not
> sufficient just to have an Ecore model with annotations just
> like the ones UML produces, you have to be using UML's
> extended GenModel for those annotations to be recognized...
>
>
> Timothy Marc wrote:
>> Ed,
>>
>> i've tried it with a reall simple model. It consists only of
>> the following elements:
>>
>> ModelElement
>> +owner:ModelElement (union)
>> +ownedElement:ModelElement (union)
>>
>> A : ModelElement
>> +theB :B (subsets +ownedElemend) -containment
>>
>> B : ModelElement
>> +theA:A (subsets +owner)
>>
>> and the Editor allows, to construct things like
>>
>> A
>> + B
>>
>> But the access fails with the message, that B is not a legal
>> value.
>>
>> It is wierd, because i thought, that the generator should
>> made use of the UML2-specific SupersetSubsetEList-Type, for
>> the subsetting properties (annotated as subsets), as it made
>> use of the DerivedUnionEList-Type for the EReferences,
>> annotated as Unions. But instead of, it uses the simple
>> Ecore-List-Type.
>>
>> After your last post, i've tried a lot with these annotations
>> ans the code generation for UML2. I'm confused right now,
>> because I'm pretty sure, that, in a former approach, the code
>> generator exactly has used this UML2-specific types. But now,
>> everytime i regenerate this simple model, it uses only the
>> EMF-specific one...
>>
>> I'm a bit frustrated currently, because i didn't get forward
>> with this problem...
>>
>> Timothy
>>
>> "Ed Merks" <Ed.Merks@gmail.com
>> <mailto:Ed.Merks@gmail.com>> schrieb im Newsbeitrag
>> news:gdhrs1$2du$1@build.eclipse.org...
>> Timothy,
>>
>> Comments below.
>>
>> Timothy Marc wrote:
>>> Ed,
>>>
>>> you were right. It was because of an invalid reference. However, this kind
>>> of reference was allowed by the generated editor. Currently, i'm playing a
>>> little bit with the UML2 codegenerator, in particular the
>>> Union/Subset-mechanism.
>>>
>> Hmmm. It should never allow you to construct an instance
>> that isn't sound. In fact, the underlying model simply
>> doesn't allow it, which is why the deserializer is
>> failing. Maybe you just had two objects with the same ID
>> or something else that the validator could notice if you
>> invoked it?
>>> Thx
>>> Timothy
>>> "Timothy Marc" <timothymarc@freenet.de> schrieb im Newsbeitrag
>>> news:gdhhid$rqj$1@build.eclipse.org...
>>>
>>>> Hey all,
>>>>
>>>> i've a problem when i try to load a resource programmatically. I think,
>>>> this is because of a missconfiguration of ResourceFactories, but i didn't
>>>> get it work.
>>>>
>>>> The genmodel settings uses the None as Resource Type. That works fine. But
>>>> when i try to load my model programmatically via the following snippet:
>>>>
>>>> final ResourceSet resourceSet = new ResourceSetImpl();
>>>> final Resource r = resourceSet.getResource(uri,true);
>>>> final TestingModel model = (TestingModel)r.getContents().get(0);
>>>>
>>>> it fails with the following exception:
>>>>
>>>> org.eclipse.emf.ecore.resource.impl.ResourceSetImpl$1Diagnos ticWrappedException:
>>>> org.eclipse.emf.ecore.xmi.IllegalValueException: Value
>>>> 'testing.impl.PackageImpl@1325aef (id: null, description: null, name:
>>>> pack)' is not legal.
>>>> (file:/D:/workspaces/esaWorkspace/testing.victoria/My.testin g, -1, -1)
>>>> at
>>>> org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.handleDe mandLoadException(ResourceSetImpl.java:316)
>>>> at
>>>> org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.demandLo adHelper(ResourceSetImpl.java:275)
>>>> at
>>>> org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.getResou rce(ResourceSetImpl.java:398)
>>>> at unit.UMLismTesting.test(UMLismTesting.java:28)
>>>> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>>>> at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
>>>> at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
>>>> at java.lang.reflect.Method.invoke(Unknown Source)
>>>> at
>>>> org.junit.internal.runners.TestMethodRunner.executeMethodBod y(TestMethodRunner.java:99)
>>>> at
>>>> org.junit.internal.runners.TestMethodRunner.runUnprotected(T estMethodRunner.java:81)
>>>> at
>>>> org.junit.internal.runners.BeforeAndAfterRunner.runProtected (BeforeAndAfterRunner.java:34)
>>>> at
>>>> org.junit.internal.runners.TestMethodRunner.runMethod(TestMe thodRunner.java:75)
>>>> at
>>>> org.junit.internal.runners.TestMethodRunner.run(TestMethodRu nner.java:45)
>>>> at
>>>> org.junit.internal.runners.TestClassMethodsRunner.invokeTest Method(TestClassMethodsRunner.java:66)
>>>> at
>>>> org.junit.internal.runners.TestClassMethodsRunner.run(TestCl assMethodsRunner.java:35)
>>>> at
>>>> org.junit.internal.runners.TestClassRunner$1.runUnprotected( TestClassRunner.java:42)
>>>> at
>>>> org.junit.internal.runners.BeforeAndAfterRunner.runProtected (BeforeAndAfterRunner.java:34)
>>>> at org.junit.internal.runners.TestClassRunner.run(TestClassRunn er.java:52)
>>>> at
>>>> org.eclipse.jdt.internal.junit4.runner.JUnit4TestReference.r un(JUnit4TestReference.java:38)
>>>> at
>>>> org.eclipse.jdt.internal.junit.runner.TestExecution.run(Test Execution.java:38)
>>>> at
>>>> org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTe sts(RemoteTestRunner.java:460)
>>>> at
>>>> org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTe sts(RemoteTestRunner.java:673)
>>>> at
>>>> org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(R emoteTestRunner.java:386)
>>>> at
>>>> org.eclipse.pde.internal.junit.runtime.RemotePluginTestRunne r.main(RemotePluginTestRunner.java:58)
>>>> at
>>>> org.eclipse.pde.internal.junit.runtime.CoreTestApplication.r un(CoreTestApplication.java:24)
>>>> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>>>> at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
>>>> at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
>>>> at java.lang.reflect.Method.invoke(Unknown Source)
>>>> at
>>>> org.eclipse.equinox.internal.app.EclipseAppContainer.callMet hod(EclipseAppContainer.java:572)
>>>> at
>>>> org.eclipse.equinox.internal.app.EclipseAppHandle.run(Eclips eAppHandle.java:171)
>>>> at
>>>> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:106)
>>>> at
>>>> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:76)
>>>> at
>>>> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:363)
>>>> at
>>>> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:176)
>>>> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>>>> at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
>>>> at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
>>>> at java.lang.reflect.Method.invoke(Unknown Source)
>>>> at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 508)
>>>> at org.eclipse.equinox.launcher.Main.basicRun(Main.java:447)
>>>> at org.eclipse.equinox.launcher.Main.run(Main.java:1173)
>>>> at org.eclipse.equinox.launcher.Main.main(Main.java:1148)
>>>> Caused by: org.eclipse.emf.ecore.xmi.IllegalValueException: Value
>>>> 'testing.impl.PackageImpl@1325aef (id: null, description: null, name:
>>>> pack)' is not legal.
>>>> (file:/D:/workspaces/esaWorkspace/testing.victoria/My.testin g, -1, -1)
>>>> at
>>>> org.eclipse.emf.ecore.xmi.impl.XMLHandler.setFeatureValue(XM LHandler.java:2535)
>>>> at
>>>> org.eclipse.emf.ecore.xmi.impl.XMLHandler.handleForwardRefer ences(XMLHandler.java:1098)
>>>> at
>>>> org.eclipse.emf.ecore.xmi.impl.XMLHandler.endDocument(XMLHan dler.java:1179)
>>>> at
>>>> com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser .endDocument(Unknown
>>>> Source)
>>>> at
>>>> com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentS cannerImpl.scanDocument(Unknown
>>>> Source)
>>>> at
>>>> com.sun.org.apache.xerces.internal.parsers.XML11Configuratio n.parse(Unknown
>>>> Source)
>>>> at
>>>> com.sun.org.apache.xerces.internal.parsers.XML11Configuratio n.parse(Unknown
>>>> Source)
>>>> at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(U nknown
>>>> Source)
>>>> at
>>>> com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser .parse(Unknown
>>>> Source)
>>>> at
>>>> com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSA XParser.parse(Unknown
>>>> Source)
>>>> at javax.xml.parsers.SAXParser.parse(Unknown Source)
>>>> at org.eclipse.emf.ecore.xmi.impl.XMLLoadImpl.load(XMLLoadImpl. java:179)
>>>> at
>>>> org.eclipse.emf.ecore.xmi.impl.XMLResourceImpl.doLoad(XMLRes ourceImpl.java:180)
>>>> at
>>>> org.eclipse.emf.ecore.resource.impl.ResourceImpl.load(Resour ceImpl.java:1354)
>>>> at
>>>> org.eclipse.emf.ecore.resource.impl.ResourceImpl.load(Resour ceImpl.java:1155)
>>>> at
>>>> org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.demandLo ad(ResourceSetImpl.java:256)
>>>> at
>>>> org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.demandLo adHelper(ResourceSetImpl.java:271)
>>>> ... 41 more
>>>> Caused by: java.lang.UnsupportedOperationException
>>>> at
>>>> org.eclipse.uml2.common.util.DerivedEObjectEList$DerivedList Iterator.add(DerivedEObjectEList.java:278)
>>>> at java.util.AbstractSequentialList.add(Unknown Source)
>>>> at
>>>> org.eclipse.uml2.common.util.DerivedEObjectEList.addUnique(D erivedEObjectEList.java:660)
>>>> at
>>>> org.eclipse.emf.ecore.xmi.impl.XMLHelperImpl.setValue(XMLHel perImpl.java:1179)
>>>> at
>>>> org.eclipse.emf.ecore.xmi.impl.XMLHandler.setFeatureValue(XM LHandler.java:2530)
>>>> ... 57 more
>>>>
>>>>
>>>> Can anyone help me? I think this is just a configuration issue, isnt' it?
>>>>
>>>> Thx
>>>> Timothy
>>>>
>>>>
>>>
>>>
>>>
>>

--------------020602040301090903040609
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
Timothy,<br>
<br>
These are really questions to direct to the UML2 newsgroup because I
just can't answer them from an EMF perspective.&nbsp; I'm not sure there is
any way in the IDE, given just an Ecore model, to create an instance of
UML's GenModel...<br>
<br>
<br>
Timothy Marc wrote:
<blockquote cite="mid:gdi1dj$b0v$1@build.eclipse.org" type="cite">
<title></title>
<meta http-equiv="Content-Type" content="text/html;charset=ISO-8859-1">
<meta content="MSHTML 6.00.2900.5659" name="GENERATOR">
<div><font face="Arial" size="2">But it is really strange, because
obviously, the DerivedUnionEObjectList-Type is used... so, why is this
Liste-Type used, but not the SubsetSuperset-one?</font></div>
<blockquote dir="ltr"
style="border-left: 2px solid rgb(0, 0, 0); padding-right: 0px; padding-left: 5px; margin-left: 5px; margin-right: 0px;">
<div>"Timothy Marc" &lt;<a moz-do-not-send="true"
href="mailto:timothymarc@freenet.de">timothymarc@freenet.de</a>&gt;
schrieb im Newsbeitrag <a moz-do-not-send="true"
href="news:gdi15h$9re$1@build.eclipse.org">news:gdi15h$9re$1@build.eclipse.org</a>...</div>
<div><font face="Arial" size="2">Okay, and how can i use it
explicitly. I didn't found any tutorial for it. Do you know some?</font></div>
<blockquote dir="ltr"
style="border-left: 2px solid rgb(0, 0, 0); padding-right: 0px; padding-left: 5px; margin-left: 5px; margin-right: 0px;">
<div>"Ed Merks" &lt;<a moz-do-not-send="true"
href="mailto:Ed.Merks@gmail.com">Ed.Merks@gmail.com</a>&gt; schrieb im
Newsbeitrag <a moz-do-not-send="true"
href="news:gdi10t$5nk$1@build.eclipse.org">news:gdi10t$5nk$1@build.eclipse.org</a>...</div>
Timothy,<br>
<br>
In order to generate the right things, you really have to be using
UML's extended GenModel, which you'll only get if you specify your
model using UML2 and import it.&nbsp;&nbsp; So it's not sufficient just to have
an Ecore model with annotations just like the ones UML produces, you
have to be using UML's extended GenModel for those annotations to be
recognized...<br>
<br>
<br>
Timothy Marc wrote:
<blockquote cite="mid:gdi0f1$vn8$1@build.eclipse.org" type="cite">
<meta content="MSHTML 6.00.2900.5659" name="GENERATOR">
<style></style>
<div><font face="Arial" size="2">Ed,</font></div>
<div>&nbsp;</div>
<div><font face="Arial" size="2">i've tried it with a reall
simple model. It consists only of the following elements:</font></div>
<div>&nbsp;</div>
<div><font face="Arial" size="2">ModelElement</font></div>
<div><font face="Arial" size="2">&nbsp;&nbsp;&nbsp; +owner:ModelElement (union)</font></div>
<div><font face="Arial" size="2">&nbsp;&nbsp;&nbsp; +ownedElement:ModelElement
(union)</font></div>
<div>&nbsp;</div>
<div><font face="Arial" size="2">A : ModelElement</font></div>
<div><font face="Arial" size="2">&nbsp;&nbsp;&nbsp; +theB :B (subsets
+ownedElemend) -containment</font></div>
<div>&nbsp;</div>
<div><font face="Arial" size="2">B : ModelElement</font></div>
<div><font face="Arial" size="2">&nbsp;&nbsp;&nbsp; +theA:A (subsets +owner)</font></div>
<div>&nbsp;</div>
<div><font face="Arial" size="2">and the Editor allows, to
construct things like </font></div>
<div>&nbsp;</div>
<div><font face="Arial" size="2">&nbsp;&nbsp;&nbsp; A</font></div>
<div><font face="Arial" size="2">&nbsp;&nbsp;&nbsp;&nbsp;+ B</font></div>
<div>&nbsp;</div>
<div><font face="Arial" size="2">But the access fails with the
message, that B is not a legal value.</font></div>
<div>&nbsp;</div>
<div><font face="Arial" size="2">It is wierd, because i
thought, that the generator should made use of the UML2-specific
SupersetSubsetEList-Type, for the subsetting properties (annotated as
subsets), as it made use of the DerivedUnionEList-Type for the
EReferences, annotated as Unions. But instead of, it uses the simple
Ecore-List-Type.</font></div>
<div>&nbsp;</div>
<div><font face="Arial" size="2">After your last post, i've
tried a lot with these annotations ans the code generation for UML2.
I'm confused right now, because I'm pretty sure, that, in a former
approach, the code generator exactly has used this UML2-specific types.
But now, everytime i regenerate this simple model, it uses only the
EMF-specific one...</font></div>
<div>&nbsp;</div>
<div><font face="Arial" size="2">I'm a bit frustrated
currently, because i didn't get forward with this problem...</font></div>
<div>&nbsp;</div>
<div><font face="Arial" size="2">Timothy</font></div>
<blockquote dir="ltr"
style="border-left: 2px solid rgb(0, 0, 0); padding-right: 0px; padding-left: 5px; margin-left: 5px; margin-right: 0px;">
<div>"Ed Merks" &lt;<a href="mailto:Ed.Merks@gmail.com"
moz-do-not-send="true">Ed.Merks@gmail.com</a>&gt; schrieb im
Newsbeitrag <a href="news:gdhrs1$2du$1@build.eclipse.org"
moz-do-not-send="true">news:gdhrs1$2du$1@build.eclipse.org</a>...</div>
Timothy,<br>
<br>
Comments below.<br>
<br>
Timothy Marc wrote:
<blockquote cite="mid:gdhr0p$v5v$1@build.eclipse.org"
type="cite">
<pre wrap="">Ed,

you were right. It was because of an invalid reference. However, this kind
of reference was allowed by the generated editor. Currently, i'm playing a
little bit with the UML2 codegenerator, in particular the
Union/Subset-mechanism.
</pre>
</blockquote>
Hmmm.&nbsp; It should never allow you to construct an instance that isn't
sound.&nbsp;&nbsp; In fact, the underlying model simply doesn't allow it, which
is why the deserializer is failing.&nbsp; Maybe you just had two objects
with the same ID or something else that the validator could notice if
you invoked it?<br>
<blockquote cite="mid:gdhr0p$v5v$1@build.eclipse.org"
type="cite">
<pre wrap="">Thx
Timothy
"Timothy Marc" <a class="moz-txt-link-rfc2396E"
href="mailto:timothymarc@freenet.de" moz-do-not-send="true">&lt;timothymarc@freenet.de&gt;</a> schrieb im Newsbeitrag
<a class="moz-txt-link-freetext"
href="news:gdhhid$rqj$1@build.eclipse.org" moz-do-not-send="true">news:gdhhid$rqj$1@build.eclipse.org</a>...
</pre>
<blockquote type="cite">
<pre wrap="">Hey all,

i've a problem when i try to load a resource programmatically. I think,
this is because of a missconfiguration of ResourceFactories, but i didn't
get it work.

The genmodel settings uses the None as Resource Type. That works fine. But
when i try to load my model programmatically via the following snippet:

final ResourceSet resourceSet = new ResourceSetImpl();
final Resource r = resourceSet.getResource(uri,true);
final TestingModel model = (TestingModel)r.getContents().get(0);

it fails with the following exception:

org.eclipse.emf.ecore.resource.impl.ResourceSetImpl$1Diagnos ticWrappedException:
org.eclipse.emf.ecore.xmi.IllegalValueException: Value
'testing.impl.PackageImpl@1325aef (id: null, description: null, name:
pack)' is not legal.
(<a class="moz-txt-link-freetext"
href=" file:/D:/workspaces/esaWorkspace/testing.victoria/My.testing "
moz-do-not-send="true"> file:/D:/workspaces/esaWorkspace/testing.victoria/My.testing </a>, -1, -1)
at
org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.handleDe mandLoadException(ResourceSetImpl.java:316)
at
org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.demandLo adHelper(ResourceSetImpl.java:275)
at
org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.getResou rce(ResourceSetImpl.java:398)
at unit.UMLismTesting.test(UMLismTesting.java:28)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at
org.junit.internal.runners.TestMethodRunner.executeMethodBod y(TestMethodRunner.java:99)
at
org.junit.internal.runners.TestMethodRunner.runUnprotected(T estMethodRunner.java:81)
at
org.junit.internal.runners.BeforeAndAfterRunner.runProtected (BeforeAndAfterRunner.java:34)
at
org.junit.internal.runners.TestMethodRunner.runMethod(TestMe thodRunner.java:75)
at
org.junit.internal.runners.TestMethodRunner.run(TestMethodRu nner.java:45)
at
org.junit.internal.runners.TestClassMethodsRunner.invokeTest Method(TestClassMethodsRunner.java:66)
at
org.junit.internal.runners.TestClassMethodsRunner.run(TestCl assMethodsRunner.java:35)
at
org.junit.internal.runners.TestClassRunner$1.runUnprotected( TestClassRunner.java:42)
at
org.junit.internal.runners.BeforeAndAfterRunner.runProtected (BeforeAndAfterRunner.java:34)
at org.junit.internal.runners.TestClassRunner.run(TestClassRunn er.java:52)
at
org.eclipse.jdt.internal.junit4.runner.JUnit4TestReference.r un(JUnit4TestReference.java:38)
at
org.eclipse.jdt.internal.junit.runner.TestExecution.run(Test Execution.java:38)
at
org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTe sts(RemoteTestRunner.java:460)
at
org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTe sts(RemoteTestRunner.java:673)
at
org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(R emoteTestRunner.java:386)
at
org.eclipse.pde.internal.junit.runtime.RemotePluginTestRunne r.main(RemotePluginTestRunner.java:58)
at
org.eclipse.pde.internal.junit.runtime.CoreTestApplication.r un(CoreTestApplication.java:24)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at
org.eclipse.equinox.internal.app.EclipseAppContainer.callMet hod(EclipseAppContainer.java:572)
at
org.eclipse.equinox.internal.app.EclipseAppHandle.run(Eclips eAppHandle.java:171)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:106)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:76)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:363)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:176)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 508)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:447)
at org.eclipse.equinox.launcher.Main.run(Main.java:1173)
at org.eclipse.equinox.launcher.Main.main(Main.java:1148)
Caused by: org.eclipse.emf.ecore.xmi.IllegalValueException: Value
'testing.impl.PackageImpl@1325aef (id: null, description: null, name:
pack)' is not legal.
(<a class="moz-txt-link-freetext"
href=" file:/D:/workspaces/esaWorkspace/testing.victoria/My.testing "
moz-do-not-send="true"> file:/D:/workspaces/esaWorkspace/testing.victoria/My.testing </a>, -1, -1)
at
org.eclipse.emf.ecore.xmi.impl.XMLHandler.setFeatureValue(XM LHandler.java:2535)
at
org.eclipse.emf.ecore.xmi.impl.XMLHandler.handleForwardRefer ences(XMLHandler.java:1098)
at
org.eclipse.emf.ecore.xmi.impl.XMLHandler.endDocument(XMLHan dler.java:1179)
at
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser .endDocument(Unknown
Source)
at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentS cannerImpl.scanDocument(Unknown
Source)
at
com.sun.org.apache.xerces.internal.parsers.XML11Configuratio n.parse(Unknown
Source)
at
com.sun.org.apache.xerces.internal.parsers.XML11Configuratio n.parse(Unknown
Source)
at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(U nknown
Source)
at
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser .parse(Unknown
Source)
at
com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSA XParser.parse(Unknown
Source)
at javax.xml.parsers.SAXParser.parse(Unknown Source)
at org.eclipse.emf.ecore.xmi.impl.XMLLoadImpl.load(XMLLoadImpl. java:179)
at
org.eclipse.emf.ecore.xmi.impl.XMLResourceImpl.doLoad(XMLRes ourceImpl.java:180)
at
org.eclipse.emf.ecore.resource.impl.ResourceImpl.load(Resour ceImpl.java:1354)
at
org.eclipse.emf.ecore.resource.impl.ResourceImpl.load(Resour ceImpl.java:1155)
at
org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.demandLo ad(ResourceSetImpl.java:256)
at
org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.demandLo adHelper(ResourceSetImpl.java:271)
.... 41 more
Caused by: java.lang.UnsupportedOperationException
at
org.eclipse.uml2.common.util.DerivedEObjectEList$DerivedList Iterator.add(DerivedEObjectEList.java:278)
at java.util.AbstractSequentialList.add(Unknown Source)
at
org.eclipse.uml2.common.util.DerivedEObjectEList.addUnique(D erivedEObjectEList.java:660)
at
org.eclipse.emf.ecore.xmi.impl.XMLHelperImpl.setValue(XMLHel perImpl.java:1179)
at
org.eclipse.emf.ecore.xmi.impl.XMLHandler.setFeatureValue(XM LHandler.java:2530)
.... 57 more


Can anyone help me? I think this is just a configuration issue, isnt' it?

Thx
Timothy

</pre>
</blockquote>
<pre wrap=""><!---->

</pre>
</blockquote>
</blockquote>
</blockquote>
</blockquote>
</blockquote>
</blockquote>
</body>
</html>

--------------020602040301090903040609--
Previous Topic:Getting Enumeration literals, DataType on Property
Next Topic:Using UML2 mechanism
Goto Forum:
  


Current Time: Sun Apr 05 18:06:27 GMT 2020

Powered by FUDForum. Page generated in 0.01825 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top