Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 » Code assist for uml2 packages doesn't work
Code assist for uml2 packages doesn't work [message #626797] Wed, 16 July 2008 06:26
alfred schnabel is currently offline alfred schnabelFriend
Messages: 2
Registered: July 2009
Junior Member
Hi e/m/m/u

I can't get eclipse code assist to work for the org.eclipse.uml2 packages.
I know, this might be the wrong place to ask this, but since I'm having
this problem only with the MDT packages I hope someone in this group can
help me. I installed MDT UML2 via Help->Software Updates... and then
referenced all jars named org.eclipse.uml2.??? in my project. I then
created an empty StateMachine, by invoking
UMLFactory.eINSTANCE.createStateMachine(). The code compiles, thus the jar
references seem to work. Nevertheless if I type UMLFactory.eINSTANCE. and
then press Ctrl-Space for code assist, I get no default proposals, but a
message that no completions are available. Code assist works fine for
other external jars, like JUnit... I really hope someone can help me along
here, cause working without code assist feels like driving with sunglasses
at night.

So long,
Alfred
Previous Topic:[Eclipse e EA 7.1]->how use eaapi.jar library?
Next Topic:Code generator problem with redefinitions
Goto Forum:
  


Current Time: Wed Sep 19 18:44:37 GMT 2018

Powered by FUDForum. Page generated in 0.01160 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top