Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 » CMOF primitive type references
CMOF primitive type references [message #625781] Wed, 26 December 2007 17:35
Dave Carlson is currently offline Dave CarlsonFriend
Messages: 402
Registered: July 2009
Senior Member
When opening a .cmof model in the UML editor, or generating Ecore from cmof,
what URIs should be used for primitive type references? In the latest SBVR
cmof model from OMG, the primtive types are defined as:

http://schema.omg.org/spec/UML/2.0/uml.xml#Boolean

These are not resolved when opening or transforming the model and the
resulting types are null. I also believe that this is an error in the SBVR
cmof model; it should not refer to the UML metamodel. So, I looked at the
format used when an .ecore model is saved to EMOF, and this type of
primitive URI is used:

http://schema.omg.org/spec/mof/2.0/emof.xmi#Boolean

So, I would expect that this should be the correct format used in CMOF:

http://schema.omg.org/spec/mof/2.0/cmof.xmi#Boolean

But the current resource loader for .cmof does not recognize this.
As a current workaround, I changed the cmof file to use primitive URIs like
this:

pathmap://UML_LIBRARIES/UMLPrimitiveTypes.library.uml#Boolea n
Previous Topic:Generate UML - class diagram
Next Topic:Transforming UML associations to Ecore
Goto Forum:
  


Current Time: Mon Aug 08 22:02:03 GMT 2022

Powered by FUDForum. Page generated in 0.02335 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top