Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 Tools » Generating UML2Tools diagram: org/eclipse/gmf/gmfgraph/LayoutRef
Generating UML2Tools diagram: org/eclipse/gmf/gmfgraph/LayoutRef [message #622590] Thu, 07 August 2008 15:21
Niels Brouwers is currently offline Niels BrouwersFriend
Messages: 79
Registered: July 2009
Hi all,

as one might have guessed from my previous post, I am trying to customize
an UML2Tools class diagram to better suit our needs. Currently, I am/was
at the point that I could generate my own version of the diagram in a
different plugin. What I did to come this way is:

- import org.eclipse.uml2.diagram.def as source project
- import org.eclipse.uml2.diagram.clazz as source project
- copied GMF models class.gmftool, class.gmfmap, class.gmfgen, class.trace
within the org.eclipse.uml2.diagram.def project and renamed them to
- refactored org.eclipse.uml2.diagram.clazz project to my.diagram.structure
- opened structureDiagram.gmfmap with a text editor and renamed each
occurrence of class.gmftool to structureDiagram.gmftool
- opened structureDiagram.gmfgen with a text editor and renamed each
occurrence of org.eclipse.uml2.diagram.clazz with my.diagram.structure
- generated the UML2Tools diagram from structureDiagram.gmfgen
- modified to contain customized strings

Tested the plugin by running it as an eclipse application (after editing
the code a bit to remove an error). All worked OK!

Now, obviously I ran into an error otherwise I wouldn't be writing this
message now ;-)

I adapted the pallette of my diagram to include a Component in the
palette. Furthermore, I added a group containing some Creation Tools.
That's all ....

Now the problem is that I can not generate the gmfgen model from the
gmfmap model. When I press 'Finish' at the final step of the 'Create
Generator Model' wizard (just after I set the location of the dynamic
templates), the following error appears in the white area just below
'Specify Transformation Options' text:

That is the only error message I get. When I press 'Finish', the
generation is not started and the error still remains to appear.

Can someone please advice on this problem?

Thank you in advance!

Kind regards,
Niels Brouwers.

Kind regards,
Niels Brouwers.
Previous Topic:Problem while re-generating UML2Tools clazz diagram
Next Topic:Generating UML2Tools diagram: org/eclipse/gmf/gmfgraph/LayoutRef
Goto Forum:

Current Time: Wed Oct 24 05:24:27 GMT 2018

Powered by FUDForum. Page generated in 0.02171 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top