|[MWE] Core requiring earlier version of apache commons? [message #621557]
||Thu, 05 November 2009 20:12
| Miles Parker
Registered: July 2009
Something weird seems to be going wrong with MWE P2 setup but I'm not sure and unfortunately I don't have time at the moment to confirm, but I think its worth mentioning in case someone else also has issues. (I can file a quick bug report is you'd like.) This might have slipped under the radar because people are usually updating from 0.7.2. But on my install when I try to go directly to 0.8.0 I get the following:|
Cannot complete the install because one or more required items could not be found.
Software being installed: MWE Core (Incubation) 0.7.2.v200908101326 (org.eclipse.emf.mwe.core.feature.group 0.7.2.v200908101326)
Missing requirement: MWE Core (Incubation) 0.7.2.v200908101326 (org.eclipse.emf.mwe.core.feature.group 0.7.2.v200908101326) requires 'org.apache.commons.lang [2.1.0.v200803061811]' but it could not be found
This means that all of xtext, xpand etc.. won't install either.. :( If I install 0.7.2 first and then 0.8.0 things work correctly so that's a fine work-around.
It looks like perhaps MWE has a specific requirement for 2.1.0 somewhere. Is that necessary? Is it possible that some plugins are using required-bundle for commons.lang rather than import-package?
Powered by FUDForum
. Page generated in 0.02178 seconds