Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » Collide ID validation error
Collide ID validation error [message #619270] Fri, 20 June 2008 19:06
Yigal Spinner is currently offline Yigal SpinnerFriend
Messages: 109
Registered: July 2009
Senior Member
I’m getting the following diagnostic error while saving the resource via
TENEO:

Diagnosis of
com.accenture.tools.sd.model.domain.impl.WindowImpl@14ad296{ hibernate://?dsname=yigal_db&query1=
from Window where entityname='WINTST2'#Window|id=95}

The ID '35' of
'com.accenture.tools.sd.model.domain.impl.EntityDescriptionI mpl @e6529c{hibernate://?dsname=yigal_db&query1=
from Window where entityname='WINTST2'#EntityDescription|id=35}'
collides with that of
' com.accenture.tools.sd.model.domain.impl.ToolResourceRegistr yImpl@d9783e{hibernate://?dsname=yigal_db&query1=
from Window where entityname='WINTST2'#ToolResourceRegistry|id=35}'

It seems that there is a conflict between IDs on different classes that
are different tables.

I do not understand why all of a sudden I have ID conflict? (we did
convert a different data set to see this issue, it does not happen with
the dataset from Assembly test).

If I have Window class that has an attribute called “WinIdKey” and it is
marked in the eCore as ID=true.

The Window class references two other classes:
1. ToolResourceRegistry (trrIdKey attribute with ID=true) and
2. EntityDescription (descIdKey attribute with ID=true)
all the ID attributes have a different name.

Why is there a conflict?


Thanks
Yigal
Previous Topic:[Teneo + GMF] Diagram and model element handling
Next Topic:Collide ID validation error
Goto Forum:
  


Current Time: Sat Apr 04 16:32:13 GMT 2020

Powered by FUDForum. Page generated in 0.02139 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top