Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » M2M (model-to-model transformation) » Re: Help with .ecore files, please
Re: Help with .ecore files, please [message #62339] Tue, 25 September 2007 12:20 Go to next message
Eclipse UserFriend
Originally posted by: merks.ca.ibm.com

This is a multi-part message in MIME format.
--------------030004000603030805070601
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit

Jesus,

You should use the m2m newsgroup for ATL questions:

news://news.eclipse.org/eclipse.modeling.m2m

I've added it to the "to" list of the reply so no need to repost your
question.


Jesus wrote:
> Hello all,
>
> I do not know if this is the right place to post this kind of things here but I will try:
>
> I am trying a simple ATL example (based on EMF) found on the Internet but I have a little problem. I am working with Eclipse and have two .ecore files 'Author.ecore' and 'Person.ecore' representing each of them two different objects (Each of them has two string attributes: name and surname). Then I create a authors.ecore file in order to create several authors. I do this this way:
>
> <?xml version="1.0" encoding="ISO-8859-1"?>
> <xmi:XMI xmi:version="2.0" xmlns:xmi="http://www.omg.org/XMI" xmlns="Author">
> <Author name="David" surname="Touzet"/>
> <Author name="Freddy" surname="Allilaire"/>
> </xmi:XMI>
>
> But Eclipse notifies me that there are several errors:
>
> 1. ClassNotFoundException: Class 'Author' not found. (platform:/resource/Author2Person/authors.ecore, 3, 41) Author2Person authors.ecore line 3, column 41 1190570785125 21
>
> 2. ClassNotFoundException: Class 'Author' not found. (platform:/resource/Author2Person/authors.ecore, 4, 45) Author2Person authors.ecore line 4, column 45 1190570785125 23
>
> 3. PackageNotFoundException: Package with uri 'Author' not found. (platform:/resource/Author2Person/authors.ecore, 3, 41) Author2Person authors.ecore line 3, column 41 1190570785109 20
>
> 4. PackageNotFoundException: Package with uri 'Author' not found. (platform:/resource/Author2Person/authors.ecore, 4, 45) Author2Person authors.ecore line 4, column 45 1190570785125 22
>
> Does anybody know what can be happening here?
>
> Thank you very much.
>


--------------030004000603030805070601
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
Jesus,<br>
<br>
You should use the m2m newsgroup for ATL questions:&nbsp; <br>
<blockquote><a href="news://news.eclipse.org/eclipse.modeling.m2m">news://news.eclipse.org/eclipse.modeling.m2m</a><br>
</blockquote>
I've added it to the "to" list of the reply so no need to repost your
question.<br>
<br>
<br>
Jesus wrote:
<blockquote
cite="mid:1061550264.45441190712991899.JavaMail.root@cp9.dzone.com"
type="cite">
<pre wrap="">Hello all,

I do not know if this is the right place to post this kind of things here but I will try:

I am trying a simple ATL example (based on EMF) found on the Internet but I have a little problem. I am working with Eclipse and have two .ecore files 'Author.ecore' and 'Person.ecore' representing each of them two different objects (Each of them has two string attributes: name and surname). Then I create a authors.ecore file in order to create several authors. I do this this way:

&lt;?xml version="1.0" encoding="ISO-8859-1"?&gt;
&lt;xmi:XMI xmi:version="2.0" xmlns:xmi=<a class="moz-txt-link-rfc2396E" href="http://www.omg.org/XMI">"http://www.omg.org/XMI"</a> xmlns="Author"&gt;
&lt;Author name="David" surname="Touzet"/&gt;
&lt;Author name="Freddy" surname="Allilaire"/&gt;
&lt;/xmi:XMI&gt;

But Eclipse notifies me that there are several errors:

1. ClassNotFoundException: Class 'Author' not found. (platform:/resource/Author2Person/authors.ecore, 3, 41) Author2Person authors.ecore line 3, column 41 1190570785125 21

2. ClassNotFoundException: Class 'Author' not found. (platform:/resource/Author2Person/authors.ecore, 4, 45) Author2Person authors.ecore line 4, column 45 1190570785125 23

3. PackageNotFoundException: Package with uri 'Author' not found. (platform:/resource/Author2Person/authors.ecore, 3, 41) Author2Person authors.ecore line 3, column 41 1190570785109 20

4. PackageNotFoundException: Package with uri 'Author' not found. (platform:/resource/Author2Person/authors.ecore, 4, 45) Author2Person authors.ecore line 4, column 45 1190570785125 22

Does anybody know what can be happening here?

Thank you very much.
</pre>
</blockquote>
<br>
</body>
</html>

--------------030004000603030805070601--
Re: Help with .ecore files, please [message #62387 is a reply to message #62339] Tue, 25 September 2007 12:41 Go to previous message
Eclipse UserFriend
Originally posted by: r.c.ladan.tue.nl

> Jesus wrote:
>> Hello all,
>>
>> I am trying a simple ATL example (based on EMF) found on the Internet but I have a little problem. I am working with Eclipse and have two .ecore files 'Author.ecore' and 'Person.ecore' representing each of them two different objects (Each of them has two string attributes: name and surname). Then I create a authors.ecore file in order to create several authors. I do this this way:
>>
>> <?xml version="1.0" encoding="ISO-8859-1"?>
>> <xmi:XMI xmi:version="2.0" xmlns:xmi="http://www.omg.org/XMI" xmlns="Author">
>> <Author name="David" surname="Touzet"/>
>> <Author name="Freddy" surname="Allilaire"/>
>> </xmi:XMI>
>>
>> But Eclipse notifies me that there are several errors:
>>
>> 1. ClassNotFoundException: Class 'Author' not found. (platform:/resource/Author2Person/authors.ecore, 3, 41) Author2Person authors.ecore line 3, column 41 1190570785125 21
>>
>> 2. ClassNotFoundException: Class 'Author' not found. (platform:/resource/Author2Person/authors.ecore, 4, 45) Author2Person authors.ecore line 4, column 45 1190570785125 23
>>
>> 3. PackageNotFoundException: Package with uri 'Author' not found. (platform:/resource/Author2Person/authors.ecore, 3, 41) Author2Person authors.ecore line 3, column 41 1190570785109 20
>>
>> 4. PackageNotFoundException: Package with uri 'Author' not found. (platform:/resource/Author2Person/authors.ecore, 4, 45) Author2Person authors.ecore line 4, column 45 1190570785125 22
>>
>> Does anybody know what can be happening here?
>

Did you right-click on the two .ecore files and choose the "Register Ecore model" option for them?
This way Eclipse 'learns' your model. You'll have to do this each time you start Eclipse.

HTH,
Rene
Previous Topic:Re: 'EStructuralFeature' is not a valid classifier
Next Topic:Adding operation to ATL VM
Goto Forum:
  


Current Time: Sun Apr 11 20:46:33 GMT 2021

Powered by FUDForum. Page generated in 0.02212 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top