Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » Problem with GenericGenerator annotation
Problem with GenericGenerator annotation [message #616022] Fri, 28 March 2008 09:14
Manfred Hahn is currently offline Manfred HahnFriend
Messages: 64
Registered: July 2009
Member
Hi Martin,

first I want to thank you for the hint with the @Basic annotation.

But now I need help with another annotation.
I like to have my ids generated with the hibernate uuid generator.
So I made an annotation to the property I also marked as id:

<eStructuralFeatures xsi:type="ecore:EAttribute" name="logicKey"
eType="ecore:EDataType http://www.eclipse.org/emf/2002/Ecore#//EString"
iD="true">
<eAnnotations source="teneo.jpa">
<details key="appinfo"
value="@GenericGenerator(name=&quot;uuidgen&quot;
strategy=&quot;uuid&quot;) "/>
</eAnnotations>
</eStructuralFeatures>

During the mapping generation the following error occurs:

org.eclipse.emf.teneo.annotations.parser.AnnotationParserExc eption: The
eclass: HbAnnotatedEAttribute does not have an efeature for
GenericGenerator
at
org.eclipse.emf.teneo.annotations.parser.EAnnotationParserIm porter.processAnnotatedModelElement(EAnnotationParserImporte r.java:130)

The error message says that I have put the annotation at the wrong place,
but where do I have to put it? I've tried the class itself, but an
equivalent error occured.

Can you help me once more?

greetings
Manfred
Previous Topic:Nullable does not work
Next Topic:Problem with GenericGenerator annotation
Goto Forum:
  


Current Time: Tue Jun 22 02:23:23 GMT 2021

Powered by FUDForum. Page generated in 0.01853 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top