Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » PDE Headless Build doesn't work with feature
PDE Headless Build doesn't work with feature [message #604522] Mon, 08 February 2010 11:08 Go to next message
Jan Krakora is currently offline Jan KrakoraFriend
Messages: 477
Registered: December 2009
Location: Prague
Senior Member
Hi guys,

I have 2 projects in my workspace. The first project is a plug-in with RCP behaviors (it includes a class implemented IApplication...) and it contains the product configuration file too.

The second project is a simple feature project, which includes the plug-in above.

Now, my problem:

When I set "The product configuration is based on plug-ins" in my product configuration file and start the Product
export wizard, then all goes well.
But if I set "The product configuration is based on features" in my product configuration file and start the Product export wizard, the deployed folder is only 300kB big and "plug-ins" folder doesn't contain any of 40 plug-ins, which my plug-in depends on.

Please help
Re: PDE Headless Build doesn't work with feature [message #604526 is a reply to message #604522] Mon, 08 February 2010 13:11 Go to previous message
Mickael Istria is currently offline Mickael IstriaFriend
Messages: 851
Registered: July 2009
Location: Grenoble, France
Senior Member

Hello,

When using a feature-based product build, your features must contain everything your product depends on. It defines the distribution.
A good but difficult way of managing feature-based build is to have 1 feature that contains your plug-ins, with dependencies defined in the dedicated tab; and one feature containing the dependency of your feature (and also the org.eclipse.rcp feature).

The difficulty is to define the right list of dependencies in the dependency feature...

behnil@centrum.cz a écrit :
> Hi guys,
>
> I have 2 projects in my workspace. The first project is a plug-in with
> RCP behaviors (it includes a class implemented IApplication...) and it
> contains the product configuration file too.
> The second project is a simple feature project, which includes the
> plug-in above.
>
> Now, my problem:
>
> When I set "The product configuration is based on plug-ins" in my
> product configuration file and start the Product export wizard, then all
> goes well. But if I set "The product configuration is based on
> features" in my product configuration file and start the Product export
> wizard, the deployed folder is only 300kB big and "plug-ins" folder
> doesn't contain any of 40 plug-ins, which my plug-in depends on.
>
> Please help
>

--
Mickael Istria - BonitaSoft S.A.
http://www.bonitasoft.com/products/downloads.php
Previous Topic:PDE Headless Build doesn't work with feature
Next Topic:project type / nature
Goto Forum:
  


Current Time: Fri Aug 07 22:21:34 GMT 2020

Powered by FUDForum. Page generated in 0.02123 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top