Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » NoClassDefFoundError on startup
NoClassDefFoundError on startup [message #61134] Tue, 12 May 2009 15:31 Go to next message
Matt Sither is currently offline Matt SitherFriend
Messages: 33
Registered: July 2009
Member
I recently upgarded to a new version of eclipse (3.5M6), and I was initially
able to use my existing Run/Debug configurations. But now (I have no idea
what changed between yesterday and today) I get a BundleException that says
my activator is invalid, caused by a NoClassDefFoundError. I checked the
run config by clicking "Add Required Plug-ins" and "Validate Plug-ins", and
no problems are detected. I had been trying to upgrade to 3.5M7 but ran
into issues manually dropping in the log4j plug-in, so I reverted back to
M6, and there's a chance there might be some M7 plugin(s) lingering. Could
that cause the error I'm seeing? Should I just wipe the slate clean and
start installing M6 all over again?

Thanks.
Re: NoClassDefFoundError on startup [message #61350 is a reply to message #61134] Wed, 13 May 2009 04:17 Go to previous messageGo to next message
Chris Aniszczyk is currently offline Chris AniszczykFriend
Messages: 674
Registered: July 2009
Senior Member
Sither wrote:
> I recently upgarded to a new version of eclipse (3.5M6), and I was
> initially able to use my existing Run/Debug configurations. But now (I
> have no idea what changed between yesterday and today) I get a
> BundleException that says my activator is invalid, caused by a
> NoClassDefFoundError. I checked the run config by clicking "Add
> Required Plug-ins" and "Validate Plug-ins", and no problems are
> detected. I had been trying to upgrade to 3.5M7 but ran into issues
> manually dropping in the log4j plug-in, so I reverted back to M6, and
> there's a chance there might be some M7 plugin(s) lingering. Could that
> cause the error I'm seeing? Should I just wipe the slate clean and
> start installing M6 all over again?

If you're activator is invalid, it could be a sign of some other
problems. I would use 3.5 M7 as that's a better bet than M6 imho.

Can you tell us more about the exception?

Before starting clean slate with M7, I would create a brand new launch
configuration, make sure that the workspace is cleared and the
configuration area in the launch config (check the 'Configuration' tab
for the checky box)

Cheers,

Chris Aniszczyk | EclipseSource Austin | +1 860 839 2465
http://twitter.com/eclipsesource | http://twitter.com/caniszczyk
Re: NoClassDefFoundError on startup [message #61444 is a reply to message #61350] Wed, 13 May 2009 15:45 Go to previous messageGo to next message
Matt Sither is currently offline Matt SitherFriend
Messages: 33
Registered: July 2009
Member
Thanks Chris. I tried deleting all of my launch configurations and then
creating a new one with the Clear checkbox selected in both the Main tab and
the Configuration tab. Also, I don't know if it matters, but I tried both
"Run a product" and "Run an application" under Main > Program to Run. Under
Java Runtime Environment, I have Runtime JRE selected and pointed at jdk
1.6.0_12. Running under this configuration, I still get the error (see
below). Let me know if I can provide you with any other relevant
information about my environment.

On a semi-related note, I tried starting over with a fresh 3.5 M7, and for
some reason it doesn't load most of the eclipse plug-ins (for example, the
Plug-ins view doesn't show org.eclipse.core.runtime or org.eclipse.swt).
Oddly enough, those plug-ins do show up in the Plug-ins Registry view. I
apologize for my ignorance here. I'm not clear on exactly how plug-ins are
loaded or what the difference is between the Plug-ins view and Plug-ins
Registry view.


!SESSION 2009-05-13
11:39:55.653 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_12
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Framework arguments: -application com.etm.application
Command-line arguments: -application com.etm.application -data
C:\Users\sither\workspace/../runtime-com.etm.ui.product -dev
file:C:/Users/sither/workspace/.metadata/.plugins/org.eclips e.pde.core/com.etm.ui.product/dev.properties -
debug
C:\Users\sither\workspace\.metadata\.plugins\org.eclipse.pde .core\com.etm.ui.product/.options
-os win32 -ws win32 -arch x86

!ENTRY org.eclipse.osgi 2 0 2009-05-13 11:40:06.471
!MESSAGE The activator com.etm.EtmUIPlugin for bundle com.etm.ui is invalid
!STACK 0
org.osgi.framework.BundleException: The activator com.etm.EtmUIPlugin for
bundle com.etm.ui is invalid
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.load BundleActivator(AbstractBundle.java:157)
at
org.eclipse.osgi.framework.internal.core.BundleContextImpl.s tart(BundleContextImpl.java:750)
at
org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:352)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.star t(AbstractBundle.java:280)
at
org.eclipse.osgi.framework.util.SecureAction.start(SecureAct ion.java:408)
at
org.eclipse.osgi.framework.internal.core.BundleHost.loadClas s(BundleHost.java:238)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.load Class(AbstractBundle.java:1193)
at
org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI .createExecutableExtension(RegistryStrategyOSGI.java:160)
at
org.eclipse.core.internal.registry.ExtensionRegistry.createE xecutableExtension(ExtensionRegistry.java:874)
at
org.eclipse.core.internal.registry.ConfigurationElement.crea teExecutableExtension(ConfigurationElement.java:243)
at
org.eclipse.core.internal.registry.ConfigurationElementHandl e.createExecutableExtension(ConfigurationElementHandle.java: 51)
at
org.eclipse.equinox.internal.app.EclipseAppHandle.run(Eclips eAppHandle.java:189)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:110)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:79)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:368)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 559)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
at org.eclipse.equinox.launcher.Main.run(Main.java:1311)
at org.eclipse.equinox.launcher.Main.main(Main.java:1287)
Caused by: java.lang.ClassNotFoundException: com.etm.EtmUIPlugin
at
org.eclipse.osgi.internal.loader.BundleLoader.findClassInter nal(BundleLoader.java:489)
at
org.eclipse.osgi.internal.loader.BundleLoader.findClass(Bund leLoader.java:405)
at
org.eclipse.osgi.internal.loader.BundleLoader.findClass(Bund leLoader.java:393)
at
org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loa dClass(DefaultClassLoader.java:105)
at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
at
org.eclipse.osgi.internal.loader.BundleLoader.loadClass(Bund leLoader.java:321)
at
org.eclipse.osgi.framework.internal.core.BundleHost.loadClas s(BundleHost.java:231)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.load BundleActivator(AbstractBundle.java:150)
... 23 more
Root exception:
java.lang.ClassNotFoundException: com.etm.EtmUIPlugin
at
org.eclipse.osgi.internal.loader.BundleLoader.findClassInter nal(BundleLoader.java:489)
at
org.eclipse.osgi.internal.loader.BundleLoader.findClass(Bund leLoader.java:405)
at
org.eclipse.osgi.internal.loader.BundleLoader.findClass(Bund leLoader.java:393)
at
org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loa dClass(DefaultClassLoader.java:105)
at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
at
org.eclipse.osgi.internal.loader.BundleLoader.loadClass(Bund leLoader.java:321)
at
org.eclipse.osgi.framework.internal.core.BundleHost.loadClas s(BundleHost.java:231)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.load BundleActivator(AbstractBundle.java:150)
at
org.eclipse.osgi.framework.internal.core.BundleContextImpl.s tart(BundleContextImpl.java:750)
at
org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:352)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.star t(AbstractBundle.java:280)
at
org.eclipse.osgi.framework.util.SecureAction.start(SecureAct ion.java:408)
at
org.eclipse.osgi.framework.internal.core.BundleHost.loadClas s(BundleHost.java:238)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.load Class(AbstractBundle.java:1193)
at
org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI .createExecutableExtension(RegistryStrategyOSGI.java:160)
at
org.eclipse.core.internal.registry.ExtensionRegistry.createE xecutableExtension(ExtensionRegistry.java:874)
at
org.eclipse.core.internal.registry.ConfigurationElement.crea teExecutableExtension(ConfigurationElement.java:243)
at
org.eclipse.core.internal.registry.ConfigurationElementHandl e.createExecutableExtension(ConfigurationElementHandle.java: 51)
at
org.eclipse.equinox.internal.app.EclipseAppHandle.run(Eclips eAppHandle.java:189)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:110)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:79)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:368)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 559)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
at org.eclipse.equinox.launcher.Main.run(Main.java:1311)
at org.eclipse.equinox.launcher.Main.main(Main.java:1287)

!ENTRY org.eclipse.osgi 4 0 2009-05-13 11:40:06.493
!MESSAGE Application error
!STACK 1
org.eclipse.core.runtime.CoreException: Plug-in com.etm.ui was unable to
load class com.etm.rcp.EtmApplication.
at
org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI .throwException(RegistryStrategyOSGI.java:180)
at
org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI .createExecutableExtension(RegistryStrategyOSGI.java:162)
at
org.eclipse.core.internal.registry.ExtensionRegistry.createE xecutableExtension(ExtensionRegistry.java:874)
at
org.eclipse.core.internal.registry.ConfigurationElement.crea teExecutableExtension(ConfigurationElement.java:243)
at
org.eclipse.core.internal.registry.ConfigurationElementHandl e.createExecutableExtension(ConfigurationElementHandle.java: 51)
at
org.eclipse.equinox.internal.app.EclipseAppHandle.run(Eclips eAppHandle.java:189)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:110)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:79)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:368)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 559)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
at org.eclipse.equinox.launcher.Main.run(Main.java:1311)
at org.eclipse.equinox.launcher.Main.main(Main.java:1287)
Caused by: java.lang.ClassNotFoundException: com.etm.rcp.EtmApplication
at
org.eclipse.osgi.internal.loader.BundleLoader.findClassInter nal(BundleLoader.java:489)
at
org.eclipse.osgi.internal.loader.BundleLoader.findClass(Bund leLoader.java:405)
at
org.eclipse.osgi.internal.loader.BundleLoader.findClass(Bund leLoader.java:393)
at
org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loa dClass(DefaultClassLoader.java:105)
at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
at
org.eclipse.osgi.internal.loader.BundleLoader.loadClass(Bund leLoader.java:321)
at
org.eclipse.osgi.framework.internal.core.BundleHost.loadClas s(BundleHost.java:231)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.load Class(AbstractBundle.java:1193)
at
org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI .createExecutableExtension(RegistryStrategyOSGI.java:160)
... 16 more




"Chris Aniszczyk" <zx@eclipsesource.com> wrote in message
news:gudhk4$404$2@build.eclipse.org...
> Sither wrote:
>> I recently upgarded to a new version of eclipse (3.5M6), and I was
>> initially able to use my existing Run/Debug configurations. But now (I
>> have no idea what changed between yesterday and today) I get a
>> BundleException that says my activator is invalid, caused by a
>> NoClassDefFoundError. I checked the run config by clicking "Add Required
>> Plug-ins" and "Validate Plug-ins", and no problems are detected. I had
>> been trying to upgrade to 3.5M7 but ran into issues manually dropping in
>> the log4j plug-in, so I reverted back to M6, and there's a chance there
>> might be some M7 plugin(s) lingering. Could that cause the error I'm
>> seeing? Should I just wipe the slate clean and start installing M6 all
>> over again?
>
> If you're activator is invalid, it could be a sign of some other problems.
> I would use 3.5 M7 as that's a better bet than M6 imho.
>
> Can you tell us more about the exception?
>
> Before starting clean slate with M7, I would create a brand new launch
> configuration, make sure that the workspace is cleared and the
> configuration area in the launch config (check the 'Configuration' tab for
> the checky box)
>
> Cheers,
>
> Chris Aniszczyk | EclipseSource Austin | +1 860 839 2465
> http://twitter.com/eclipsesource | http://twitter.com/caniszczyk
Re: NoClassDefFoundError on startup [message #61737 is a reply to message #61444] Thu, 14 May 2009 10:49 Go to previous message
Matt Sither is currently offline Matt SitherFriend
Messages: 33
Registered: July 2009
Member
Thanks again for the help, Chris. It turns out that at some point while I
was upgrading eclipse and loading my projects into it, the pojects'
build.properties were altered. I reverted build.properties, and the problem
went away.


"Sither" <sither@mit.edu> wrote in message
news:guepvh$13s$1@build.eclipse.org...
> Thanks Chris. I tried deleting all of my launch configurations and then
> creating a new one with the Clear checkbox selected in both the Main tab
> and the Configuration tab. Also, I don't know if it matters, but I tried
> both "Run a product" and "Run an application" under Main > Program to Run.
> Under Java Runtime Environment, I have Runtime JRE selected and pointed at
> jdk 1.6.0_12. Running under this configuration, I still get the error
> (see below). Let me know if I can provide you with any other relevant
> information about my environment.
>
> On a semi-related note, I tried starting over with a fresh 3.5 M7, and for
> some reason it doesn't load most of the eclipse plug-ins (for example, the
> Plug-ins view doesn't show org.eclipse.core.runtime or org.eclipse.swt).
> Oddly enough, those plug-ins do show up in the Plug-ins Registry view. I
> apologize for my ignorance here. I'm not clear on exactly how plug-ins
> are loaded or what the difference is between the Plug-ins view and
> Plug-ins Registry view.
>
>
> !SESSION 2009-05-13
> 11:39:55.653 -----------------------------------------------
> eclipse.buildId=unknown
> java.version=1.6.0_12
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
> Framework arguments: -application com.etm.application
> Command-line arguments: -application com.etm.application -data
> C:\Users\sither\workspace/../runtime-com.etm.ui.product -dev
> file:C:/Users/sither/workspace/.metadata/.plugins/org.eclips e.pde.core/com.etm.ui.product/dev.properties -
> debug
> C:\Users\sither\workspace\.metadata\.plugins\org.eclipse.pde .core\com.etm.ui.product/.options
> -os win32 -ws win32 -arch x86
>
> !ENTRY org.eclipse.osgi 2 0 2009-05-13 11:40:06.471
> !MESSAGE The activator com.etm.EtmUIPlugin for bundle com.etm.ui is
> invalid
> !STACK 0
> org.osgi.framework.BundleException: The activator com.etm.EtmUIPlugin for
> bundle com.etm.ui is invalid
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.load BundleActivator(AbstractBundle.java:157)
> at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.s tart(BundleContextImpl.java:750)
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:352)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.star t(AbstractBundle.java:280)
> at
> org.eclipse.osgi.framework.util.SecureAction.start(SecureAct ion.java:408)
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.loadClas s(BundleHost.java:238)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.load Class(AbstractBundle.java:1193)
> at
> org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI .createExecutableExtension(RegistryStrategyOSGI.java:160)
> at
> org.eclipse.core.internal.registry.ExtensionRegistry.createE xecutableExtension(ExtensionRegistry.java:874)
> at
> org.eclipse.core.internal.registry.ConfigurationElement.crea teExecutableExtension(ConfigurationElement.java:243)
> at
> org.eclipse.core.internal.registry.ConfigurationElementHandl e.createExecutableExtension(ConfigurationElementHandle.java: 51)
> at
> org.eclipse.equinox.internal.app.EclipseAppHandle.run(Eclips eAppHandle.java:189)
> at
> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:110)
> at
> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:79)
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:368)
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:179)
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
> at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:25)
> at java.lang.reflect.Method.invoke(Method.java:597)
> at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 559)
> at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
> at org.eclipse.equinox.launcher.Main.run(Main.java:1311)
> at org.eclipse.equinox.launcher.Main.main(Main.java:1287)
> Caused by: java.lang.ClassNotFoundException: com.etm.EtmUIPlugin
> at
> org.eclipse.osgi.internal.loader.BundleLoader.findClassInter nal(BundleLoader.java:489)
> at
> org.eclipse.osgi.internal.loader.BundleLoader.findClass(Bund leLoader.java:405)
> at
> org.eclipse.osgi.internal.loader.BundleLoader.findClass(Bund leLoader.java:393)
> at
> org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loa dClass(DefaultClassLoader.java:105)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
> at
> org.eclipse.osgi.internal.loader.BundleLoader.loadClass(Bund leLoader.java:321)
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.loadClas s(BundleHost.java:231)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.load BundleActivator(AbstractBundle.java:150)
> ... 23 more
> Root exception:
> java.lang.ClassNotFoundException: com.etm.EtmUIPlugin
> at
> org.eclipse.osgi.internal.loader.BundleLoader.findClassInter nal(BundleLoader.java:489)
> at
> org.eclipse.osgi.internal.loader.BundleLoader.findClass(Bund leLoader.java:405)
> at
> org.eclipse.osgi.internal.loader.BundleLoader.findClass(Bund leLoader.java:393)
> at
> org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loa dClass(DefaultClassLoader.java:105)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
> at
> org.eclipse.osgi.internal.loader.BundleLoader.loadClass(Bund leLoader.java:321)
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.loadClas s(BundleHost.java:231)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.load BundleActivator(AbstractBundle.java:150)
> at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.s tart(BundleContextImpl.java:750)
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:352)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.star t(AbstractBundle.java:280)
> at
> org.eclipse.osgi.framework.util.SecureAction.start(SecureAct ion.java:408)
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.loadClas s(BundleHost.java:238)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.load Class(AbstractBundle.java:1193)
> at
> org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI .createExecutableExtension(RegistryStrategyOSGI.java:160)
> at
> org.eclipse.core.internal.registry.ExtensionRegistry.createE xecutableExtension(ExtensionRegistry.java:874)
> at
> org.eclipse.core.internal.registry.ConfigurationElement.crea teExecutableExtension(ConfigurationElement.java:243)
> at
> org.eclipse.core.internal.registry.ConfigurationElementHandl e.createExecutableExtension(ConfigurationElementHandle.java: 51)
> at
> org.eclipse.equinox.internal.app.EclipseAppHandle.run(Eclips eAppHandle.java:189)
> at
> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:110)
> at
> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:79)
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:368)
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:179)
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
> at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:25)
> at java.lang.reflect.Method.invoke(Method.java:597)
> at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 559)
> at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
> at org.eclipse.equinox.launcher.Main.run(Main.java:1311)
> at org.eclipse.equinox.launcher.Main.main(Main.java:1287)
>
> !ENTRY org.eclipse.osgi 4 0 2009-05-13 11:40:06.493
> !MESSAGE Application error
> !STACK 1
> org.eclipse.core.runtime.CoreException: Plug-in com.etm.ui was unable to
> load class com.etm.rcp.EtmApplication.
> at
> org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI .throwException(RegistryStrategyOSGI.java:180)
> at
> org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI .createExecutableExtension(RegistryStrategyOSGI.java:162)
> at
> org.eclipse.core.internal.registry.ExtensionRegistry.createE xecutableExtension(ExtensionRegistry.java:874)
> at
> org.eclipse.core.internal.registry.ConfigurationElement.crea teExecutableExtension(ConfigurationElement.java:243)
> at
> org.eclipse.core.internal.registry.ConfigurationElementHandl e.createExecutableExtension(ConfigurationElementHandle.java: 51)
> at
> org.eclipse.equinox.internal.app.EclipseAppHandle.run(Eclips eAppHandle.java:189)
> at
> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:110)
> at
> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:79)
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:368)
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:179)
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
> at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:25)
> at java.lang.reflect.Method.invoke(Method.java:597)
> at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 559)
> at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
> at org.eclipse.equinox.launcher.Main.run(Main.java:1311)
> at org.eclipse.equinox.launcher.Main.main(Main.java:1287)
> Caused by: java.lang.ClassNotFoundException: com.etm.rcp.EtmApplication
> at
> org.eclipse.osgi.internal.loader.BundleLoader.findClassInter nal(BundleLoader.java:489)
> at
> org.eclipse.osgi.internal.loader.BundleLoader.findClass(Bund leLoader.java:405)
> at
> org.eclipse.osgi.internal.loader.BundleLoader.findClass(Bund leLoader.java:393)
> at
> org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loa dClass(DefaultClassLoader.java:105)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
> at
> org.eclipse.osgi.internal.loader.BundleLoader.loadClass(Bund leLoader.java:321)
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.loadClas s(BundleHost.java:231)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.load Class(AbstractBundle.java:1193)
> at
> org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI .createExecutableExtension(RegistryStrategyOSGI.java:160)
> ... 16 more
>
>
>
>
> "Chris Aniszczyk" <zx@eclipsesource.com> wrote in message
> news:gudhk4$404$2@build.eclipse.org...
>> Sither wrote:
>>> I recently upgarded to a new version of eclipse (3.5M6), and I was
>>> initially able to use my existing Run/Debug configurations. But now (I
>>> have no idea what changed between yesterday and today) I get a
>>> BundleException that says my activator is invalid, caused by a
>>> NoClassDefFoundError. I checked the run config by clicking "Add
>>> Required Plug-ins" and "Validate Plug-ins", and no problems are
>>> detected. I had been trying to upgrade to 3.5M7 but ran into issues
>>> manually dropping in the log4j plug-in, so I reverted back to M6, and
>>> there's a chance there might be some M7 plugin(s) lingering. Could that
>>> cause the error I'm seeing? Should I just wipe the slate clean and
>>> start installing M6 all over again?
>>
>> If you're activator is invalid, it could be a sign of some other
>> problems. I would use 3.5 M7 as that's a better bet than M6 imho.
>>
>> Can you tell us more about the exception?
>>
>> Before starting clean slate with M7, I would create a brand new launch
>> configuration, make sure that the workspace is cleared and the
>> configuration area in the launch config (check the 'Configuration' tab
>> for the checky box)
>>
>> Cheers,
>>
>> Chris Aniszczyk | EclipseSource Austin | +1 860 839 2465
>> http://twitter.com/eclipsesource | http://twitter.com/caniszczyk
>
Re: NoClassDefFoundError on startup [message #597357 is a reply to message #61134] Wed, 13 May 2009 04:17 Go to previous message
Chris Aniszczyk is currently offline Chris AniszczykFriend
Messages: 674
Registered: July 2009
Senior Member
Sither wrote:
> I recently upgarded to a new version of eclipse (3.5M6), and I was
> initially able to use my existing Run/Debug configurations. But now (I
> have no idea what changed between yesterday and today) I get a
> BundleException that says my activator is invalid, caused by a
> NoClassDefFoundError. I checked the run config by clicking "Add
> Required Plug-ins" and "Validate Plug-ins", and no problems are
> detected. I had been trying to upgrade to 3.5M7 but ran into issues
> manually dropping in the log4j plug-in, so I reverted back to M6, and
> there's a chance there might be some M7 plugin(s) lingering. Could that
> cause the error I'm seeing? Should I just wipe the slate clean and
> start installing M6 all over again?

If you're activator is invalid, it could be a sign of some other
problems. I would use 3.5 M7 as that's a better bet than M6 imho.

Can you tell us more about the exception?

Before starting clean slate with M7, I would create a brand new launch
configuration, make sure that the workspace is cleared and the
configuration area in the launch config (check the 'Configuration' tab
for the checky box)

Cheers,

Chris Aniszczyk | EclipseSource Austin | +1 860 839 2465
http://twitter.com/eclipsesource | http://twitter.com/caniszczyk
Re: NoClassDefFoundError on startup [message #597384 is a reply to message #61350] Wed, 13 May 2009 15:45 Go to previous message
Matt Sither is currently offline Matt SitherFriend
Messages: 33
Registered: July 2009
Member
Thanks Chris. I tried deleting all of my launch configurations and then
creating a new one with the Clear checkbox selected in both the Main tab and
the Configuration tab. Also, I don't know if it matters, but I tried both
"Run a product" and "Run an application" under Main > Program to Run. Under
Java Runtime Environment, I have Runtime JRE selected and pointed at jdk
1.6.0_12. Running under this configuration, I still get the error (see
below). Let me know if I can provide you with any other relevant
information about my environment.

On a semi-related note, I tried starting over with a fresh 3.5 M7, and for
some reason it doesn't load most of the eclipse plug-ins (for example, the
Plug-ins view doesn't show org.eclipse.core.runtime or org.eclipse.swt).
Oddly enough, those plug-ins do show up in the Plug-ins Registry view. I
apologize for my ignorance here. I'm not clear on exactly how plug-ins are
loaded or what the difference is between the Plug-ins view and Plug-ins
Registry view.


!SESSION 2009-05-13
11:39:55.653 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_12
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Framework arguments: -application com.etm.application
Command-line arguments: -application com.etm.application -data
C:\Users\sither\workspace/../runtime-com.etm.ui.product -dev
file:C:/Users/sither/workspace/.metadata/.plugins/org.eclips e.pde.core/com.etm.ui.product/dev.properties -
debug
C:\Users\sither\workspace\.metadata\.plugins\org.eclipse.pde .core\com.etm.ui.product/.options
-os win32 -ws win32 -arch x86

!ENTRY org.eclipse.osgi 2 0 2009-05-13 11:40:06.471
!MESSAGE The activator com.etm.EtmUIPlugin for bundle com.etm.ui is invalid
!STACK 0
org.osgi.framework.BundleException: The activator com.etm.EtmUIPlugin for
bundle com.etm.ui is invalid
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.load BundleActivator(AbstractBundle.java:157)
at
org.eclipse.osgi.framework.internal.core.BundleContextImpl.s tart(BundleContextImpl.java:750)
at
org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:352)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.star t(AbstractBundle.java:280)
at
org.eclipse.osgi.framework.util.SecureAction.start(SecureAct ion.java:408)
at
org.eclipse.osgi.framework.internal.core.BundleHost.loadClas s(BundleHost.java:238)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.load Class(AbstractBundle.java:1193)
at
org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI .createExecutableExtension(RegistryStrategyOSGI.java:160)
at
org.eclipse.core.internal.registry.ExtensionRegistry.createE xecutableExtension(ExtensionRegistry.java:874)
at
org.eclipse.core.internal.registry.ConfigurationElement.crea teExecutableExtension(ConfigurationElement.java:243)
at
org.eclipse.core.internal.registry.ConfigurationElementHandl e.createExecutableExtension(ConfigurationElementHandle.java: 51)
at
org.eclipse.equinox.internal.app.EclipseAppHandle.run(Eclips eAppHandle.java:189)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:110)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:79)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:368)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 559)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
at org.eclipse.equinox.launcher.Main.run(Main.java:1311)
at org.eclipse.equinox.launcher.Main.main(Main.java:1287)
Caused by: java.lang.ClassNotFoundException: com.etm.EtmUIPlugin
at
org.eclipse.osgi.internal.loader.BundleLoader.findClassInter nal(BundleLoader.java:489)
at
org.eclipse.osgi.internal.loader.BundleLoader.findClass(Bund leLoader.java:405)
at
org.eclipse.osgi.internal.loader.BundleLoader.findClass(Bund leLoader.java:393)
at
org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loa dClass(DefaultClassLoader.java:105)
at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
at
org.eclipse.osgi.internal.loader.BundleLoader.loadClass(Bund leLoader.java:321)
at
org.eclipse.osgi.framework.internal.core.BundleHost.loadClas s(BundleHost.java:231)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.load BundleActivator(AbstractBundle.java:150)
... 23 more
Root exception:
java.lang.ClassNotFoundException: com.etm.EtmUIPlugin
at
org.eclipse.osgi.internal.loader.BundleLoader.findClassInter nal(BundleLoader.java:489)
at
org.eclipse.osgi.internal.loader.BundleLoader.findClass(Bund leLoader.java:405)
at
org.eclipse.osgi.internal.loader.BundleLoader.findClass(Bund leLoader.java:393)
at
org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loa dClass(DefaultClassLoader.java:105)
at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
at
org.eclipse.osgi.internal.loader.BundleLoader.loadClass(Bund leLoader.java:321)
at
org.eclipse.osgi.framework.internal.core.BundleHost.loadClas s(BundleHost.java:231)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.load BundleActivator(AbstractBundle.java:150)
at
org.eclipse.osgi.framework.internal.core.BundleContextImpl.s tart(BundleContextImpl.java:750)
at
org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:352)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.star t(AbstractBundle.java:280)
at
org.eclipse.osgi.framework.util.SecureAction.start(SecureAct ion.java:408)
at
org.eclipse.osgi.framework.internal.core.BundleHost.loadClas s(BundleHost.java:238)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.load Class(AbstractBundle.java:1193)
at
org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI .createExecutableExtension(RegistryStrategyOSGI.java:160)
at
org.eclipse.core.internal.registry.ExtensionRegistry.createE xecutableExtension(ExtensionRegistry.java:874)
at
org.eclipse.core.internal.registry.ConfigurationElement.crea teExecutableExtension(ConfigurationElement.java:243)
at
org.eclipse.core.internal.registry.ConfigurationElementHandl e.createExecutableExtension(ConfigurationElementHandle.java: 51)
at
org.eclipse.equinox.internal.app.EclipseAppHandle.run(Eclips eAppHandle.java:189)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:110)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:79)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:368)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 559)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
at org.eclipse.equinox.launcher.Main.run(Main.java:1311)
at org.eclipse.equinox.launcher.Main.main(Main.java:1287)

!ENTRY org.eclipse.osgi 4 0 2009-05-13 11:40:06.493
!MESSAGE Application error
!STACK 1
org.eclipse.core.runtime.CoreException: Plug-in com.etm.ui was unable to
load class com.etm.rcp.EtmApplication.
at
org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI .throwException(RegistryStrategyOSGI.java:180)
at
org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI .createExecutableExtension(RegistryStrategyOSGI.java:162)
at
org.eclipse.core.internal.registry.ExtensionRegistry.createE xecutableExtension(ExtensionRegistry.java:874)
at
org.eclipse.core.internal.registry.ConfigurationElement.crea teExecutableExtension(ConfigurationElement.java:243)
at
org.eclipse.core.internal.registry.ConfigurationElementHandl e.createExecutableExtension(ConfigurationElementHandle.java: 51)
at
org.eclipse.equinox.internal.app.EclipseAppHandle.run(Eclips eAppHandle.java:189)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:110)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:79)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:368)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 559)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
at org.eclipse.equinox.launcher.Main.run(Main.java:1311)
at org.eclipse.equinox.launcher.Main.main(Main.java:1287)
Caused by: java.lang.ClassNotFoundException: com.etm.rcp.EtmApplication
at
org.eclipse.osgi.internal.loader.BundleLoader.findClassInter nal(BundleLoader.java:489)
at
org.eclipse.osgi.internal.loader.BundleLoader.findClass(Bund leLoader.java:405)
at
org.eclipse.osgi.internal.loader.BundleLoader.findClass(Bund leLoader.java:393)
at
org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loa dClass(DefaultClassLoader.java:105)
at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
at
org.eclipse.osgi.internal.loader.BundleLoader.loadClass(Bund leLoader.java:321)
at
org.eclipse.osgi.framework.internal.core.BundleHost.loadClas s(BundleHost.java:231)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.load Class(AbstractBundle.java:1193)
at
org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI .createExecutableExtension(RegistryStrategyOSGI.java:160)
... 16 more




"Chris Aniszczyk" <zx@eclipsesource.com> wrote in message
news:gudhk4$404$2@build.eclipse.org...
> Sither wrote:
>> I recently upgarded to a new version of eclipse (3.5M6), and I was
>> initially able to use my existing Run/Debug configurations. But now (I
>> have no idea what changed between yesterday and today) I get a
>> BundleException that says my activator is invalid, caused by a
>> NoClassDefFoundError. I checked the run config by clicking "Add Required
>> Plug-ins" and "Validate Plug-ins", and no problems are detected. I had
>> been trying to upgrade to 3.5M7 but ran into issues manually dropping in
>> the log4j plug-in, so I reverted back to M6, and there's a chance there
>> might be some M7 plugin(s) lingering. Could that cause the error I'm
>> seeing? Should I just wipe the slate clean and start installing M6 all
>> over again?
>
> If you're activator is invalid, it could be a sign of some other problems.
> I would use 3.5 M7 as that's a better bet than M6 imho.
>
> Can you tell us more about the exception?
>
> Before starting clean slate with M7, I would create a brand new launch
> configuration, make sure that the workspace is cleared and the
> configuration area in the launch config (check the 'Configuration' tab for
> the checky box)
>
> Cheers,
>
> Chris Aniszczyk | EclipseSource Austin | +1 860 839 2465
> http://twitter.com/eclipsesource | http://twitter.com/caniszczyk
Re: NoClassDefFoundError on startup [message #597462 is a reply to message #61444] Thu, 14 May 2009 10:49 Go to previous message
Matt Sither is currently offline Matt SitherFriend
Messages: 33
Registered: July 2009
Member
Thanks again for the help, Chris. It turns out that at some point while I
was upgrading eclipse and loading my projects into it, the pojects'
build.properties were altered. I reverted build.properties, and the problem
went away.


"Sither" <sither@mit.edu> wrote in message
news:guepvh$13s$1@build.eclipse.org...
> Thanks Chris. I tried deleting all of my launch configurations and then
> creating a new one with the Clear checkbox selected in both the Main tab
> and the Configuration tab. Also, I don't know if it matters, but I tried
> both "Run a product" and "Run an application" under Main > Program to Run.
> Under Java Runtime Environment, I have Runtime JRE selected and pointed at
> jdk 1.6.0_12. Running under this configuration, I still get the error
> (see below). Let me know if I can provide you with any other relevant
> information about my environment.
>
> On a semi-related note, I tried starting over with a fresh 3.5 M7, and for
> some reason it doesn't load most of the eclipse plug-ins (for example, the
> Plug-ins view doesn't show org.eclipse.core.runtime or org.eclipse.swt).
> Oddly enough, those plug-ins do show up in the Plug-ins Registry view. I
> apologize for my ignorance here. I'm not clear on exactly how plug-ins
> are loaded or what the difference is between the Plug-ins view and
> Plug-ins Registry view.
>
>
> !SESSION 2009-05-13
> 11:39:55.653 -----------------------------------------------
> eclipse.buildId=unknown
> java.version=1.6.0_12
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
> Framework arguments: -application com.etm.application
> Command-line arguments: -application com.etm.application -data
> C:\Users\sither\workspace/../runtime-com.etm.ui.product -dev
> file:C:/Users/sither/workspace/.metadata/.plugins/org.eclips e.pde.core/com.etm.ui.product/dev.properties -
> debug
> C:\Users\sither\workspace\.metadata\.plugins\org.eclipse.pde .core\com.etm.ui.product/.options
> -os win32 -ws win32 -arch x86
>
> !ENTRY org.eclipse.osgi 2 0 2009-05-13 11:40:06.471
> !MESSAGE The activator com.etm.EtmUIPlugin for bundle com.etm.ui is
> invalid
> !STACK 0
> org.osgi.framework.BundleException: The activator com.etm.EtmUIPlugin for
> bundle com.etm.ui is invalid
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.load BundleActivator(AbstractBundle.java:157)
> at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.s tart(BundleContextImpl.java:750)
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:352)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.star t(AbstractBundle.java:280)
> at
> org.eclipse.osgi.framework.util.SecureAction.start(SecureAct ion.java:408)
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.loadClas s(BundleHost.java:238)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.load Class(AbstractBundle.java:1193)
> at
> org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI .createExecutableExtension(RegistryStrategyOSGI.java:160)
> at
> org.eclipse.core.internal.registry.ExtensionRegistry.createE xecutableExtension(ExtensionRegistry.java:874)
> at
> org.eclipse.core.internal.registry.ConfigurationElement.crea teExecutableExtension(ConfigurationElement.java:243)
> at
> org.eclipse.core.internal.registry.ConfigurationElementHandl e.createExecutableExtension(ConfigurationElementHandle.java: 51)
> at
> org.eclipse.equinox.internal.app.EclipseAppHandle.run(Eclips eAppHandle.java:189)
> at
> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:110)
> at
> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:79)
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:368)
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:179)
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
> at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:25)
> at java.lang.reflect.Method.invoke(Method.java:597)
> at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 559)
> at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
> at org.eclipse.equinox.launcher.Main.run(Main.java:1311)
> at org.eclipse.equinox.launcher.Main.main(Main.java:1287)
> Caused by: java.lang.ClassNotFoundException: com.etm.EtmUIPlugin
> at
> org.eclipse.osgi.internal.loader.BundleLoader.findClassInter nal(BundleLoader.java:489)
> at
> org.eclipse.osgi.internal.loader.BundleLoader.findClass(Bund leLoader.java:405)
> at
> org.eclipse.osgi.internal.loader.BundleLoader.findClass(Bund leLoader.java:393)
> at
> org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loa dClass(DefaultClassLoader.java:105)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
> at
> org.eclipse.osgi.internal.loader.BundleLoader.loadClass(Bund leLoader.java:321)
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.loadClas s(BundleHost.java:231)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.load BundleActivator(AbstractBundle.java:150)
> ... 23 more
> Root exception:
> java.lang.ClassNotFoundException: com.etm.EtmUIPlugin
> at
> org.eclipse.osgi.internal.loader.BundleLoader.findClassInter nal(BundleLoader.java:489)
> at
> org.eclipse.osgi.internal.loader.BundleLoader.findClass(Bund leLoader.java:405)
> at
> org.eclipse.osgi.internal.loader.BundleLoader.findClass(Bund leLoader.java:393)
> at
> org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loa dClass(DefaultClassLoader.java:105)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
> at
> org.eclipse.osgi.internal.loader.BundleLoader.loadClass(Bund leLoader.java:321)
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.loadClas s(BundleHost.java:231)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.load BundleActivator(AbstractBundle.java:150)
> at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.s tart(BundleContextImpl.java:750)
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:352)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.star t(AbstractBundle.java:280)
> at
> org.eclipse.osgi.framework.util.SecureAction.start(SecureAct ion.java:408)
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.loadClas s(BundleHost.java:238)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.load Class(AbstractBundle.java:1193)
> at
> org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI .createExecutableExtension(RegistryStrategyOSGI.java:160)
> at
> org.eclipse.core.internal.registry.ExtensionRegistry.createE xecutableExtension(ExtensionRegistry.java:874)
> at
> org.eclipse.core.internal.registry.ConfigurationElement.crea teExecutableExtension(ConfigurationElement.java:243)
> at
> org.eclipse.core.internal.registry.ConfigurationElementHandl e.createExecutableExtension(ConfigurationElementHandle.java: 51)
> at
> org.eclipse.equinox.internal.app.EclipseAppHandle.run(Eclips eAppHandle.java:189)
> at
> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:110)
> at
> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:79)
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:368)
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:179)
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
> at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:25)
> at java.lang.reflect.Method.invoke(Method.java:597)
> at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 559)
> at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
> at org.eclipse.equinox.launcher.Main.run(Main.java:1311)
> at org.eclipse.equinox.launcher.Main.main(Main.java:1287)
>
> !ENTRY org.eclipse.osgi 4 0 2009-05-13 11:40:06.493
> !MESSAGE Application error
> !STACK 1
> org.eclipse.core.runtime.CoreException: Plug-in com.etm.ui was unable to
> load class com.etm.rcp.EtmApplication.
> at
> org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI .throwException(RegistryStrategyOSGI.java:180)
> at
> org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI .createExecutableExtension(RegistryStrategyOSGI.java:162)
> at
> org.eclipse.core.internal.registry.ExtensionRegistry.createE xecutableExtension(ExtensionRegistry.java:874)
> at
> org.eclipse.core.internal.registry.ConfigurationElement.crea teExecutableExtension(ConfigurationElement.java:243)
> at
> org.eclipse.core.internal.registry.ConfigurationElementHandl e.createExecutableExtension(ConfigurationElementHandle.java: 51)
> at
> org.eclipse.equinox.internal.app.EclipseAppHandle.run(Eclips eAppHandle.java:189)
> at
> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:110)
> at
> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:79)
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:368)
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:179)
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
> at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:25)
> at java.lang.reflect.Method.invoke(Method.java:597)
> at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 559)
> at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
> at org.eclipse.equinox.launcher.Main.run(Main.java:1311)
> at org.eclipse.equinox.launcher.Main.main(Main.java:1287)
> Caused by: java.lang.ClassNotFoundException: com.etm.rcp.EtmApplication
> at
> org.eclipse.osgi.internal.loader.BundleLoader.findClassInter nal(BundleLoader.java:489)
> at
> org.eclipse.osgi.internal.loader.BundleLoader.findClass(Bund leLoader.java:405)
> at
> org.eclipse.osgi.internal.loader.BundleLoader.findClass(Bund leLoader.java:393)
> at
> org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loa dClass(DefaultClassLoader.java:105)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
> at
> org.eclipse.osgi.internal.loader.BundleLoader.loadClass(Bund leLoader.java:321)
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.loadClas s(BundleHost.java:231)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.load Class(AbstractBundle.java:1193)
> at
> org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI .createExecutableExtension(RegistryStrategyOSGI.java:160)
> ... 16 more
>
>
>
>
> "Chris Aniszczyk" <zx@eclipsesource.com> wrote in message
> news:gudhk4$404$2@build.eclipse.org...
>> Sither wrote:
>>> I recently upgarded to a new version of eclipse (3.5M6), and I was
>>> initially able to use my existing Run/Debug configurations. But now (I
>>> have no idea what changed between yesterday and today) I get a
>>> BundleException that says my activator is invalid, caused by a
>>> NoClassDefFoundError. I checked the run config by clicking "Add
>>> Required Plug-ins" and "Validate Plug-ins", and no problems are
>>> detected. I had been trying to upgrade to 3.5M7 but ran into issues
>>> manually dropping in the log4j plug-in, so I reverted back to M6, and
>>> there's a chance there might be some M7 plugin(s) lingering. Could that
>>> cause the error I'm seeing? Should I just wipe the slate clean and
>>> start installing M6 all over again?
>>
>> If you're activator is invalid, it could be a sign of some other
>> problems. I would use 3.5 M7 as that's a better bet than M6 imho.
>>
>> Can you tell us more about the exception?
>>
>> Before starting clean slate with M7, I would create a brand new launch
>> configuration, make sure that the workspace is cleared and the
>> configuration area in the launch config (check the 'Configuration' tab
>> for the checky box)
>>
>> Cheers,
>>
>> Chris Aniszczyk | EclipseSource Austin | +1 860 839 2465
>> http://twitter.com/eclipsesource | http://twitter.com/caniszczyk
>
Previous Topic:Specifying dependend update sites to one's own
Next Topic:Exporting extension point documentation
Goto Forum:
  


Current Time: Fri Jun 18 05:09:37 GMT 2021

Powered by FUDForum. Page generated in 0.02630 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top