Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » JDOUserException while initializing datastore
JDOUserException while initializing datastore [message #603782] Thu, 22 March 2007 10:31
Markus Bischof is currently offline Markus BischofFriend
Messages: 72
Registered: July 2009
Member
Hello,

I'm new to Teneo and this newsgroup...so I hope this is the right place to
ask my question.

I used Teneo to create a package.jdo-File from my ecore-Model. This worked
fine...After this I created a JpoxDatastore and tried to initialize the
database. Now I'm running in a JDOUserException in a specific class.

Here's the exception-message:

javax.jdo.JDOUserException: Specified field
"StructuredActivityNodeImpl.in" has no container (collection/map/array)
MetaData!

Here's the mapping for this class:

<class name="StructuredActivityNodeImpl" requires-extent="true"
persistence-modifier="persistence-capable" detachable="true"
identity-type="datastore">
<implements name="StructuredActivityNode"/>
<inheritance strategy="superclass-table">
<discriminator value="StructuredActivityNode"/>
</inheritance>
<version strategy="version-number" column="e_version"/>
</class>

(There is no class-tag for my StructuredActivityNode-class)

I don't know what is wrong here...
So, my question is, if this could be a bug in the generation-mechanism of
Teneo, or is there something I have to do?

Regards.
Previous Topic:Teneo 0.8.0/0.7.5 Release Notes/Information
Next Topic:New to JET can't access xsi:type value
Goto Forum:
  


Current Time: Mon Oct 26 06:52:27 GMT 2020

Powered by FUDForum. Page generated in 0.01990 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top