Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » ant unable to delete file
ant unable to delete file [message #600845] Thu, 20 August 2009 07:05
Aurélien Pupier is currently offline Aurélien PupierFriend
Messages: 637
Registered: July 2009
Location: Grenoble, FRANCE
Senior Member

Hi,

I want to know if the issue is known or I'm just doing something wrong... (and if there is a solution :))

I tried to do a Continuous Integration with Eclipse plug-gins. I used the templates provided in PDE.
All works fine on my local Win XP.

I'm trying to do it on a test server in a virtual Windows XP.
And the following error appeared in the console output :

[java] cleanup.assembly:
[java] [delete] Deleting directory C:\home\jemuser\hudson\workspace\JASMINe-Design\buildDirecto ry\tmp
[antcall] Exiting C:\home\jemuser\hudson\workspace\JASMINe-Design\org.ow2.jasm ine.design.builder\build.xml.
[antcall] Exiting C:\home\jemuser\hudson\workspace\JASMINe-Design\org.ow2.jasm ine.design.builder\build.xml.

BUILD FAILED
C:\home\jemuser\hudson\workspace\JASMINe-Design\org.ow2.jasm ine.design.builder\build.xml:193: The following error occurred while executing this line:
C:\home\jemuser\hudson\workspace\JASMINe-Design\org.ow2.jasm ine.design.builder\build.xml:89: The following error occurred while executing this line:
C:\home\jemuser\hudson\workspace\JASMINe-Design\org.ow2.jasm ine.design.builder\build.xml:124: Java returned: 13

And when I look into the log of the workspace used by the eclipse launched for build, there are this sort of error :

--- Nested Exception ---
C:\home\jemuser\hudson\workspace\JASMINe-Design\buildDirecto ry\assemble.org.ow2.jasmine.design.feature.xml:234: Unable to delete file C:\home\jemuser\hudson\workspace\JASMINe-Design\buildDirecto ry\tmp\eclipse\plugins\org.ow2.jasmine.design.discovery_0.1. 0.200908190718N.jar

The assemble.org.ow2.jasmine.design.feature.xml is generated by PDE. It seems to correspond to :
<target name="cleanup.assembly">
<delete dir="${assemblyTempDir}"/>
</target>

as it is generated by PDE I can't change them easily.

I found someone that seems to recently have the same problem : http://mail-archives.apache.org/mod_mbox/ant-user/200908.mbo x/%3C32C9659BBD4DE64DA4B361F6E00FAAE813B1D36E@emss04m23.us.l mco.com%3E
but no resolution

the build was good only twice on the test server. It was when other tests were running in the same time.

So thi smak eme think about this kind of issue http://mail-archives.apache.org/mod_mbox/ant-user/200307.mbo x/%3COF2704F014.DEF9462E-ON07256D5E.0078B63D-07256D5E.00790C 8C@az05.bull.com%3E
But it's a really old issue that is fixed.

Some config information :
Eclipse 3.5
Windows XP SP2 with NTFS for my local machine and for the test machine.

I can delete the files manually just after the error and using "unlocker" I didn't see any lock on the files when the file is tried to be deleted.

So if someone can give me some hints... where can I find more information? What can I look?


Thanks for help and sorry for my little english

Aurelien Pupier


Aurélien Pupier - Red Hat
Senior Software Engineer in Fuse Tooling team
Previous Topic:Wrong archive file extension
Next Topic:get the URI of a file selected
Goto Forum:
  


Current Time: Sat Aug 20 00:33:19 GMT 2022

Powered by FUDForum. Page generated in 0.05637 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top