Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Weird PDE behavior in 3.5
Weird PDE behavior in 3.5 [message #598962] Fri, 03 July 2009 12:18
Roland Tepp is currently offline Roland TeppFriend
Messages: 336
Registered: July 2009
Senior Member
Hello,

I am trying to move my IDE environment from Eclipse 3.4 to 3.5 and we
are having a very strange problem related to Reqire-Bundle header.

Workspace being exactly the same that was uesd in Eclipse 3.4, we are
getting "Unsatisfied version constraint" errors on one of our plug-ins.

The error appears only for this one project and only if we add one
specific bundle to the Require-Bundle list (no matter if we restrict it
to one specific bundle or not)

There is nothing special about either of the plug-ins and this exact
setup worked (and still works) without problems in Eclipse 3.4

Basically as soon as we include the "wrong" bundle in Require-Bundle
list, all the bundles there will marked with "Unsatisfied version
constraint" error.

Also - the weirdest part is that the "wrong" bundle is required by many
other bundles as well, where it dies not seem to cause any problems.
Previous Topic:Weird PDE behavior in 3.5
Next Topic:Building non-RCP osgi application
Goto Forum:
  


Current Time: Sat Jun 19 10:10:36 GMT 2021

Powered by FUDForum. Page generated in 0.01217 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top