Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Conflicting required versions of o.e.core.resources after export
Conflicting required versions of o.e.core.resources after export [message #598644] Fri, 26 June 2009 18:43
Ben Vitale is currently offline Ben VitaleFriend
Messages: 247
Registered: July 2009
Senior Member
I am trying to export a product on 3.5. I am exporting to one platform
and I do not have the delta pack installed. Near the end of the export,
I get this:

Missing requirement: Company Product Feature 1.6.1.200906261432
(com.company.product.feature.feature.group 1.6.1.200906261432) requires
'org.eclipse.core.resources [3.4.0,3.5.0)' but it could not be found

In the repository content.xml I see this:

<unit id="com.company.product.feature.feature.group"
version="1.6.1.200906261432" singleton="false">
.....
<requires size="106">
.....
<required namespace="org.eclipse.equinox.p2.iu"
name="org.eclipse.core.resources" range="[3.4.0,4.0.0)" />
<required namespace="org.eclipse.equinox.p2.iu"
name="org.eclipse.core.resources" range="[3.4.0,3.5.0)" />

I can't figure out what bundle is driving the requirement of the second
org.eclipse.core.resources.

Suggestions on how to find the offending bundle?

Cheers
Ben
Previous Topic:Eclipse JUnit Plug-in Test
Next Topic:PDE Build templates
Goto Forum:
  


Current Time: Tue Jun 15 11:13:22 GMT 2021

Powered by FUDForum. Page generated in 0.01880 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top