Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Problem upgrading existing automated build to use eclipse 3.5 (related to p2?)
Problem upgrading existing automated build to use eclipse 3.5 (related to p2?) [message #597154] Mon, 11 May 2009 11:16
Matt Sither is currently offline Matt SitherFriend
Messages: 33
Registered: July 2009
Member
I have an existing headless build that successfully uses the SDK and delta
pack from 3.4. I recently added dependencies on the latest ECF changes, so
I had to upgrade to 3.5. I replaced the SDK and delta pack from 3.4 with
the ones from 3.5, and I also added the ECF plugin. The build itself
succeeds, but when I run the built application, I get an error having to do
with unresolved bundles (see below), all of which are Equinox p2 bundles. I
read that this problem could indicate that my SDK and delta pack libraries
are incompatible, but I downloaded them from the same build, so that seems
unlikely.

Any ideas? I'm stumped, and I have to resort to manually building (via the
product file UI) and distributing the software for now.

Thanks!
Matt


!SESSION 2009-05-10
16:28:33.820 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_13
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Command-line arguments: -os win32 -ws win32 -arch x86 -console -consoleLog

!ENTRY org.eclipse.equinox.registry 2 0 2009-05-10 16:28:35.311
!MESSAGE The extensions and extension-points from the bundle "com.etm.ws"
are ignored. The bundle is not marked as singleton.

!ENTRY org.eclipse.osgi 4 0 2009-05-10 16:28:35.632
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: Application "com.etm.application" could not be
found in the registry. The applications available are:
com.etm.ui.news.application, org.eclipse.ant.core.antRunner,
org.eclipse.ecf.example.clients.chatroomrobot,
org.eclipse.ecf.example.clients.chatsorobot,
org.eclipse.ecf.example.clients.chatrobot,
org.eclipse.ecf.server.generic.Server, org.eclipse.equinox.app.error.
at
org.eclipse.equinox.internal.app.EclipseAppContainer.startDe faultApp(EclipseAppContainer.java:242)
at
org.eclipse.equinox.internal.app.MainApplicationLauncher.run (MainApplicationLauncher.java:29)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:110)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:79)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:368)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 559)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
at org.eclipse.equinox.launcher.Main.run(Main.java:1311)

!ENTRY org.eclipse.osgi 2 0 2009-05-10 16:28:35.692
!MESSAGE One or more bundles are not resolved because the following root
constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-05-10 16:28:35.694
!MESSAGE Bundle
initial@reference :file:plugins/org.eclipse.equinox.p2.artifact.repository_1.0 .100.v20090430-2300.jar/
was not resolved.
!SUBENTRY 2 org.eclipse.equinox.p2.artifact.repository 2 0 2009-05-10
16:28:35.697
!MESSAGE Missing imported package
org.eclipse.equinox.internal.p2.repository_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.artifact.repository 2 0 2009-05-10
16:28:35.700
!MESSAGE Missing imported package
org.eclipse.equinox.internal.provisional.spi.p2.repository_0 .0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.artifact.repository 2 0 2009-05-10
16:28:35.703
!MESSAGE Missing imported package
org.eclipse.equinox.internal.p2.repository.helpers_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.artifact.repository 2 0 2009-05-10
16:28:35.705
!MESSAGE Missing imported package
org.eclipse.equinox.internal.p2.persistence_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.artifact.repository 2 0 2009-05-10
16:28:35.708
!MESSAGE Missing imported package
org.eclipse.equinox.internal.provisional.p2.repository_0.0.0 .
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-05-10 16:28:35.711
!MESSAGE Bundle
initial@reference :file:plugins/org.eclipse.equinox.p2.engine_1.0.100.v2009043 0-0100.jar/
was not resolved.
!SUBENTRY 2 org.eclipse.equinox.p2.engine 2 0 2009-05-10 16:28:35.713
!MESSAGE Missing imported package
org.eclipse.equinox.internal.provisional.spi.p2.repository_0 .0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.engine 2 0 2009-05-10 16:28:35.716
!MESSAGE Missing imported package
org.eclipse.equinox.internal.p2.persistence_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.engine 2 0 2009-05-10 16:28:35.718
!MESSAGE Missing imported package
org.eclipse.equinox.internal.provisional.p2.repository_0.0.0 .
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-05-10 16:28:35.720
!MESSAGE Bundle
initial@reference :file:plugins/org.eclipse.equinox.p2.metadata.repository_1.0 .100.v20090429-2126.jar/
was not resolved.
!SUBENTRY 2 org.eclipse.equinox.p2.metadata.repository 2 0 2009-05-10
16:28:35.723
!MESSAGE Missing imported package
org.eclipse.equinox.internal.p2.repository_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.metadata.repository 2 0 2009-05-10
16:28:35.725
!MESSAGE Missing imported package
org.eclipse.equinox.internal.p2.persistence_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.metadata.repository 2 0 2009-05-10
16:28:35.729
!MESSAGE Missing imported package
org.eclipse.equinox.internal.provisional.spi.p2.repository_0 .0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.metadata.repository 2 0 2009-05-10
16:28:35.732
!MESSAGE Missing imported package
org.eclipse.equinox.internal.provisional.p2.repository_0.0.0 .
!SUBENTRY 2 org.eclipse.equinox.p2.metadata.repository 2 0 2009-05-10
16:28:35.734
!MESSAGE Missing imported package
org.eclipse.equinox.internal.p2.repository.helpers_0.0.0.

!ENTRY org.eclipse.osgi 2 0 2009-05-10 16:28:35.770
!MESSAGE The following is a complete list of bundles which are not resolved,
see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-05-10 16:28:35.772
!MESSAGE Bundle com.etm.network_1.0.0 was not resolved.
!SUBENTRY 2 com.etm.network 2 0 2009-05-10 16:28:35.776
!MESSAGE Missing required bundle org.eclipse.ecf.example.collab_2.0.0.
!SUBENTRY 2 com.etm.network 2 0 2009-05-10 16:28:35.778
!MESSAGE Missing required bundle org.eclipse.ecf.docshare_2.1.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-05-10 16:28:35.780
!MESSAGE Bundle com.etm.ui_1.0.0 was not resolved.
!SUBENTRY 2 com.etm.ui 2 0 2009-05-10 16:28:35.782
!MESSAGE Missing required bundle com.etm.ui.network_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-05-10 16:28:35.783
!MESSAGE Bundle com.etm.ui.network_1.0.0 was not resolved.
!SUBENTRY 2 com.etm.ui.network 2 0 2009-05-10 16:28:35.785
!MESSAGE Missing required bundle com.etm.network_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-05-10 16:28:35.787
!MESSAGE Bundle org.eclipse.ecf.docshare_2.1.0.v20090504-0800 was not
resolved.
!SUBENTRY 2 org.eclipse.ecf.docshare 2 0 2009-05-10 16:28:35.790
!MESSAGE Missing required bundle org.eclipse.ui.editors_0.0.0.
!SUBENTRY 2 org.eclipse.ecf.docshare 2 0 2009-05-10 16:28:35.791
!MESSAGE Missing required bundle org.eclipse.ui.ide_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-05-10 16:28:35.793
!MESSAGE Bundle org.eclipse.ecf.example.collab_2.0.0.v20090504-0800 was
not resolved.
!SUBENTRY 2 org.eclipse.ecf.example.collab 2 0 2009-05-10 16:28:35.796
!MESSAGE Missing required bundle org.eclipse.ui.ide_0.0.0.
!SUBENTRY 2 org.eclipse.ecf.example.collab 2 0 2009-05-10 16:28:35.798
!MESSAGE Missing required bundle org.eclipse.ui.editors_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-05-10 16:28:35.800
!MESSAGE Bundle
org.eclipse.equinox.p2.artifact.repository_1.0.100.v20090430 -2300 was
not resolved.
!SUBENTRY 2 org.eclipse.equinox.p2.artifact.repository 2 0 2009-05-10
16:28:35.802
!MESSAGE Missing imported package
org.eclipse.equinox.internal.p2.persistence_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.artifact.repository 2 0 2009-05-10
16:28:35.805
!MESSAGE Missing imported package
org.eclipse.equinox.internal.p2.repository_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.artifact.repository 2 0 2009-05-10
16:28:35.807
!MESSAGE Missing imported package
org.eclipse.equinox.internal.p2.repository.helpers_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.artifact.repository 2 0 2009-05-10
16:28:35.810
!MESSAGE Missing imported package
org.eclipse.equinox.internal.provisional.p2.repository_0.0.0 .
!SUBENTRY 2 org.eclipse.equinox.p2.artifact.repository 2 0 2009-05-10
16:28:35.813
!MESSAGE Missing imported package
org.eclipse.equinox.internal.provisional.spi.p2.repository_0 .0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-05-10 16:28:35.816
!MESSAGE Bundle org.eclipse.equinox.p2.engine_1.0.100.v20090430-0100
was not resolved.
!SUBENTRY 2 org.eclipse.equinox.p2.engine 2 0 2009-05-10 16:28:35.818
!MESSAGE Missing required bundle
org.eclipse.equinox.p2.metadata.repository_1.0.100.
!SUBENTRY 2 org.eclipse.equinox.p2.engine 2 0 2009-05-10 16:28:35.820
!MESSAGE Missing imported package
org.eclipse.equinox.internal.p2.metadata.repository_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.engine 2 0 2009-05-10 16:28:35.822
!MESSAGE Missing imported package
org.eclipse.equinox.internal.p2.metadata.repository.io_0.0.0 .
!SUBENTRY 2 org.eclipse.equinox.p2.engine 2 0 2009-05-10 16:28:35.824
!MESSAGE Missing imported package
org.eclipse.equinox.internal.p2.persistence_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.engine 2 0 2009-05-10 16:28:35.827
!MESSAGE Missing imported package
org.eclipse.equinox.internal.provisional.p2.artifact.reposit ory_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.engine 2 0 2009-05-10 16:28:35.829
!MESSAGE Missing imported package
org.eclipse.equinox.internal.provisional.p2.metadata.reposit ory_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.engine 2 0 2009-05-10 16:28:35.831
!MESSAGE Missing imported package
org.eclipse.equinox.internal.provisional.p2.repository_0.0.0 .
!SUBENTRY 2 org.eclipse.equinox.p2.engine 2 0 2009-05-10 16:28:35.834
!MESSAGE Missing imported package
org.eclipse.equinox.internal.provisional.spi.p2.metadata.rep ository_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.engine 2 0 2009-05-10 16:28:35.836
!MESSAGE Missing imported package
org.eclipse.equinox.internal.provisional.spi.p2.repository_0 .0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-05-10 16:28:35.838
!MESSAGE Bundle
org.eclipse.equinox.p2.metadata.repository_1.0.100.v20090429 -2126 was
not resolved.
!SUBENTRY 2 org.eclipse.equinox.p2.metadata.repository 2 0 2009-05-10
16:28:35.841
!MESSAGE Missing imported package
org.eclipse.equinox.internal.p2.persistence_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.metadata.repository 2 0 2009-05-10
16:28:35.843
!MESSAGE Missing imported package
org.eclipse.equinox.internal.p2.repository_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.metadata.repository 2 0 2009-05-10
16:28:35.846
!MESSAGE Missing imported package
org.eclipse.equinox.internal.p2.repository.helpers_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.metadata.repository 2 0 2009-05-10
16:28:35.849
!MESSAGE Missing imported package
org.eclipse.equinox.internal.provisional.p2.repository_0.0.0 .
!SUBENTRY 2 org.eclipse.equinox.p2.metadata.repository 2 0 2009-05-10
16:28:35.851
!MESSAGE Missing imported package
org.eclipse.equinox.internal.provisional.spi.p2.repository_0 .0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-05-10 16:28:35.854
!MESSAGE Bundle org.eclipse.ui.editors_3.5.0.v20090429-1800b was not
resolved.
!SUBENTRY 2 org.eclipse.ui.editors 2 0 2009-05-10 16:28:35.856
!MESSAGE Missing required bundle org.eclipse.ui.ide_[3.5.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-05-10 16:28:35.858
!MESSAGE Bundle org.eclipse.ui.ide_3.5.0.I20090429-1800 was not
resolved.
!SUBENTRY 2 org.eclipse.ui.ide 2 0 2009-05-10 16:28:35.860
!MESSAGE Missing required bundle
org.eclipse.equinox.p2.engine_[1.0.100,2.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-05-10 16:28:35.862
!MESSAGE Bundle org.eclipse.ui.win32_3.2.100.v20090429-1800 [93] was not
resolved.
!SUBENTRY 2 org.eclipse.ui.win32 2 0 2009-05-10 16:28:35.864
!MESSAGE Missing host org.eclipse.ui.ide_[3.2.0,4.0.0).
Previous Topic:Eclipse plugin and declarative services
Next Topic:Problem upgrading existing automated build to use eclipse 3.5 (related to p2?)
Goto Forum:
  


Current Time: Tue Jun 22 12:34:43 GMT 2021

Powered by FUDForum. Page generated in 0.02119 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top