Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Issue in building feature - Eclipse 3.4.1
Issue in building feature - Eclipse 3.4.1 [message #596845] Wed, 06 May 2009 04:10
Nitin Bohara is currently offline Nitin BoharaFriend
Messages: 17
Registered: July 2009
Junior Member
Hi,
We have our feature developed in Eclipse 3.4.1
I tried exporting it as an archive file using export wizard and then
extract it into a fresh eclipse install. I tried switching the perspective
to my feature and it worked properly.

Now, I tried building the same feature by referring to help contents -
Plug-in Development Environment Guide > Tasks > PDE Build
The build was successful. However, when I extracted the archive in my
eclipse folder and tried switching to my feature's perspective I got an
error - Problems opening perspective
'com.infy.finacle.fss.ui.FinaclePerspective'
And the error shown in error log is :
Root exception:
java.lang.NoClassDefFoundError:
com/infy/finacle/fss/core/metadata/managers/FSSAppMetadataMa nager
at com.infy.finacle.fss.ui.FSSUIPlugin.start(Unknown Source)
at
org.eclipse.osgi.framework.internal.core.BundleContextImpl$2 .run(BundleContextImpl.java:1009)
.......

Also, there is a discrepancy in the sizes of the jars of the plugins
created by exporting the feature and by building it.

What could have gone wrong here ?
Previous Topic:IOException reading workspace metadata
Next Topic:Using p2.inf to create a directory
Goto Forum:
  


Current Time: Wed Jun 23 10:15:50 GMT 2021

Powered by FUDForum. Page generated in 0.02012 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top