Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » PDE wizard generates incorrect version number?
PDE wizard generates incorrect version number? [message #596418] Sun, 26 April 2009 22:05
Mike S is currently offline Mike SFriend
Messages: 21
Registered: July 2009
Junior Member
I have a couple of problems and I'm beginning to think they may be
related. When I use the PDE Wizard to create a org.eclipse.ui.menus plugin
it always generates a header with <?eclipse version="3.2"?> even though I
am using 3.4.1 Ganymede version as it was downloaded from the site with no
changes to it. The tutorial group I'm working with have never seen this
nor can they explain it. Anyone ever run into this?

Second, I am doing a PDE tutorial with a "visible when" clause added in
that allows a context menu item to be added to the Package Explorer when
the file selected is a Java file. I generate the plugin changes from the
Extensions tab in the manifest editor. I generate a plugin.xml file that
is identical to the Tutorials minus the 3.2 version number above. Problem
is when I select a java file from the Package Explorer the menu item
doesn't appear because it is not recognized as a subclass of
org.eclips.jdt.core.ICompilationUnit. If I change the "visible when" to
test on org.eclipse.core.resources.IFile it works. I have done a
instanceof test, printed out the class and superclass, and a toString on
the selected Java file from the execute method of my method that
implements AbstractHandler and all indications are the Java file is a
org.eclipse.core.resources.IFile and not a ICompilationUnit.But the author
of the tutorial says this can't be so. Anyone ever run into this kind of
problem?

Any guidance would be greatly appreciated,
Thanks, Mike
Previous Topic:PDE wizard generates incorrect version number?
Next Topic:PDE Wizard generates inorrect version header
Goto Forum:
  


Current Time: Thu Jun 24 13:39:05 GMT 2021

Powered by FUDForum. Page generated in 0.01616 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top