Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » p2 director can't find binary,org.eclipse.equinox.executable_root
p2 director can't find binary,org.eclipse.equinox.executable_root [message #595342] Thu, 16 April 2009 02:45
Eclipse UserFriend
Originally posted by: wbeckwith.gmail.com

The director complains of not finding the
org.eclipse.equinox.executable_root binary @ version
3.3.200.v20090306-1900-7M-FhJFHQfz-5DbTcLIwDaa. Where is this coming
from? Since I'm building a windows product with a windows SDK pointed
at a target with Eclipse 3.5M6 SDK + Eclipse 3.5M6 Delta Pack, there
should be no reason it can't find the executable I imagine.

1.) Where is this org.eclipse.equinox.executable_root
plugin/feature/fragment?

2.) What does the director application used it for?

If I can get those question answered then I can hopefully get a product
actually provisioned.



runDirector:
Project base dir set to: D:\dev\workspace-main\lisa-product.builder\build
[ant] calling target(s) [runDirector] in build file
D:\dev\eclipse-3.5M6\plugins\org.eclipse.pde.build_3.5.0.v20 090312-1500\scripts\genericTargets.xml
parsing buildfile
D:\dev\eclipse-3.5M6\plugins\org.eclipse.pde.build_3.5.0.v20 090312-1500\scripts\genericTargets.xml
with URI =
file:/D:/dev/eclipse-3.5M6/plugins/org.eclipse.pde.build_3.5 .0.v20090312-1500/scripts/genericTargets.xml
Project base dir set to: D:\dev\workspace-main\lisa-product.builder\build
Override ignored for property "configs"
Override ignored for property "fetchTag"
Override ignored for property "customEESources"
Override ignored for property "transformedRepoLocation"
Override ignored for property "buildingOSGi"
Override ignored for property "generateJnlp"
Override ignored for property "signJars"
Override ignored for property "generateFeatureVersionSuffix"
Override ignored for property "generateVersionsLists"
Override ignored for property "groupConfigurations"
Override ignored for property "pluginPath"
Override ignored for property "filteredDependencyCheck"
Override ignored for property "filterP2Base"
[ant] Entering
D:\dev\eclipse-3.5M6\plugins\org.eclipse.pde.build_3.5.0.v20 090312-1500\scripts\genericTargets.xml...
Build sequence for target(s) `runDirector' is [runDirector]
Complete build sequence is [runDirector, noDefault, transformRepos,
init, assembleElement, processElement, processFlat, gatherLogs,
gatherSources, packageElement, processViaFeature, generateScript,
fetchElement, gatherBinaries, cleanElement, ]

runDirector:
Override ignored for property "p2.director.version"
[java] Executing 'C:\jdk1.5.x\jre\bin\java.exe' with arguments:
[java]
'-Declipse.p2.data.area=D:\dev\workspace-main\lisa-product.b uilder/build/tmp/eclipse/p2'
[java] '-Declipse.p2.MD5Check=false'
[java] '-jar'
[java]
'D:\dev\eclipse-3.5M6\plugins\org.eclipse.equinox.launcher_1 .0.200.v20090306-1900.jar'
[java] '-application'
[java] 'org.eclipse.equinox.p2.director.app.application'
[java] '-nosplash'
[java] '--launcher.suppressErrors'
[java] '-consoleLog'
[java] '-flavor'
[java] 'tooling'
[java] '-installIU'
[java] 'com.itko.lisa.workstation.product'
[java] '-version'
[java] '1.0.0'
[java] '-p2.os'
[java] 'win32'
[java] '-p2.ws'
[java] 'win32'
[java] '-p2.arch'
[java] 'x86'
[java] '-roaming'
[java] '-profile'
[java] 'profile'
[java] '-profileProperties'
[java] 'org.eclipse.update.install.features=true'
[java] '-metadataRepository'
[java]
'file:D:\dev\workspace-main\lisa-product.builder/build/build Repo'
[java] '-artifactRepository'
[java]
'file:D:\dev\workspace-main\lisa-product.builder/build/build Repo'
[java] '-destination'
[java] 'D:\dev\workspace-main\lisa-product.builder/build/tmp/eclips e'
[java] '-bundlepool'
[java] 'D:\dev\workspace-main\lisa-product.builder/build/tmp/eclips e'
[java]
[java] The ' characters around the executable and arguments are
[java] not part of the command.
[java] Installing com.itko.lisa.workstation.product 1.0.0.
[java] Installation failed.
[java] !SESSION 2009-04-15 19:10:19.179
-----------------------------------------------
[java] eclipse.buildId=I20090313-0100
[java] java.version=1.5.0_17
[java] java.vendor=Sun Microsystems Inc.
[java] BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
[java] Framework arguments: -application
org.eclipse.equinox.p2.director.app.application
--launcher.suppressErrors -flavor tooling -installIU
com.itko.lisa.workstation.product -version 1.0.0 -p2.os win32 -p2.ws
win32 -p2.arch x86 -roaming -profile profile -profileProperties
org.eclipse.update.install.features=true -metadataRepository
file:D:\dev\workspace-main\lisa-product.builder/build/buildR epo
-artifactRepository
file:D:\dev\workspace-main\lisa-product.builder/build/buildR epo
-destination
D:\dev\workspace-main\lisa-product.builder/build/tmp/eclipse -bundlepool
D:\dev\workspace-main\lisa-product.builder/build/tmp/eclipse
[java] Command-line arguments: -application
org.eclipse.equinox.p2.director.app.application
--launcher.suppressErrors -consoleLog -flavor tooling -installIU
com.itko.lisa.workstation.product -version 1.0.0 -p2.os win32 -p2.ws
win32 -p2.arch x86 -roaming -profile profile -profileProperties
org.eclipse.update.install.features=true -metadataRepository
file:D:\dev\workspace-main\lisa-product.builder/build/buildR epo
-artifactRepository
file:D:\dev\workspace-main\lisa-product.builder/build/buildR epo
-destination
D:\dev\workspace-main\lisa-product.builder/build/tmp/eclipse -bundlepool
D:\dev\workspace-main\lisa-product.builder/build/tmp/eclipse
[java]
[java] !ENTRY org.eclipse.equinox.p2.engine 4 4 2009-04-15
19:10:31.557
[java] !MESSAGE An error occurred while collecting items to be
installed
[java] !SUBENTRY 1 org.eclipse.equinox.p2.engine 4 0 2009-04-15
19:10:31.557
[java] !MESSAGE session context was:(profile=profile, phase=,
operand=, action=).
[java] !SUBENTRY 1 org.eclipse.equinox.p2.artifact.repository 4 0
2009-04-15 19:10:31.557
[java] !MESSAGE No repository found containing:
binary,org.eclipse.equinox.executable_root,3.3.200.v20090306 -1900-7M-FhJFHQfz-5DbTcLIwDaa
[ant] Exiting
D:\dev\eclipse-3.5M6\plugins\org.eclipse.pde.build_3.5.0.v20 090312-1500\scripts\genericTargets.xml.
[antcall] Exiting
D:\dev\workspace-main\lisa-product.builder\build\package.org .eclipse.pde.build.container.feature.win32.win32.x86.xml.
[ant] Exiting
D:\dev\workspace-main\lisa-product.builder\build\package.org .eclipse.pde.build.container.feature.win32.win32.x86.xml.
[ant] Exiting
D:\dev\workspace-main\lisa-product.builder\customTargets.xml .
[ant] Exiting
D:\dev\workspace-main\lisa-product.builder\build\package.org .eclipse.pde.build.container.feature.all.xml.
[ant] Exiting
D:\dev\eclipse-3.5M6\plugins\org.eclipse.pde.build_3.5.0.v20 090312-1500\scripts\genericTargets.xml.
[antcall] Exiting
D:\dev\workspace-main\lisa-product.builder\customTargets.xml .
[ant] Exiting
D:\dev\workspace-main\lisa-product.builder\customTargets.xml .
[antcall] Exiting
D:\dev\eclipse-3.5M6\plugins\org.eclipse.pde.build_3.5.0.v20 090312-1500\scripts\productBuild\productBuild.xml.

BUILD FAILED
D:\dev\eclipse-3.5M6\plugins\org.eclipse.pde.build_3.5.0.v20 090312-1500\scripts\productBuild\productBuild.xml:32:
The following error occurred while executing this line:
D:\dev\eclipse-3.5M6\plugins\org.eclipse.pde.build_3.5.0.v20 090312-1500\scripts\build.xml:115:
The following error occurred while executing this line:
D:\dev\workspace-main\lisa-product.builder\customTargets.xml :12: The
following error occurred while executing this line:
D:\dev\eclipse-3.5M6\plugins\org.eclipse.pde.build_3.5.0.v20 090312-1500\scripts\productBuild\allElements.xml:10:
The following error occurred while executing this line:
D:\dev\eclipse-3.5M6\plugins\org.eclipse.pde.build_3.5.0.v20 090312-1500\scripts\genericTargets.xml:182:
The following error occurred while executing this line:
D:\dev\workspace-main\lisa-product.builder\build\package.org .eclipse.pde.build.container.feature.all.xml:23:
The following error occurred while executing this line:
D:\dev\workspace-main\lisa-product.builder\build\package.org .eclipse.pde.build.container.feature.all.xml:15:
The following error occurred while executing this line:
D:\dev\eclipse-3.5M6\plugins\org.eclipse.pde.build_3.5.0.v20 090312-1500\scripts\productBuild\allElements.xml:44:
The following error occurred while executing this line:
D:\dev\workspace-main\lisa-product.builder\build\package.org .eclipse.pde.build.container.feature.win32.win32.x86.xml:89:
The following error occurred while executing this line:
D:\dev\workspace-main\lisa-product.builder\build\package.org .eclipse.pde.build.container.feature.win32.win32.x86.xml:766 :
The following error occurred while executing this line:
D:\dev\eclipse-3.5M6\plugins\org.eclipse.pde.build_3.5.0.v20 090312-1500\scripts\genericTargets.xml:213:
Java returned: 13

Wb
Previous Topic:Property sheet and ISelectionProvider
Next Topic:Importing a plug-in to modify
Goto Forum:
  


Current Time: Sun Jun 20 05:02:47 GMT 2021

Powered by FUDForum. Page generated in 0.01716 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top