Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » M2M (model-to-model transformation) » [ATL] .asm not generated after install of ATL 2.0RC2
[ATL] .asm not generated after install of ATL 2.0RC2 [message #59926] Thu, 30 August 2007 11:28 Go to next message
Eclipse UserFriend
Originally posted by: botterwe.uni-koblenz.de

Hi all,

PROBLEM

As documented on
http://www.eclipse.org/m2m/atl/download/
I installed ATL 2.0RC2 from the update site at
download.eclipse.org/modeling/m2m/atl/updates/2.0.0

When I edit and save an .atl file I would expect that the corresponding
..asm file is generated automatically. However, this does not happen.


SOME IDEAS

For earlier versions of ATL one had to install additional resources
(ANTLR and mdr-standalone.zip). Is this also required for the install
via update site? Where do I have to put the files?


Thanks for any hints,
Goetz
Re: [ATL] .asm not generated after install of ATL 2.0RC2 [message #59954 is a reply to message #59926] Thu, 30 August 2007 11:44 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: Hugo.Bruneliere.univ-nantes.fr

Goetz Botterweck a écrit :
> Hi all,

Hi Goetz,

>
> PROBLEM
>
> As documented on
> http://www.eclipse.org/m2m/atl/download/
> I installed ATL 2.0RC2 from the update site at
> download.eclipse.org/modeling/m2m/atl/updates/2.0.0
>
> When I edit and save an .atl file I would expect that the corresponding
> .asm file is generated automatically. However, this does not happen.
>

Is the project containing the file an ATL one (i.e. a project which is
of the "ATL" nature)? If not, it is normal that the .asm file is not
generated.

You can also check if the "Project->Build Automatically" option (from
the menu bar) has been selected.

>
> SOME IDEAS
>
> For earlier versions of ATL one had to install additional resources
> (ANTLR and mdr-standalone.zip). Is this also required for the install
> via update site? Where do I have to put the files?
>

No, with the latest version of ATL you don't have to add the ANTLR jar
which is now already included (and the mdr-standalone archive is
required only if you want to use the mdr4atl driver).

>
> Thanks for any hints,
> Goetz

Best regards,

Hugo

--
--------------------------------------------------------
Hugo Bruneliere - R&D Engineer
ATLAS Group (INRIA & LINA) - University of Nantes
2, rue de la Houssiniere
44322 Nantes Cedex 3 - France
office +33 2 51 12 58 10 /\ cell.+33 6 07 42 45 30
EMail: Hugo.Bruneliere@univ-nantes.fr
http://www.sciences.univ-nantes.fr/lina/atl/
--------------------------------------------------------
Re: [ATL] .asm not generated after install of ATL 2.0RC2 [message #59977 is a reply to message #59926] Thu, 30 August 2007 12:03 Go to previous messageGo to next message
Vincent MAHE is currently offline Vincent MAHEFriend
Messages: 129
Registered: July 2009
Senior Member
Goetz Botterweck a écrit :
> Hi all,
>
> PROBLEM
>
> As documented on
> http://www.eclipse.org/m2m/atl/download/
> I installed ATL 2.0RC2 from the update site at
> download.eclipse.org/modeling/m2m/atl/updates/2.0.0
>
> When I edit and save an .atl file I would expect that the corresponding
> .asm file is generated automatically. However, this does not happen.
>
Are you under the "ATL perspective" ?

Vincent
Re: [ATL] .asm not generated after install of ATL 2.0RC2 [message #60001 is a reply to message #59954] Thu, 30 August 2007 12:46 Go to previous message
Eclipse UserFriend
Originally posted by: botterwe.uni-koblenz.de

Hugo Bruneliere wrote:

> Is the project containing the file an ATL one (i.e. a project which is
> of the "ATL" nature)? If not, it is normal that the .asm file is not
> generated.

Yes, that was the problem. After recreating the project as an "ATL
Project" the .asm files are generated as usual.

I did not think about this earlier because I falsely suspected that it
was caused by not installed 3rd party components (ANTLR).

>> For earlier versions of ATL one had to install additional resources
>> (ANTLR and mdr-standalone.zip). Is this also required for the install
>> via update site? Where do I have to put the files?
>>
>
> No, with the latest version of ATL you don't have to add the ANTLR jar
> which is now already included (and the mdr-standalone archive is
> required only if you want to use the mdr4atl driver).

Thanks for the quick help.
Goetz
Previous Topic:UserInteraction in Transformationprocess
Next Topic:New ATL use case: Models Measurement
Goto Forum:
  


Current Time: Sun Apr 11 23:07:23 GMT 2021

Powered by FUDForum. Page generated in 0.02339 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top