Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » XML Schema Definition (XSD) » plugin not loaded when I include XSD dependency
plugin not loaded when I include XSD dependency [message #589529] Tue, 29 June 2004 19:55
Eclipse UserFriend
Originally posted by: kharris.unveil.com

I have a plugin that provides an XML editor which extends TextEditor. This
worked fine in Eclipse 2.x. Now that I've moved to Eclipse 3.0, I can no
longer get my editor to work. My editor provides schema completion, which
relies on the EMF and XSD plugins. If I remove those plugins from my plugin
dependencies, my editor comes up fine. Of course, when I trigger the schema
completion, I get a class not found exception in EMF. All of this makes
sense. But when I add my dependencies, (and I've tried this with multiple
versions of Eclipse, XSD, and EMF), as soon as I add either EMF or XSD or
both to my dependencies, and then start up my runtime workspace, my editor
is gone. There are no error messages of any kind - it's just missing. If I
put a break point in my plugin constructor, I never get there. If no one has
an answer for me, can you please tell me where to begin trying to debug
this?

THANK YOU!!! (note the sound of desperation)
Karen
Previous Topic:Re: EMF/SDO/XSD Update Site
Next Topic:plugin not loaded when I include XSD dependency
Goto Forum:
  


Current Time: Tue Oct 20 09:51:06 GMT 2020

Powered by FUDForum. Page generated in 0.01761 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top