Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit / JGit » Linux permissions issue
Linux permissions issue [message #577729] Thu, 25 February 2010 23:15
Alan Chaney is currently offline Alan ChaneyFriend
Messages: 20
Registered: January 2010
Junior Member

If this is a bug I'm happy to file a bug report. In my project I had some files which weren't under version control. I tried using the egit 'Add to version control' which seemed to work - they had the appropriate decorator against the icon. However, when I tried to commit they got the * decorator.

I came out and used command line git version on centos 5.3 X64. Using git status gave me the file list as modified
and not committed.
]$ git status
# On branch master
# Changes to be committed:
# (use "git reset HEAD <file>..." to unstage)
# modified: public/images/bg/beige_bg.jpg
# modified: public/images/bg/header_bg.jpg
# modified: public/images/bg/header_bg_2.jpg
# modified: public/images/bg/header_bg_3.jpg
# modified: public/images/bg/img01.jpg
# modified: public/images/bg/img08.gif
# modified: public/images/bg/sidebar-header.jpg
# modified: public/images/bg/title-header.jpg
# modified: public/images/facebook-button-2.jpg
# modified: public/images/favicon.gif
# modified: public/images/header_homepage.png
# modified: public/images/kestrel_logo-2.jpg
# modified: public/images/potrero_logo-2.jpg
# modified: public/images/potrero_logo_header.gif
# modified: public/images/text-logo_2.jpg
# modified: public/images/twitter-button-2.jpg
# modified: public/stylesheets/layout.css

I then went git commit -a and got:

$ git commit -a
Created commit 9f16105: Committed changes to the images and stylesheet dir stuff which didn't work in eclipse
16 files changed, 0 insertions(+), 0 deletions(-)
mode change 100644 => 100755 public/images/bg/beige_bg.jpg
mode change 100644 => 100755 public/images/bg/header_bg.jpg
mode change 100644 => 100755 public/images/bg/header_bg_2.jpg
mode change 100644 => 100755 public/images/bg/header_bg_3.jpg
mode change 100644 => 100755 public/images/bg/img01.jpg
mode change 100644 => 100755 public/images/bg/img08.gif
mode change 100644 => 100755 public/images/bg/sidebar-header.jpg
mode change 100644 => 100755 public/images/bg/title-header.jpg
mode change 100644 => 100755 public/images/facebook-button-2.jpg
mode change 100644 => 100755 public/images/favicon.gif
mode change 100644 => 100755 public/images/header_homepage.png
mode change 100644 => 100755 public/images/kestrel_logo-2.jpg
mode change 100644 => 100755 public/images/potrero_logo-2.jpg
mode change 100644 => 100755 public/images/potrero_logo_header.gif
mode change 100644 => 100755 public/images/text-logo_2.jpg
mode change 100644 => 100755 public/images/twitter-button-2.jpg
mode change 100644 => 100755 public/stylesheets/layout.css

obviously the first line is my comment in the commmit

git status then showed them to be OK and re-opening eclipse showed them as commited (little yellow disk decorator)

From what I can work out it seems that the original file modes didn't have the execute bit set. Oddly, after the commit, they still only have the execute bit set on the user (not the group) even though the mode change message above would indicate that it should have become rwxr-xr-x. Obviously this is nothing to do with egit as I used the C/L git to make the changes.

So my ponit is that it seems that egit couldn't commit a file which did not have user execute and didn't know how to say anything about it.

Please tell me if one or more of these a bug:

1. egit couldn't commit a file without user execute permission
2. egit couldn't or didn't change the file execute permission
3. egit didn't tell me it couldn't do 1. or 2.?

and if so, I'll file a bug report.

I have to admit to being a complete newbie with git /egit but I hope this makes more sense to an expert.


Alan Chaney
Previous Topic:Linux permissions issue
Next Topic:Adding origin
Goto Forum:

Current Time: Mon Aug 03 19:25:53 GMT 2020

Powered by FUDForum. Page generated in 0.03729 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top