Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » Issue with loading properties from a CDO resource in Library Example project
Issue with loading properties from a CDO resource in Library Example project [message #561370] Mon, 14 November 2005 07:44
Eclipse UserFriend
Originally posted by: tvalence1.cox.net

Greetings,



I have been investigating an issue with populating a model with properties
from a CDO resource that has been persisted in MySql. I believe that I have
been able to reproduce a similar behavior with the Library Example project
using the latest code from CVS.



In this instance, the
org.eclipse.net4j.cdo.test.actions.LoadResourceAction.loadRe source method
succeeds in accessing and printing the name of the first author (Einstein),
but throws an exception when trying to access the second author (Dahl)
object from the library resource. The relevant code snippet and a debug
trace of LoadResourceAction's operation is attached for reference.



Note that an expansion of the persisted library resource using the Library
Model Editor works with no problems in my eClipse 3.1.0/JDK 1.5 development
environment.



Please advise on how I can resolve this issue. I can send additional
configuration and trace information if this can further define the problem.



Thanks!

= Ted




Previous Topic:CDO library example fails to create resource
Next Topic:EODM release date
Goto Forum:
  


Current Time: Mon Sep 26 09:57:52 GMT 2022

Powered by FUDForum. Page generated in 0.01836 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top