Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Graphiti » Rendering decorators for connections
Rendering decorators for connections [message #560232] Tue, 21 September 2010 15:54 Go to next message
Shenxue Zhou is currently offline Shenxue ZhouFriend
Messages: 60
Registered: July 2009
Member
In the Tutorial example, a warning decorator for the ECLass pictogram was added if the class name started with a lower case letter.

Is rendering decorator supported for connections? My use case is I want to model process flows using connections. Process flow names are displayed with connection text decorators. If a process flow is invalid, I'd like to display a warning icon in front of the process name which is modeled using connection text decorator.

Does Graphiti support this type of rendering decorators? I tried to follow the Tutorial example to add an image rendering decorator to the connection text decorator but could not get it to work. If Graphiti support this type of rendering decorator, could you give me some code snippet in the context of the Tutorial example?

Thanks!

Shenxue
Re: Rendering decorators for connections [message #626290 is a reply to message #560232] Wed, 22 September 2010 13:46 Go to previous messageGo to next message
Matthias Gorning is currently offline Matthias GorningFriend
Messages: 81
Registered: April 2010
Location: Germany
Member
There was a small bug in the framework. I have fixed it today.

Now you can provide an image decorator for your ConnectionDecorator via the ToolBehaviorProvider. You can do it in the same way, as we did it in our tutorial for the ECLass.

One remark: Currently you must place your image decorator in the visible area - that means inside the text decorator. You can set the location with:

ImageDecorator imageRenderingDecorator = new ImageDecorator(IPlatformImageConstants.IMG_ECLIPSE_ERROR_TSK );
imageRenderingDecorator.setX(0);
imageRenderingDecorator.setY(0);


We will work on a solution to place it in front of the text decorator. But this needs some time.

Regards,
Matthias
Re: Rendering decorators for connections [message #632357 is a reply to message #626290] Tue, 12 October 2010 16:24 Go to previous messageGo to next message
Shenxue Zhou is currently offline Shenxue ZhouFriend
Messages: 60
Registered: July 2009
Member
Matthias Gorning wrote on Wed, 22 September 2010 07:46
There was a small bug in the framework. I have fixed it today.

Now you can provide an image decorator for your ConnectionDecorator via the ToolBehaviorProvider. You can do it in the same way, as we did it in our tutorial for the ECLass.

One remark: Currently you must place your image decorator in the visible area - that means inside the text decorator. You can set the location with:

ImageDecorator imageRenderingDecorator = new ImageDecorator(IPlatformImageConstants.IMG_ECLIPSE_ERROR_TSK );
imageRenderingDecorator.setX(0);
imageRenderingDecorator.setY(0);


We will work on a solution to place it in front of the text decorator. But this needs some time.

Regards,
Matthias



Matthias,

Any update in finding solution to place decorator in front of text decorator? Do you want me to open a bugzilla bug to track this issue?

Thanks!

Shenxue
Re: Rendering decorators for connections [message #633527 is a reply to message #632357] Mon, 18 October 2010 10:32 Go to previous messageGo to next message
Matthias Gorning is currently offline Matthias GorningFriend
Messages: 81
Registered: April 2010
Location: Germany
Member
Sorry, currently there is no progress on this topic. We had a lot of other important things to do.

It would be very helpful if you open a bugzilla bug to track this issue.

Hopefully we can address this problem in one of our next development takts.

Regards,
Matthias
Re: Rendering decorators for connections [message #634192 is a reply to message #633527] Wed, 20 October 2010 18:30 Go to previous message
Shenxue Zhou is currently offline Shenxue ZhouFriend
Messages: 60
Registered: July 2009
Member
I've created a bugzilla bug https://bugs.eclipse.org/bugs/show_bug.cgi?id=328279 to track this issue.
Previous Topic:dealing with canceled commands (or ones that didn't apply changes)
Next Topic:label for a shape
Goto Forum:
  


Current Time: Mon May 25 15:59:05 GMT 2020

Powered by FUDForum. Page generated in 0.02286 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top