Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » M2M (model-to-model transformation) » [ATL] auto-completion
[ATL] auto-completion [message #556630] Thu, 02 September 2010 07:27 Go to next message
ebtesam  is currently offline ebtesam Friend
Messages: 5
Registered: August 2010
Junior Member
Hi all,

I wonder if auto-completion in ATL editor is working !!
Is there such a feature as same as what in java editor ?

If yes I wonder how can I enable it !!
Re: [ATL] auto-completion [message #556643 is a reply to message #556630] Thu, 02 September 2010 08:05 Go to previous messageGo to next message
Sylvain EVEILLARD is currently offline Sylvain EVEILLARDFriend
Messages: 556
Registered: July 2009
Senior Member
When you create an ATL transformation using the wizard and if you indicate the meta-models, it will automatically initialize the transformation with the informations needed for the auto-completion.

That is :
-- @nsURI nameOfTheMetaModel=uri
before the ATL module declaration
Re: [ATL] auto-completion [message #556660 is a reply to message #556630] Thu, 02 September 2010 08:40 Go to previous messageGo to next message
Vincent MAHE is currently offline Vincent MAHEFriend
Messages: 129
Registered: July 2009
Senior Member
Le 02/09/2010 09:27, ebtesam a écrit :
> Hi all,
>
> I wonder if auto-completion in ATL editor is working !!
> Is there such a feature as same as what in java editor ?
>
> If yes I wonder how can I enable it !!

You need to declare your metamodels at the beginning of the module file:

-- @path InMM=/org.eclipse.myproject/model/MyMM.ecore
-- @nsURI OutMM=http://org.eclipse.AnotherMM/1.0/toto

The first form is for metamodels in the workspace, second for registered
metamodels.
--
Cordialement

Vincent MAHÉ

Ingénieur Expert - Projet IDM++ - Équipe AtlanMod
École des Mines de Nantes
La Chantrerie - 4, rue Alfred Kastler
B.P. 20722 - F-44307 NANTES Cedex 3
Tel: (33)2 51 85 81 00
Re: [ATL] auto-completion [message #557146 is a reply to message #556630] Sun, 05 September 2010 06:32 Go to previous messageGo to next message
ebtesam  is currently offline ebtesam Friend
Messages: 5
Registered: August 2010
Junior Member
THANKS for your answers

I did the same as what you suggested
I used the editor wizards and i declare it by hand
but still not working !!

-- @path A=/projectQ/SS.ecore
-- @path B=/projectQ/MM.ecore

module m;
create OUT : B from IN : A;

rule ABC{
from
s:A!NODE
to
mo: B!Model (
rate<- s. (here I don't know why i did not get autocompletion when i write dot . )
}


I have this issue in both eclipse 3.5 and 3.4

[Updated on: Sun, 05 September 2010 06:36]

Report message to a moderator

Re: [ATL] auto-completion [message #560134 is a reply to message #557146] Tue, 21 September 2010 10:00 Go to previous message
Elhamlaoui Mahmoud is currently offline Elhamlaoui MahmoudFriend
Messages: 268
Registered: March 2010
Senior Member
Hi,

you can try to go to "preferences" and you will find a tab ATL->Editor->codeAssist and you will find a checkbox "enable auto activation".
perhaps it will work wit this

Cordialement
Mahmoud
Previous Topic:ATL - if then else
Next Topic:[ATL] Lazy rules and multiple instantiations
Goto Forum:
  


Current Time: Tue Jun 25 07:44:38 GMT 2019

Powered by FUDForum. Page generated in 0.01371 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top