Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » PDT plugins configured correctly, but no php support
PDT plugins configured correctly, but no php support [message #55728] Thu, 27 September 2007 17:15 Go to next message
Eclipse UserFriend
Originally posted by: laura.thurber.intraisp.com

I'm running on Ubuntu 7.04, PHP 5.2.1, Java 5.0, Eclipse 3.2.0.

I've downloaded org.eclipse.php_feature-1.0-R20070917.zip
and org.zend.php.debug_feature-I20070905.zip, and dropped both into
/usr/local/lib/eclipse/features & plugins directories. Eclipse reports
that both are configured correctly, but I cannot associate .php files with
a PHP Editor, nor can I see any sort of PHP support anywhere (can't create
a PHP project, can't get syntax highlighting, etc).

Is there another package that I should have installed?

Thanks!
-Laura
Re: PDT plugins configured correctly, but no php support [message #55810 is a reply to message #55728] Thu, 27 September 2007 19:44 Go to previous messageGo to next message
D Kelsey is currently offline D KelseyFriend
Messages: 232
Registered: July 2009
Senior Member
Hi Laura,
PDT 1.0 as a list of pre-reqs starting with
eclipse 3.3
WTP 2.0
DTP 1.5
EMF 3.3

An easier way is to download the all in one package for limux.

Cheers
Dave Kelsey

Laura Thurebr wrote:
> I'm running on Ubuntu 7.04, PHP 5.2.1, Java 5.0, Eclipse 3.2.0.
>
> I've downloaded org.eclipse.php_feature-1.0-R20070917.zip
> and org.zend.php.debug_feature-I20070905.zip, and dropped both into
> /usr/local/lib/eclipse/features & plugins directories. Eclipse reports
> that both are configured correctly, but I cannot associate .php files with
> a PHP Editor, nor can I see any sort of PHP support anywhere (can't create
> a PHP project, can't get syntax highlighting, etc).
>
> Is there another package that I should have installed?
>
> Thanks!
> -Laura
Re: PDT plugins configured correctly, but no php support [message #56295 is a reply to message #55810] Mon, 01 October 2007 16:23 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: dabukun.gmail.com

I'm having the same issue, and I downloaded the All-In-One package. I've
tried several different versions of the all-in-one package to no avail.
Eclipse runs fine but I have no PHP perspective, nor do I get any options
to create a PHP project, file, etc. I'm completely stumped; if I go to
Help->Software Updates->Find and Install, I can see all of the PDT stuff
listed there and it all seems to be fine. Any ideas?
Re: PDT plugins configured correctly, but no php support [message #56303 is a reply to message #56295] Mon, 01 October 2007 17:36 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: ganoro.gmail.com

you can start with the java version Eclipse use. it should be 1.5 or
greater , double check which JVM is used for eclipse as this is a common
problem developers usually encounter.
Re: PDT plugins configured correctly, but no php support [message #57009 is a reply to message #56295] Fri, 05 October 2007 13:35 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: watchman291273.hotmail.com

Same for me after installing PDT 1.0 all in one.

I have a former all in one package (with eclipse 3.2) and I had the php
perspective right from the start.

With PDT 1.0, all the types of project I can choose from is: Java and CVS.
(lacking C, C++, J2E, PHP,.....)

I'll see if it's not a problem caused by the version of Java, but it's quite
messy for an all in one package.


"David Davis" <dabukun@gmail.com> a
Re: PDT plugins configured correctly, but no php support [message #57035 is a reply to message #56303] Fri, 05 October 2007 14:09 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: watchman291273.hotmail.com

http://wiki.eclipse.org/Graphical_Eclipse_FAQs#How_do_I_find _out_which_Java_runtime_environment_is_being_used_to_run_my_ Eclipse.3F

Thanks Roy. They should make it clear on the download page.

"Roy Ganor" <ganoro@gmail.com> a
Re: PDT plugins configured correctly, but no php support [message #60002 is a reply to message #55810] Tue, 30 October 2007 19:49 Go to previous messageGo to next message
Bill Busen is currently offline Bill BusenFriend
Messages: 2
Registered: July 2009
Junior Member
I likewise downloaded the All-in-one (OS X 10.3) and have no php-specific
support. I will check for Java 1.5 when I am at that system this evening.
Re: PDT plugins configured correctly, but no php support DIAGNOSED [message #60193 is a reply to message #60002] Fri, 02 November 2007 16:31 Go to previous message
Bill Busen is currently offline Bill BusenFriend
Messages: 2
Registered: July 2009
Junior Member
In my case, the problem is that OS X 10.3 does not support Java 1.5.
Therefore, PDT cannot be used without at least Tiger (OS X 10.4). I'm
pretty sure this was not documented; if I verify it isn't, I will report
the documentation bug, but I may not get to it soon, as this problem has
shortened my schedule on other things.
Previous Topic:Bug 207098 and Java Runtime
Next Topic:pdt documentation for newbie?
Goto Forum:
  


Current Time: Sun Feb 05 13:41:04 GMT 2023

Powered by FUDForum. Page generated in 1.07734 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top