Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Eclipse will not start
Eclipse will not start [message #551890] Tue, 10 August 2010 02:42 Go to next message
Ram is currently offline RamFriend
Messages: 21
Registered: July 2009
Junior Member
Running ubuntu 10.04 X64. been working on RAP. Ubuntu was updated. a
yesterday. Now when I try to start eclipse, I get an error and eclipse
won't re-start.
Backed up all my projects, deleted eclipse folder, deleted
$HOME/.eclipse, deleted $HOME/workspace.
Unpacked file and tried to re-start same error.
Uninstalled sun java and re-installed - same error. Anyone have any
suggestions?

Java verion:
java version "1.6.0_18"
OpenJDK Runtime Environment (IcedTea6 1.8) (6b18-1.8-4ubuntu3)
OpenJDK 64-Bit Server VM (build 16.0-b13, mixed mode)



Here is what is shown in the error window:
JVM terminated. Exit code=1
/usr/bin/java
-Dosgi.requiredJavaVersion=1.5
-XX:MaxPermSize=256m
-Xms40m
-Xmx512m
-jar
/home/ramm/eclipse/plugins/org.eclipse.equinox.launcher_1.1. 0.v20100507.jar
-os linux
-ws gtk
-arch x86_64
-showsplash
-launcher /home/ramm/eclipse/eclipse
-name Eclipse
--launcher.library
/home/ramm/eclipse/plugins/org.eclipse.equinox.launcher.gtk. linux.x86_64_1.1.0.v20100503/eclipse_1307.so
-startup
/home/ramm/eclipse/plugins/org.eclipse.equinox.launcher_1.1. 0.v20100507.jar
-exitdata 15d000f
-product org.eclipse.epp.package.rcp.product
-vm /usr/bin/java
-vmargs
-Dosgi.requiredJavaVersion=1.5
-XX:MaxPermSize=256m
-Xms40m
-Xmx512m
-jar
/home/ramm/eclipse/plugins/org.eclipse.equinox.launcher_1.1. 0.v20100507.jar
Re: Eclipse will not start [message #552180 is a reply to message #551890] Wed, 11 August 2010 07:45 Go to previous message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2426
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi Ram,

you could try Oracle (Sun) JDK 6 instead of OpenJDK. It looks like a JVM
problem. Please use Oracle (Sun) Java 6 update 20 and not the latest
update 21 to avoid problems described here [1].

[1] http://www.infoq.com/news/2010/07/eclipse-java-6u21

Best,
Ivan

On 08/10/2010 5:42 AM, Ram wrote:
> Running ubuntu 10.04 X64. been working on RAP. Ubuntu was updated. a
> yesterday. Now when I try to start eclipse, I get an error and eclipse
> won't re-start.
> Backed up all my projects, deleted eclipse folder, deleted
> $HOME/.eclipse, deleted $HOME/workspace.
> Unpacked file and tried to re-start same error.
> Uninstalled sun java and re-installed - same error. Anyone have any
> suggestions?
>
> Java verion:
> java version "1.6.0_18"
> OpenJDK Runtime Environment (IcedTea6 1.8) (6b18-1.8-4ubuntu3)
> OpenJDK 64-Bit Server VM (build 16.0-b13, mixed mode)
>
>
>
> Here is what is shown in the error window:
> JVM terminated. Exit code=1
> /usr/bin/java
> -Dosgi.requiredJavaVersion=1.5
> -XX:MaxPermSize=256m
> -Xms40m
> -Xmx512m
> -jar
> /home/ramm/eclipse/plugins/org.eclipse.equinox.launcher_1.1. 0.v20100507.jar
> -os linux
> -ws gtk
> -arch x86_64
> -showsplash
> -launcher /home/ramm/eclipse/eclipse
> -name Eclipse
> --launcher.library
> /home/ramm/eclipse/plugins/org.eclipse.equinox.launcher.gtk. linux.x86_64_1.1.0.v20100503/eclipse_1307.so
> -startup
> /home/ramm/eclipse/plugins/org.eclipse.equinox.launcher_1.1. 0.v20100507.jar
> -exitdata 15d000f
> -product org.eclipse.epp.package.rcp.product
> -vm /usr/bin/java
> -vmargs
> -Dosgi.requiredJavaVersion=1.5
> -XX:MaxPermSize=256m
> -Xms40m
> -Xmx512m
> -jar
> /home/ramm/eclipse/plugins/org.eclipse.equinox.launcher_1.1. 0.v20100507.jar
Previous Topic:war deployment with products: how to access RAP servlet?
Next Topic:Problem while resizing firefox
Goto Forum:
  


Current Time: Fri Mar 01 05:33:57 GMT 2024

Powered by FUDForum. Page generated in 0.03069 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top