Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMF (Graphical Modeling Framework) » Problems on using GMF generated Editor
Problems on using GMF generated Editor [message #539971] Mon, 14 June 2010 13:17
Tobi Sieger is currently offline Tobi SiegerFriend
Messages: 1
Registered: May 2010
Junior Member
Hi there,

i just created a GMF project using the cheatsheet wizard(s), all worked pretty fine until i ran the first test: i am not able to drop a node onto my canvas.

I created the ECORE model on a XSD base which was created from a valid XML.

<?xml version="1.0" encoding="UTF-8"?>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema" elementFormDefault="qualified">
    <xs:element name="test">
    <xs:complexType>
      <xs:attribute name="name" use="required" type="xs:string"/>
    </xs:complexType>
    </xs:element>
</xs:schema>

One thing i noticed on troubleshooting was: when i removed the model-to-node mapping within the GMFMAP i am able to drop the node (just a simple rectangle) onto the canvas - im missing the properties then of course.

Is there any typical hint to this problem?

It would also be nice if you could point me some kind of entry point for debugging and stuff.

thanks,
Tobi
Previous Topic:retrieve the emf resource from the diagram currently edited
Next Topic:Migration to GMF 2.3: issue with Editpolicy and move/reparent
Goto Forum:
  


Current Time: Mon May 20 03:29:59 GMT 2024

Powered by FUDForum. Page generated in 0.03664 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top