Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » M2M (model-to-model transformation) » [QVTO] standalone qvt stereotypes in profile not recognized
[QVTO] standalone qvt stereotypes in profile not recognized [message #537758] Thu, 03 June 2010 14:44 Go to next message
Eclipse UserFriend
Originally posted by: vanbeerst.gmail.com

Hi,

I am having trouble applying stereotypes to an UML element in an
outmodel when running a standalone QVT transformation.
My profile is loaded ok, since I can retrieve/apply the profile from/to
a a UML::Model. The problem is that the base types of the stereotypes
are not recognized. I can retrieve all stereotypes from a profile, but
when I call getExtendedMetaClasses() on those stereotypes, the name of
the base class is 'null'. And stereotype applications will not be done,
getApplicableStereotypes() on an element does not show the stereotypes
either.
When I run the same transformation with the same input parameters, I do
get the correct names of the meta classes and I can apply the
stereotypes to model elements.
This means It must be possible, but I am doing something wrong, but I do
not know what. I probably need to register some URI mapping or register
another package which I did not register yet...
I created a small example of a standalone transformation, which can be
found here :
http://vanbeerst.ulyssis.be/qvt/TestStandaloneQVT.zip

To run this example a a standalone application, following jars should be
in the classpath :
com.ibm.icu_4.2.1.v20100412.jar
lpg.runtime.java_2.0.17.v201004271640.jar
net.sourceforge.lpg.lpgjavaruntime_1.1.0.v200803061910.jar
org.eclipse.emf.common_2.6.0.v20100521-1846.jar
org.eclipse.emf.common.source_2.6.0.v20100427-1455.jar
org.eclipse.emf.ecore_2.6.0.v20100521-1846.jar
org.eclipse.emf.ecore.xmi_2.5.0.v20100521-1846.jar
org.eclipse.emf.mapping.ecore2xml_2.5.0.v201002011637.jar
org.eclipse.m2m.qvt.oml_3.0.0.v20100524-1530.jar
org.eclipse.m2m.qvt.oml.common_2.1.0.v20100524-1530.jar
org.eclipse.m2m.qvt.oml.cst.parser_2.1.0.v20100524-1530.jar
org.eclipse.m2m.qvt.oml.ecore.imperativeocl_3.0.0.v20091209- 1553.jar
org.eclipse.m2m.qvt.oml.emf.util_2.0.100.v20100122-1411.jar
org.eclipse.m2m.qvt.oml.source_3.0.0.v20100524-1530.jar
org.eclipse.ocl_3.0.0.v201005061704.jar
org.eclipse.ocl.ecore_3.0.0.v201005061704.jar
org.eclipse.uml2.common_1.5.0.v201005031530.jar
org.eclipse.uml2.uml_2.2.0.v200805141133.jar
org.eclipse.uml2.uml_3.1.0.v201005031530.jar

The output in the console shows that the metaclasses are unknown (name =
'null'). When you run the transformation 'transforms/Test.qvto' directly
from within eclipse, with as parameter 'models/patterns.uml', the output
shows that the metaclasses are correctly recognized.

So now for the big question :
What am i doing wrong?????? and how should I change the project in the
forementioned zip to make it work?

Dear regards,
Tony Van Beers.
Re: [QVTO] [SOLVED] standalone qvt stereotypes in profile not recognized [message #537861 is a reply to message #537758] Thu, 03 June 2010 21:39 Go to previous message
Eclipse UserFriend
Originally posted by: vanbeerst.gmail.com

The problem is solved, thanks to Sergey Boyko!

I used a wrong resource the create the URI mappings for the UML
metamodel. In the project attached to the original post, in the
'initMetamodels()' method I refered to following jar :
'org.eclipse.uml2.uml_3.1.0.v201005031530.jar'
Replacing this reference with :
'org.eclipse.uml2.uml.resources_3.1.0.v201005031530.jar'
solved the problem.

Sergey rules!

Tony.
Previous Topic:[QVTO] mapping to EType
Next Topic:[ATL] Launching ATL from Java
Goto Forum:
  


Current Time: Thu Apr 22 04:05:42 GMT 2021

Powered by FUDForum. Page generated in 0.01767 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top