Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Test and Performance Tools Platform (TPTP) » Profiler not seeing application's configuration files
Profiler not seeing application's configuration files [message #537556] Wed, 02 June 2010 21:14 Go to next message
Elizabeth  is currently offline Elizabeth Friend
Messages: 13
Registered: December 2009
Junior Member
I have gotten the TPTP profiler set up, along with the AgentController. Everything seems to be working fine, except that when I start the profiler, it doesn't see the configuration files I'm using for my application. I've got two configuration files for my application. The first is to set up the logger for log4j. I got it to see this one by changing the vm argument to include the full path. To get the run-as configuration to see the second configuration file, I changed the working directory to that of my application's plug-in (Run As Configurations -> Arguments-> Working Directory (at the bottom) -> click "Other" -> click "Workspace" button -> choose plug-in that contains the application configuration files. Doing this for the profile as configurations didn't make it so the profiler could see the second configuration file. I've also tried putting my configuration files in my workspace, to no avail. What do I need to do to get the TPTP profiler to recognize the configuration file(s) I'm using to configure my application?
Re: Profiler not seeing application's configuration files [message #538041 is a reply to message #537556] Fri, 04 June 2010 15:49 Go to previous message
Jonathan West is currently offline Jonathan WestFriend
Messages: 49
Registered: July 2009
Hi Elizabeth,
The mechanism by which your application locates the second configuration file is application specific, is it not? I ran a quick test and running the application through the profiler versus through run did not change the working directory of the java app (checked through Process Explorer). You should check that the library that is attempting to locate the second configuration file is looking in the right places (and there may be a way to hardcode a specific location for your purposes). If you open a bug and provide us a simple sample case that reproduces the problem we also may be able to determine if the profiler is at fault. Thanks!
Previous Topic:Collecting results from plugin profiling
Next Topic:java Profiling - JRE 1.5 or newer causes NoSuchMethodExecption
Goto Forum:

Current Time: Sat Jun 25 08:26:13 GMT 2022

Powered by FUDForum. Page generated in 0.01951 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top