Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Copy and Paste does not work on my Mac OS X(Tried most recent Cocoa and Carbon builds, no success)
Copy and Paste does not work on my Mac OS X [message #535600] Mon, 24 May 2010 19:49 Go to next message
ZF  is currently offline ZF Friend
Messages: 1
Registered: May 2010
Junior Member
Hi, I downloaded the 32 bit Carbon and Cocoa builds, no success. I can't copy and paste, neither through the menu commands, mouse 2nd function or shortcuts.

I had a similar issue with KDE but it was solved by disabling klipper. Is the same thing, or similar, needed with Mac OS X? The java on this pc was installed by Apple, through their interface, could this be the issue?

I searched lots before posting, did not find anything specific about Mac OS X, sorry if this is a common issue, I did try searching before.

Thanks in advance for any pointers.

Version: Mac OS X v. 10.6.3

Packages attempted:

eclipse-java-galileo-SR2-macosx-cocoa.tar.gz
eclipse-java-galileo-SR2-macosx-carbon.tar.gz

EDIT: It does not happen all the time. I just ran Eclipse again, and it works. If I shut it down and restart, sometimes it goes back to not working. Any ideas?

EDIT 2 : It only works if you launch through the .APP launcher, not via the shell. I copied the launcher parameters in the .INI file and still it did not work. I need to run Eclipse as a different user, thus I'm trying to run it from the shell....I guess the cause of the problem is solved, but I wish it'd work otherwise.

EDIT 3: It's not solved.... I tested and I can paste outside of Eclipse, but not inside it... Anyone have any ideas, please?

EDIT 4: OK, I think I found out what it was.

When I run Eclipse.app from the dock, Mac OS X seems to know what window to paste to. When I run it from the shell, it seems that Eclipse launcher does not connect the destination window to the paste handler, or whatever the techies call it.

Running the exact same command line on the shell, that the dock does on the GUI(Finder) Eclipse does not allow pasting. When I run it from the dock, everything works perfectly. Even if the user with which you run it on the shell is the same that is logged in on the GUI.

To make sure this isn' t some issue with Mac OS, I ran Firefox from the command line and it allows copying and pasting perfectly. Other apps work fine as well.

It may be related to the JVM, but who knows, I'm leaving this here in case someone can use this report.

[Updated on: Mon, 24 May 2010 23:47]

Report message to a moderator

Re: Copy and Paste does not work on my Mac OS X [message #756369 is a reply to message #535600] Sat, 12 November 2011 12:25 Go to previous message
javier.tegedor is currently offline javier.tegedorFriend
Messages: 1
Registered: November 2011
Junior Member
Hi,

I am having the very same problem, when I launch Eclipse from the dock I can copy and paste without any problems. When I launch it from the console from another users, the paste function does not work anymore.

This does not happen with other applications I launch from the console.
Does anyone have a clue what might be happening?
Javier
Previous Topic:Eclipse Indigo in Ubuntu 11.04
Next Topic:Auto-correction similar Netbeans?
Goto Forum:
  


Current Time: Wed Jun 16 11:07:06 GMT 2021

Powered by FUDForum. Page generated in 0.03387 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top