Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMF (Graphical Modeling Framework) » Can't delete a Component of diagram that I've create
Can't delete a Component of diagram that I've create [message #534277] Tue, 18 May 2010 14:46 Go to next message
All Pereira is currently offline All PereiraFriend
Messages: 6
Registered: April 2010
Location: Balneário Camboriú- SC...
Junior Member

Hi, all right?

I need de following help:

- I have a diagram that can have several components, but each has some specific rules. When diagram was created, I don't have created the rules to Receivers Component for Diagram. We must bear in mind that a diagram can have only one Receiver Component, but several Senders.

When I try to delete a Receiver Component of Diagram , it is only deleted from the diagram that moment, but if I check the file that contains the serialized model it is still there.

Any opinion?

Re: Can't delete a Component of diagram that I've create [message #535639 is a reply to message #534277] Tue, 25 May 2010 05:23 Go to previous messageGo to next message
Jevon  is currently offline Jevon Friend
Messages: 164
Registered: July 2009
Senior Member
Hi All,

Do you get any error messages in the error log when you try and delete
the diagram element? How are you deleting the element - I am guessing by
clicking on it and typing 'del'?

Jevon

All Pereira wrote:
> Hi, all right?
>
> I need de following help:
>
> - I have a diagram that can have several components, but each has some
> specific rules. When diagram was created, I don't have created the rules
> to Receivers Component for Diagram. We must bear in mind that a diagram
> can have only one Receiver Component, but several Senders.
> When I try to delete a Receiver Component of Diagram , it is only
> deleted from the diagram that moment, but if I check the file that
> contains the serialized model it is still there.
> Any opinion?
>
>
Re: Can't delete a Component of diagram that I've create [message #535687 is a reply to message #535639] Tue, 25 May 2010 09:28 Go to previous message
Tatiana Fesenko is currently offline Tatiana FesenkoFriend
Messages: 21
Registered: May 2010
Junior Member
Hi All,

Try explicitely use 'Delete from Model' action from the context menu of the element. Will you get the same result in this case?

Tanya.
Previous Topic:job creates commands, until app freeze, why?
Next Topic:org.eclipse.gmf not accessible from CVS
Goto Forum:
  


Current Time: Sat May 18 10:54:20 GMT 2024

Powered by FUDForum. Page generated in 0.03170 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top