Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » M2M (model-to-model transformation) » [ATL] problem with UML2 metamodel
[ATL] problem with UML2 metamodel [message #53752] Fri, 20 July 2007 09:13 Go to next message
Eclipse UserFriend
Originally posted by: adilanwar10.yahoo.fr

Hi ,

I 'am looking for a metamodel UML2 which is conform to models UML edited in
Topcased Tool 0.11.0v200611061547

Topcased Editor generate files with (.uml) extension, i used several files
for metamodel UML2 but i still have the same problem

I got the message "An internal error occured during : "Launching"

and the exception

WARNING: could not find model UML.

****** BEGIN Stack Trace

message: cannot find model UML

A.main() : ??#30 97:24-97:33

local variables = {self=UML2Corresp : ASMModule}

local stack = []

****** END Stack Trace

Execution terminated due to error (see launch configuration to allow
continuation after errors).

how can i do ??

thanks for help ??
Regards,

Adil
Re: [ATL] problem with UML2 metamodel [message #53782 is a reply to message #53752] Fri, 20 July 2007 09:42 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: Hugo.Bruneliere.univ-nantes.fr

Adil Anwar a écrit :
> Hi ,

Hi Adil,

> I 'am looking for a metamodel UML2 which is conform to models UML edited in
> Topcased Tool 0.11.0v200611061547

UML2 models conform to the UML2 metamodel (and not the reverse) ;-)

> Topcased Editor generate files with (.uml) extension, i used several files
> for metamodel UML2 but i still have the same problem
>

The UML2 metamodel is available in the Eclipse/MDT UML2 component. You
can download the latest version from
http://www.eclipse.org/modeling/mdt/downloads/?project=uml2

TopCased uses this component as its UML2 metamodel implementation.

Then, in ATL, you can also use this metamodel by loading it providing
the following nsUri: http://www.eclipse.org/uml2/2.1.0/UML

Best regards,

Hugo

> I got the message "An internal error occured during : "Launching"
>
> and the exception
>
> WARNING: could not find model UML.
>
> ****** BEGIN Stack Trace
>
> message: cannot find model UML
>
> A.main() : ??#30 97:24-97:33
>
> local variables = {self=UML2Corresp : ASMModule}
>
> local stack = []
>
> ****** END Stack Trace
>
> Execution terminated due to error (see launch configuration to allow
> continuation after errors).
>
> how can i do ??
>
> thanks for help ??
> Regards,
>
> Adil
>
>


--
--------------------------------------------------------
Hugo Bruneliere - R&D Engineer
ATLAS Group (INRIA & LINA) - University of Nantes
2, rue de la Houssiniere
44322 Nantes Cedex 3 - France
office +33 2 51 12 58 10 /\ cell.+33 6 07 42 45 30
EMail: Hugo.Bruneliere@univ-nantes.fr
http://www.sciences.univ-nantes.fr/lina/atl/
--------------------------------------------------------
Re: [ATL] problem with UML2 metamodel [message #54165 is a reply to message #53782] Sat, 21 July 2007 09:35 Go to previous message
Eclipse UserFriend
Originally posted by: adilanwar10.yahoo.fr

Hi Hugo,
Thanks for the response.

it works well now,

Best regards,

Adil


"Hugo Bruneliere" <Hugo.Bruneliere@univ-nantes.fr> a
Previous Topic:[ATL] model modification possible?
Next Topic:[ATL] In-place transformation/refine/copy whole model?
Goto Forum:
  


Current Time: Mon Jan 25 15:14:45 GMT 2021

Powered by FUDForum. Page generated in 0.01370 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top