Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Text widget with default message needs a second click (IE)
Text widget with default message needs a second click (IE) [message #532457] Mon, 10 May 2010 07:17 Go to next message
Niels Lippke is currently offline Niels LippkeFriend
Messages: 71
Registered: December 2009
Member
Hi,

when I use a text widget with a default message, the text field does not
handle the focus correctly: The message disappears, but there's no cursor
and you also cannot type in any text. You have to click a second time upon
the text field to get the cursor.
This seems to be an IE (8) issue, since I it works on FF.

Sample snippet:
public void createPartControl(Composite parent) {
parent.setLayout(new RowLayout());
Text text = new Text(parent, SWT.BORDER);
text.setMessage("enter");
}

Should I file a bug?

Thanks,
Niels
Re: Text widget with default message needs a second click (IE) [message #532460 is a reply to message #532457] Mon, 10 May 2010 07:27 Go to previous messageGo to next message
Rüdiger Herrmann is currently offline Rüdiger HerrmannFriend
Messages: 581
Registered: July 2009
Senior Member
On 10.05.2010 09:17, Niels Lippke wrote:
> Hi,
>
> when I use a text widget with a default message, the text field does not
> handle the focus correctly: The message disappears, but there's no
> cursor and you also cannot type in any text. You have to click a second
> time upon the text field to get the cursor.
> This seems to be an IE (8) issue, since I it works on FF.
>
> Sample snippet:
> public void createPartControl(Composite parent) {
> parent.setLayout(new RowLayout());
> Text text = new Text(parent, SWT.BORDER);
> text.setMessage("enter");
> }
>
> Should I file a bug?
Yes, please.
TIA
Rüdiger

>
> Thanks,
> Niels
Re: Text widget with default message needs a second click (IE) [message #532480 is a reply to message #532460] Mon, 10 May 2010 08:30 Go to previous message
Niels Lippke is currently offline Niels LippkeFriend
Messages: 71
Registered: December 2009
Member
Done. Bug #312215.

Thanks, Niels
Previous Topic:[Upload Widget] Access Denied?
Next Topic:Design Tabbar hides active editor
Goto Forum:
  


Current Time: Tue Dec 07 19:45:54 GMT 2021

Powered by FUDForum. Page generated in 0.02200 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top