Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Exception when running demo app
Exception when running demo app [message #531213] Tue, 04 May 2010 08:16 Go to next message
Radek Terber is currently offline Radek TerberFriend
Messages: 3
Registered: May 2010
Junior Member
Hi all

I downloaded pure eclipse 3.5.2 (RCP bundle), installed it and then installed tha RAP 1.2 via update site by foilllowing instructions here: http://eclipse.org/rap/gettingstarted.php.
Then I created rap.demo app and run it. I got following output:

I'm new to OSGI and RAP. What is wrong - this is "pure" installatoin and I suppose this demo app should run.
I tested it on eclipse 3.6 M5 and 4.0 M5 with similar result.

Thanks for responses.
Radek.

------------------------------------------------------------ --------------------------------
!SESSION 2010-05-04 09:17:08.203 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=cs_CZ
Command-line arguments: -dev file:C:/Users/terber/workspaces/rap/.metadata/.plugins/org.e clipse.pde.core/RAP Application/dev.properties -os win32 -ws win32 -arch x86 -consoleLog

!ENTRY org.eclipse.rap.demo 4 0 2010-05-04 09:17:08.777
!MESSAGE
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Require-Bundle: org.eclipse.rap.ui; bundle-version="0.0.0"
at org.eclipse.osgi.framework.internal.core.AbstractBundle.getR esolverError(AbstractBundle.java:1313)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.getR esolutionFailureException(AbstractBundle.java:1297)
at org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:309)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:370)
at org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1068)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:557)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:464)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:248)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:445)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:227)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:337)

!ENTRY org.eclipse.core.databinding 4 0 2010-05-04 09:17:09.098
!MESSAGE
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Import-Package: com.ibm.icu.text; version="0.0.0"
at org.eclipse.osgi.framework.internal.core.AbstractBundle.getR esolverError(AbstractBundle.java:1313)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.getR esolutionFailureException(AbstractBundle.java:1297)
at org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:309)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:370)
at org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1068)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:557)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:464)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:248)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:445)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:227)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:337)

!ENTRY org.eclipse.osgi 4 0 2010-05-04 09:17:09.111
!MESSAGE Bundle initial@reference :file:plugins/org.eclipse.core.databinding_1.2.0.M20090819-0 800.jar/ was not resolved.

!ENTRY org.eclipse.osgi 4 0 2010-05-04 09:17:09.112
!MESSAGE Bundle initial@reference :file:../../../../../Users/terber/workspaces/rap/org.eclipse .rap.demo/ was not resolved.
------------------------------------------------------------ --------------------------------
Re: Exception when running demo app [message #531242 is a reply to message #531213] Tue, 04 May 2010 09:54 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2359
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi Radek,

welcome to the RAP newsgroup. Did you install and switch on the RAP
target platform? How did you create the demo application? How did you
launch it?

Best,
Ivan

On 05/04/2010 11:16 AM, Radek Terber wrote:
> Hi all
>
> I downloaded pure eclipse 3.5.2 (RCP bundle), installed it and then
> installed tha RAP 1.2 via update site by foilllowing instructions
> here: http://eclipse.org/rap/gettingstarted.php Then I created
> rap.demo app and run it. I got following output:
> I'm new to OSGI and RAP. What is wrong - this is "pure" installatoin
> and I suppose this demo app should run.
> I tested it on eclipse 3.6 M5 and 4.0 M5 with similar result.
> Thanks for responses.
> Radek.
>
> ------------------------------------------------------------
> --------------------------------
> !SESSION 2010-05-04 09:17:08.203
> -----------------------------------------------
> eclipse.buildId=unknown
> java.version=1.6.0
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=cs_CZ
> Command-line arguments: -dev
> file:C:/Users/terber/workspaces/rap/.metadata/.plugins/org.e
> clipse.pde.core/RAP Application/dev.properties -os win32 -ws win32
> -arch x86 -consoleLog
>
> !ENTRY org.eclipse.rap.demo 4 0 2010-05-04 09:17:08.777
> !MESSAGE !STACK 0
> org.osgi.framework.BundleException: The bundle could not be resolved.
> Reason: Missing Constraint: Require-Bundle: org.eclipse.rap.ui;
> bundle-version="0.0.0"
> at org.eclipse.osgi.framework.internal.core.AbstractBundle.getR
> esolverError(AbstractBundle.java:1313)
> at org.eclipse.osgi.framework.internal.core.AbstractBundle.getR
> esolutionFailureException(AbstractBundle.java:1297)
> at org.eclipse.osgi.framework.internal.core.BundleHost.startWor
> ker(BundleHost.java:309)
> at org.eclipse.osgi.framework.internal.core.AbstractBundle.resu
> me(AbstractBundle.java:370)
> at org.eclipse.osgi.framework.internal.core.Framework.resumeBun
> dle(Framework.java:1068)
> at org.eclipse.osgi.framework.internal.core.StartLevelManager.r
> esumeBundles(StartLevelManager.java:557)
> at org.eclipse.osgi.framework.internal.core.StartLevelManager.i
> ncFWSL(StartLevelManager.java:464)
> at org.eclipse.osgi.framework.internal.core.StartLevelManager.d
> oSetStartLevel(StartLevelManager.java:248)
> at org.eclipse.osgi.framework.internal.core.StartLevelManager.d
> ispatchEvent(StartLevelManager.java:445)
> at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve
> nt(EventManager.java:227)
> at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread
> .run(EventManager.java:337)
>
> !ENTRY org.eclipse.core.databinding 4 0 2010-05-04 09:17:09.098
> !MESSAGE !STACK 0
> org.osgi.framework.BundleException: The bundle could not be resolved.
> Reason: Missing Constraint: Import-Package: com.ibm.icu.text;
> version="0.0.0"
> at org.eclipse.osgi.framework.internal.core.AbstractBundle.getR
> esolverError(AbstractBundle.java:1313)
> at org.eclipse.osgi.framework.internal.core.AbstractBundle.getR
> esolutionFailureException(AbstractBundle.java:1297)
> at org.eclipse.osgi.framework.internal.core.BundleHost.startWor
> ker(BundleHost.java:309)
> at org.eclipse.osgi.framework.internal.core.AbstractBundle.resu
> me(AbstractBundle.java:370)
> at org.eclipse.osgi.framework.internal.core.Framework.resumeBun
> dle(Framework.java:1068)
> at org.eclipse.osgi.framework.internal.core.StartLevelManager.r
> esumeBundles(StartLevelManager.java:557)
> at org.eclipse.osgi.framework.internal.core.StartLevelManager.i
> ncFWSL(StartLevelManager.java:464)
> at org.eclipse.osgi.framework.internal.core.StartLevelManager.d
> oSetStartLevel(StartLevelManager.java:248)
> at org.eclipse.osgi.framework.internal.core.StartLevelManager.d
> ispatchEvent(StartLevelManager.java:445)
> at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve
> nt(EventManager.java:227)
> at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread
> .run(EventManager.java:337)
>
> !ENTRY org.eclipse.osgi 4 0 2010-05-04 09:17:09.111
> !MESSAGE Bundle mailto:initial@reference
> :file:plugins/org.eclipse.core.databinding_1.2.0.M20090819-0 800.jar/
> was not resolved.
>
> !ENTRY org.eclipse.osgi 4 0 2010-05-04 09:17:09.112
> !MESSAGE Bundle mailto:initial@reference
> :file:../../../../../Users/terber/workspaces/rap/org.eclipse
> .rap.demo/ was not resolved.
> ------------------------------------------------------------
> --------------------------------
>
Re: Exception when running demo app [message #531276 is a reply to message #531213] Tue, 04 May 2010 12:19 Go to previous messageGo to next message
Robert Degen is currently offline Robert DegenFriend
Messages: 1
Registered: May 2010
Junior Member
Hi Radek,

have you checked your MANIFEST Require directives?

Require-Bundle: org.eclipse.rap.ui

Check your plugin.xml-Editor. Tab "Dependencies".
Add org.eclipse.rap.ui if necessary.

May be the icu dependency (the other) resolves automatically.


Regards,
Rob



Am 5/4/2010 10:16 AM, schrieb Radek Terber:
> Hi all
>
> I downloaded pure eclipse 3.5.2 (RCP bundle), installed it and then
> installed tha RAP 1.2 via update site by foilllowing instructions here:
> http://eclipse.org/rap/gettingstarted.php Then I created rap.demo app
> and run it. I got following output:
> I'm new to OSGI and RAP. What is wrong - this is "pure" installatoin and
> I suppose this demo app should run.
> I tested it on eclipse 3.6 M5 and 4.0 M5 with similar result.
> Thanks for responses.
> Radek.
>
> ------------------------------------------------------------
> --------------------------------
> !SESSION 2010-05-04 09:17:08.203
> -----------------------------------------------
> eclipse.buildId=unknown
> java.version=1.6.0
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=cs_CZ
> Command-line arguments: -dev
> file:C:/Users/terber/workspaces/rap/.metadata/.plugins/org.e
> clipse.pde.core/RAP Application/dev.properties -os win32 -ws win32 -arch
> x86 -consoleLog
>
> !ENTRY org.eclipse.rap.demo 4 0 2010-05-04 09:17:08.777
> !MESSAGE !STACK 0
> org.osgi.framework.BundleException: The bundle could not be resolved.
> Reason: Missing Constraint: Require-Bundle: org.eclipse.rap.ui;
> bundle-version="0.0.0"
> at org.eclipse.osgi.framework.internal.core.AbstractBundle.getR
> esolverError(AbstractBundle.java:1313)
> at org.eclipse.osgi.framework.internal.core.AbstractBundle.getR
> esolutionFailureException(AbstractBundle.java:1297)
> at org.eclipse.osgi.framework.internal.core.BundleHost.startWor
> ker(BundleHost.java:309)
> at org.eclipse.osgi.framework.internal.core.AbstractBundle.resu
> me(AbstractBundle.java:370)
> at org.eclipse.osgi.framework.internal.core.Framework.resumeBun
> dle(Framework.java:1068)
> at org.eclipse.osgi.framework.internal.core.StartLevelManager.r
> esumeBundles(StartLevelManager.java:557)
> at org.eclipse.osgi.framework.internal.core.StartLevelManager.i
> ncFWSL(StartLevelManager.java:464)
> at org.eclipse.osgi.framework.internal.core.StartLevelManager.d
> oSetStartLevel(StartLevelManager.java:248)
> at org.eclipse.osgi.framework.internal.core.StartLevelManager.d
> ispatchEvent(StartLevelManager.java:445)
> at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve
> nt(EventManager.java:227)
> at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread
> .run(EventManager.java:337)
>
> !ENTRY org.eclipse.core.databinding 4 0 2010-05-04 09:17:09.098
> !MESSAGE !STACK 0
> org.osgi.framework.BundleException: The bundle could not be resolved.
> Reason: Missing Constraint: Import-Package: com.ibm.icu.text;
> version="0.0.0"
> at org.eclipse.osgi.framework.internal.core.AbstractBundle.getR
> esolverError(AbstractBundle.java:1313)
> at org.eclipse.osgi.framework.internal.core.AbstractBundle.getR
> esolutionFailureException(AbstractBundle.java:1297)
> at org.eclipse.osgi.framework.internal.core.BundleHost.startWor
> ker(BundleHost.java:309)
> at org.eclipse.osgi.framework.internal.core.AbstractBundle.resu
> me(AbstractBundle.java:370)
> at org.eclipse.osgi.framework.internal.core.Framework.resumeBun
> dle(Framework.java:1068)
> at org.eclipse.osgi.framework.internal.core.StartLevelManager.r
> esumeBundles(StartLevelManager.java:557)
> at org.eclipse.osgi.framework.internal.core.StartLevelManager.i
> ncFWSL(StartLevelManager.java:464)
> at org.eclipse.osgi.framework.internal.core.StartLevelManager.d
> oSetStartLevel(StartLevelManager.java:248)
> at org.eclipse.osgi.framework.internal.core.StartLevelManager.d
> ispatchEvent(StartLevelManager.java:445)
> at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve
> nt(EventManager.java:227)
> at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread
> .run(EventManager.java:337)
>
> !ENTRY org.eclipse.osgi 4 0 2010-05-04 09:17:09.111
> !MESSAGE Bundle mailto:initial@reference
> :file:plugins/org.eclipse.core.databinding_1.2.0.M20090819-0 800.jar/
> was not resolved.
>
> !ENTRY org.eclipse.osgi 4 0 2010-05-04 09:17:09.112
> !MESSAGE Bundle mailto:initial@reference
> :file:../../../../../Users/terber/workspaces/rap/org.eclipse .rap.demo/
> was not resolved.
> ------------------------------------------------------------
> --------------------------------
>
Re: Exception when running demo app [message #531490 is a reply to message #531276] Wed, 05 May 2010 08:41 Go to previous messageGo to next message
Radek Terber is currently offline Radek TerberFriend
Messages: 3
Registered: May 2010
Junior Member
All I did was exactly according to the instructions in video-tutorial on this page: "http://eclipse.org/rap/gettingstarted.php" Video on right side) . Demo app was instantied from plugin list. Dependency to "org.eclipse.rap.ui" is registered in "plugin.xml". I have jre 1.6.0 (not an JDK). A launch demo app by click to link "Launch a RAP Application" in in plugin-xml editor (as is described in video tutorial).
Re: Exception when running demo app [message #531537 is a reply to message #531490] Wed, 05 May 2010 11:10 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2359
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi Radek,

Please confirm that you install the RAP target platform from within
Eclipse Welcome page -> Overview -> Rich Ajax Platform (RAP) -> Install
Target Platform and switch it on (check box is selected).

Best,
Ivan

On 05/05/2010 11:41 AM, Radek Terber wrote:
> All I did was exactly according to the instructions in video-tutorial
> on this page: "http://eclipse.org/rap/gettingstarted.php" Video on
> right side) . Demo app was instantied from plugin list. Dependency to
> "org.eclipse.rap.ui" is registered in "plugin.xml". I have jre 1.6.0
> (not an JDK). A launch demo app by click to link "Launch a RAP
> Application" in in plugin-xml editor (as is described in video tutorial).
Re: Exception when running demo app [message #531575 is a reply to message #531537] Wed, 05 May 2010 13:02 Go to previous messageGo to next message
Radek Terber is currently offline Radek TerberFriend
Messages: 3
Registered: May 2010
Junior Member
Yes, the checkbox is checked and target platform is installed.
I forgot to wrile it to the last post - I tried run and compile it with both choices - "RAP" and "Running platform" (switching it in preferences). When "Running platform" is selected, the project is even compiled with errors, hence it is evident that the configuration is bad.
Re: Exception when running demo app [message #531624 is a reply to message #531575] Wed, 05 May 2010 15:54 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2359
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi Radek,

I've followed the screencast step-by-step and everything is working as
expected (Eclipse for RCP/Plug-in Developers 3.5 SR2 + RAP 1.2.2). The
only change that I've made is to use this update site (
*http://download.eclipse.org/rt/rap/1.2/update*) as it is documented
here [1].

[1] http://eclipse.org/rap/gettingstarted.php

Best,
Ivan

On 05/05/2010 4:02 PM, Radek Terber wrote:
> Yes, the checkbox is checked and target platform is installed. I
> forgot to wrile it to the last post - I tried run and compile it with
> both choices - "RAP" and "Running platform" (switching it in
> preferences). When "Running platform" is selected, the project is even
> compiled with errors, hence it is evident that the configuration is bad.
Re: Exception when running demo app [message #531815 is a reply to message #531490] Thu, 06 May 2010 08:36 Go to previous message
Rüdiger Herrmann is currently offline Rüdiger HerrmannFriend
Messages: 581
Registered: July 2009
Senior Member
there should be a launch configuration called "RAP Workbench Demo". Did
you try to use this one?
If you are using your own/a generated launch configuration, does
"Validate Plug-ins" report any issues?

HTH
Rüdiger

On 05.05.2010 10:41, Radek Terber wrote:
> All I did was exactly according to the instructions in video-tutorial on
> this page: "http://eclipse.org/rap/gettingstarted.php" Video on right
> side) . Demo app was instantied from plugin list. Dependency to
> "org.eclipse.rap.ui" is registered in "plugin.xml". I have jre 1.6.0
> (not an JDK). A launch demo app by click to link "Launch a RAP
> Application" in in plugin-xml editor (as is described in video tutorial).
Previous Topic:Vertical label
Next Topic:Eclipse RAP and OSGi DS
Goto Forum:
  


Current Time: Wed Dec 01 04:35:17 GMT 2021

Powered by FUDForum. Page generated in 0.02713 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top