Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » M2M (model-to-model transformation) » Problem running example(This is the output of the consolle.)
Problem running example [message #530598] Fri, 30 April 2010 09:49
No real name is currently offline No real nameFriend
Messages: 4
Registered: April 2010
Junior Member
The project i'm working of is a project that allows to transform an Uml project in a file RTF.

This is the output:

org.eclipse.m2m.atl.engine.emfvm.VMException: Could not find model element Association from UML
Java Stack:
org.eclipse.m2m.atl.engine.emfvm.VMException: Could not find model element Association from UML
at org.eclipse.m2m.atl.engine.emfvm.ASM.registerOperations(ASM. java:232)
at org.eclipse.m2m.atl.engine.emfvm.ASM.run(ASM.java:176)
at org.eclipse.m2m.atl.engine.emfvm.launch.EMFVMLauncher.launch (EMFVMLauncher.java:162)
at org.eclipse.m2m.atl.engine.emfvm.launch.EMFVMLauncher.launch (EMFVMLauncher.java:135)
at org.eclipse.m2m.atl.core.service.LauncherService.launch(Laun cherService.java:135)
at org.eclipse.m2m.atl.core.ui.launch.AtlLaunchConfigurationDel egate.launch(AtlLaunchConfigurationDelegate.java:222)
at org.eclipse.debug.internal.core.LaunchConfiguration.launch(L aunchConfiguration.java:853)
at org.eclipse.debug.internal.core.LaunchConfiguration.launch(L aunchConfiguration.java:703)
at org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch(D ebugUIPlugin.java:866)
at org.eclipse.debug.internal.ui.DebugUIPlugin$8.run(DebugUIPlu gin.java:1069)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
Caused by: org.eclipse.m2m.atl.engine.emfvm.ASM$SignatureParsingExcepti on: Could not find model element Association from UML
at org.eclipse.m2m.atl.engine.emfvm.ASM.parseTypeInternal(ASM.j ava:408)
at org.eclipse.m2m.atl.engine.emfvm.ASM.parseType(ASM.java:368)
at org.eclipse.m2m.atl.engine.emfvm.ASM.registerOperations(ASM. java:229)
... 10 more

[Updated on: Fri, 30 April 2010 09:50]

Report message to a moderator

Previous Topic:[QVTO] taggedvalues
Next Topic:[ATL] Using a http://schema.omg.org/spec/UML/2.1 model
Goto Forum:
  


Current Time: Thu Oct 24 04:53:34 GMT 2019

Powered by FUDForum. Page generated in 0.01968 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top