Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Problem using 1.3.M6 with BIRT
Problem using 1.3.M6 with BIRT [message #530298] Thu, 29 April 2010 09:00 Go to next message
Lars Fischer is currently offline Lars FischerFriend
Messages: 105
Registered: July 2009
Senior Member
Hello,

I would like to use RAP 1.3.M6 together with BIRT and followed the
documentation described here: http://wiki.eclipse.org/RAP/BIRT_Integration

Thats why I do not use the com.ibm.icu.base_4.2.1.v20100212.jar bundle
contained in the rap-tooling.

But when running with BIRTs com.ibm.icu_4.0.1.v20090822.jar I get the
following error. I also tried the com.ibm.icu_4.2.1.v20100212.jar from
the eclipse SDK 3.6.M6.

Where is my mistake?


java.lang.NoClassDefFoundError: com/ibm/icu/text/Collator
at
org.eclipse.ui.internal.registry.EditorRegistry$1.<init>(EditorRegistry.java:143)
at
org.eclipse.ui.internal.registry.EditorRegistry.<clinit>(EditorRegistry.java:142)
at
org.eclipse.ui.internal.WorkbenchPlugin.getEditorRegistry(Wo rkbenchPlugin.java:609)
at
org.eclipse.ui.internal.EditorManager.getEditorRegistry(Edit orManager.java:561)
at org.eclipse.ui.internal.EditorManager.openEditor(EditorManag er.java:632)
at
org.eclipse.ui.internal.WorkbenchPage.busyOpenEditorBatched( WorkbenchPage.java:2716)
at
org.eclipse.ui.internal.WorkbenchPage.busyOpenEditor(Workben chPage.java:2630)
at org.eclipse.ui.internal.WorkbenchPage.access$11(WorkbenchPag e.java:2622)
at org.eclipse.ui.internal.WorkbenchPage$10.run(WorkbenchPage.j ava:2574)
at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator .java:66)
at
org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPa ge.java:2569)
at
org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPa ge.java:2553)
at
org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPa ge.java:2544)
at client.ui.common.DefaultEditAction.run(DefaultEditAction.jav a:69)
at
client.ui.common.DefaultEditAction.doubleClick(DefaultEditAc tion.java:99)
at
org.eclipse.jface.viewers.StructuredViewer$1.run(StructuredV iewer.java:823)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
at org.eclipse.core.runtime.Platform.run(Platform.java:888)
at org.eclipse.ui.internal.JFaceUtil$1.run(JFaceUtil.java:50)
at org.eclipse.jface.util.SafeRunnable.run(SafeRunnable.java:17 5)
at
org.eclipse.jface.viewers.StructuredViewer.fireDoubleClick(S tructuredViewer.java:821)
at
org.eclipse.jface.viewers.StructuredViewer.handleDoubleSelec t(StructuredViewer.java:1085)
at
org.eclipse.jface.viewers.StructuredViewer$4.widgetDefaultSe lected(StructuredViewer.java:1197)
at
org.eclipse.jface.util.OpenStrategy.fireDefaultSelectionEven t(OpenStrategy.java:239)
at org.eclipse.jface.util.OpenStrategy.access$0(OpenStrategy.ja va:236)
at org.eclipse.jface.util.OpenStrategy$1.handleEvent(OpenStrate gy.java:301)
at
org.eclipse.swt.internal.widgets.UntypedEventAdapter.dispatc hEvent(UntypedEventAdapter.java:651)
at
org.eclipse.swt.internal.widgets.UntypedEventAdapter.widgetD efaultSelected(UntypedEventAdapter.java:82)
at
org.eclipse.swt.events.SelectionEvent.dispatchToObserver(Sel ectionEvent.java:197)
at org.eclipse.rwt.internal.events.Event.processEvent(Event.jav a:44)
at org.eclipse.swt.events.TypedEvent.processEvent(TypedEvent.ja va:160)
at org.eclipse.swt.events.TypedEvent.executeNext(TypedEvent.jav a:200)
at
org.eclipse.rwt.internal.lifecycle.RWTLifeCycle.readAndDispa tch(RWTLifeCycle.java:266)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java :1006)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.jav a:2396)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2355)
at org.eclipse.ui.internal.Workbench.access$5(Workbench.java:22 06)
at org.eclipse.ui.internal.Workbench$4.run(Workbench.java:424)
at
org.eclipse.core.databinding.observable.Realm.runWithDefault (Realm.java:332)
at
org.eclipse.jface.internal.databinding.realmadapter.RealmAda pter.run(RealmAdapter.java:44)
at
org.eclipse.rap.ui.internal.RealmAdapterHook.runWithDefault( RealmAdapterHook.java:48)
at
org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Work bench.java:427)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.j ava:157)
at
client.RapApplication.start(RapApplication.java:58)
at
org.eclipse.rap.ui.internal.application.EntrypointApplicatio nWrapper.createUI(EntrypointApplicationWrapper.java:27)
at
org.eclipse.rwt.internal.lifecycle.EntryPointManager.createU I(EntryPointManager.java:92)
at
org.eclipse.rwt.internal.lifecycle.RWTLifeCycle.createUI(RWT LifeCycle.java:253)
at
org.eclipse.rwt.internal.lifecycle.RWTLifeCycle$UIThreadCont roller.run(RWTLifeCycle.java:117)
at java.lang.Thread.run(Thread.java:619)
at org.eclipse.rwt.internal.lifecycle.UIThread.run(UIThread.jav a:80)
Caused by: java.lang.ClassNotFoundException: com.ibm.icu.text.Collator
at
org.eclipse.osgi.internal.loader.BundleLoader.findClassInter nal(BundleLoader.java:460)
at
org.eclipse.osgi.internal.loader.BundleLoader.findClass(Bund leLoader.java:422)
at
org.eclipse.osgi.internal.loader.BundleLoader.findClass(Bund leLoader.java:410)
at
org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loa dClass(DefaultClassLoader.java:107)
at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
... 50 more

I there a newer

Regards,
Lars
Re: Problem using 1.3.M6 with BIRT [message #530305 is a reply to message #530298] Thu, 29 April 2010 09:45 Go to previous messageGo to next message
Lars Fischer is currently offline Lars FischerFriend
Messages: 105
Registered: July 2009
Senior Member
On 29.04.2010 11:00, Lars Fischer wrote:
> I would like to use RAP 1.3.M6 together with BIRT and followed the
> documentation described here: http://wiki.eclipse.org/RAP/BIRT_Integration
>
> Thats why I do not use the com.ibm.icu.base_4.2.1.v20100212.jar bundle
> contained in the rap-tooling.
>
> But when running with BIRTs com.ibm.icu_4.0.1.v20090822.jar I get the
> following error. I also tried the com.ibm.icu_4.2.1.v20100212.jar from
> the eclipse SDK 3.6.M6.
>
> Where is my mistake?

I found that the birt reportengine runtime contains a bundle fragment
org.eclipse.birt.api version 1.0.0. This fragment is exporting many
packages. E.g. com.ibm.icu.text version 4.0.1.

Without this fragment, rap 1.3.M6 is able to run with the full
com.ibm.icu_4.2.1.v20100212.jar. But I don't know if it is needed for BIRT.

Regards,
Lars
Re: Problem using 1.3.M6 with BIRT [message #530476 is a reply to message #530298] Thu, 29 April 2010 17:36 Go to previous messageGo to next message
Rüdiger Herrmann is currently offline Rüdiger HerrmannFriend
Messages: 581
Registered: July 2009
Senior Member
did you take a look at the FAQ?
http://wiki.eclipse.org/RAP/FAQ#How_to_integrate_BIRT.3F

HTH
Rüdiger

On 29.04.2010 11:00, Lars Fischer wrote:
> Hello,
>
> I would like to use RAP 1.3.M6 together with BIRT and followed the
> documentation described here: http://wiki.eclipse.org/RAP/BIRT_Integration
>
> Thats why I do not use the com.ibm.icu.base_4.2.1.v20100212.jar bundle
> contained in the rap-tooling.
>
> But when running with BIRTs com.ibm.icu_4.0.1.v20090822.jar I get the
> following error. I also tried the com.ibm.icu_4.2.1.v20100212.jar from
> the eclipse SDK 3.6.M6.
>
> Where is my mistake?
>
>
> java.lang.NoClassDefFoundError: com/ibm/icu/text/Collator
> at
> org.eclipse.ui.internal.registry.EditorRegistry$1.<init>(EditorRegistry.java:143)
>
> at
> org.eclipse.ui.internal.registry.EditorRegistry.<clinit>(EditorRegistry.java:142)
>
> at
> org.eclipse.ui.internal.WorkbenchPlugin.getEditorRegistry(Wo rkbenchPlugin.java:609)
>
> at
> org.eclipse.ui.internal.EditorManager.getEditorRegistry(Edit orManager.java:561)
>
> at org.eclipse.ui.internal.EditorManager.openEditor(EditorManag er.java:632)
> at
> org.eclipse.ui.internal.WorkbenchPage.busyOpenEditorBatched( WorkbenchPage.java:2716)
>
> at
> org.eclipse.ui.internal.WorkbenchPage.busyOpenEditor(Workben chPage.java:2630)
>
> at org.eclipse.ui.internal.WorkbenchPage.access$11(WorkbenchPag e.java:2622)
> at org.eclipse.ui.internal.WorkbenchPage$10.run(WorkbenchPage.j ava:2574)
> at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator .java:66)
> at
> org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPa ge.java:2569)
> at
> org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPa ge.java:2553)
> at
> org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPa ge.java:2544)
> at client.ui.common.DefaultEditAction.run(DefaultEditAction.jav a:69)
> at
> client.ui.common.DefaultEditAction.doubleClick(DefaultEditAc tion.java:99)
> at
> org.eclipse.jface.viewers.StructuredViewer$1.run(StructuredV iewer.java:823)
> at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
> at org.eclipse.core.runtime.Platform.run(Platform.java:888)
> at org.eclipse.ui.internal.JFaceUtil$1.run(JFaceUtil.java:50)
> at org.eclipse.jface.util.SafeRunnable.run(SafeRunnable.java:17 5)
> at
> org.eclipse.jface.viewers.StructuredViewer.fireDoubleClick(S tructuredViewer.java:821)
>
> at
> org.eclipse.jface.viewers.StructuredViewer.handleDoubleSelec t(StructuredViewer.java:1085)
>
> at
> org.eclipse.jface.viewers.StructuredViewer$4.widgetDefaultSe lected(StructuredViewer.java:1197)
>
> at
> org.eclipse.jface.util.OpenStrategy.fireDefaultSelectionEven t(OpenStrategy.java:239)
>
> at org.eclipse.jface.util.OpenStrategy.access$0(OpenStrategy.ja va:236)
> at org.eclipse.jface.util.OpenStrategy$1.handleEvent(OpenStrate gy.java:301)
> at
> org.eclipse.swt.internal.widgets.UntypedEventAdapter.dispatc hEvent(UntypedEventAdapter.java:651)
>
> at
> org.eclipse.swt.internal.widgets.UntypedEventAdapter.widgetD efaultSelected(UntypedEventAdapter.java:82)
>
> at
> org.eclipse.swt.events.SelectionEvent.dispatchToObserver(Sel ectionEvent.java:197)
>
> at org.eclipse.rwt.internal.events.Event.processEvent(Event.jav a:44)
> at org.eclipse.swt.events.TypedEvent.processEvent(TypedEvent.ja va:160)
> at org.eclipse.swt.events.TypedEvent.executeNext(TypedEvent.jav a:200)
> at
> org.eclipse.rwt.internal.lifecycle.RWTLifeCycle.readAndDispa tch(RWTLifeCycle.java:266)
>
> at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java :1006)
> at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.jav a:2396)
> at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2355)
> at org.eclipse.ui.internal.Workbench.access$5(Workbench.java:22 06)
> at org.eclipse.ui.internal.Workbench$4.run(Workbench.java:424)
> at
> org.eclipse.core.databinding.observable.Realm.runWithDefault (Realm.java:332)
>
> at
> org.eclipse.jface.internal.databinding.realmadapter.RealmAda pter.run(RealmAdapter.java:44)
>
> at
> org.eclipse.rap.ui.internal.RealmAdapterHook.runWithDefault( RealmAdapterHook.java:48)
>
> at
> org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Work bench.java:427)
> at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.j ava:157)
> at
> client.RapApplication.start(RapApplication.java:58)
> at
> org.eclipse.rap.ui.internal.application.EntrypointApplicatio nWrapper.createUI(EntrypointApplicationWrapper.java:27)
>
> at
> org.eclipse.rwt.internal.lifecycle.EntryPointManager.createU I(EntryPointManager.java:92)
>
> at
> org.eclipse.rwt.internal.lifecycle.RWTLifeCycle.createUI(RWT LifeCycle.java:253)
>
> at
> org.eclipse.rwt.internal.lifecycle.RWTLifeCycle$UIThreadCont roller.run(RWTLifeCycle.java:117)
>
> at java.lang.Thread.run(Thread.java:619)
> at org.eclipse.rwt.internal.lifecycle.UIThread.run(UIThread.jav a:80)
> Caused by: java.lang.ClassNotFoundException: com.ibm.icu.text.Collator
> at
> org.eclipse.osgi.internal.loader.BundleLoader.findClassInter nal(BundleLoader.java:460)
>
> at
> org.eclipse.osgi.internal.loader.BundleLoader.findClass(Bund leLoader.java:422)
>
> at
> org.eclipse.osgi.internal.loader.BundleLoader.findClass(Bund leLoader.java:410)
>
> at
> org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loa dClass(DefaultClassLoader.java:107)
>
> at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
> ... 50 more
>
> I there a newer
>
> Regards,
> Lars
>


--
Rüdiger Herrmann
http://eclipsesource.com
Re: Problem using 1.3.M6 with BIRT [message #530571 is a reply to message #530476] Fri, 30 April 2010 08:05 Go to previous messageGo to next message
Lars Fischer is currently offline Lars FischerFriend
Messages: 105
Registered: July 2009
Senior Member
Hello Rüdiger,

On 29.04.2010 19:36, Rüdiger Herrmann wrote:
> did you take a look at the FAQ?
> http://wiki.eclipse.org/RAP/FAQ#How_to_integrate_BIRT.3F

Your link forwards to the HOWTO which I used.

I got it working now: RAP 1.3.M6 with BIRT 2.5.2. But I have to take
care that the bundle fragment org.eclipse.birt.api version 1.0.0 is not
used.
Don't know if this is a bug of BIRT.

Regards,
Lars
Re: Problem using 1.3.M6 with BIRT [message #530605 is a reply to message #530571] Fri, 30 April 2010 09:39 Go to previous messageGo to next message
Ralf Sternberg is currently offline Ralf SternbergFriend
Messages: 1313
Registered: July 2009
Senior Member

Hi Lars,

you could ask on the BIRT newsgroup (eclipse.birt) what the use of this
fragment is and maybe file a bug against BIRT. If you do so, it would be
nice if you could let us know if there is something to be added to our
HOWTO.

Thanks, Ralf

Lars Fischer wrote:
> Hello Rüdiger,
>
> On 29.04.2010 19:36, Rüdiger Herrmann wrote:
>> did you take a look at the FAQ?
>> http://wiki.eclipse.org/RAP/FAQ#How_to_integrate_BIRT.3F
>
> Your link forwards to the HOWTO which I used.
>
> I got it working now: RAP 1.3.M6 with BIRT 2.5.2. But I have to take
> care that the bundle fragment org.eclipse.birt.api version 1.0.0 is not
> used.
> Don't know if this is a bug of BIRT.
>
> Regards,
> Lars
>
Re: Problem using 1.3.M6 with BIRT [message #533866 is a reply to message #530605] Mon, 17 May 2010 10:10 Go to previous messageGo to next message
Lars Fischer is currently offline Lars FischerFriend
Messages: 105
Registered: July 2009
Senior Member
Hi Ralf,

On 30.04.2010 11:39, Ralf Sternberg wrote:
>
> you could ask on the BIRT newsgroup (eclipse.birt) what the use of this
> fragment is and maybe file a bug against BIRT. If you do so, it would be
> nice if you could let us know if there is something to be added to our
> HOWTO.

I got no response on the BIRT group.

But I could use BIRT together with RAP as described in the HOWTO. The
only thing to take care of is to _not_ include the org.eclipse.birt.api
fragment.
This is working fine for me.

Maybe this could be added as a hint to the WIKI entry?

Regards,
Lars
Re: Problem using 1.3.M6 with BIRT [message #533884 is a reply to message #533866] Mon, 17 May 2010 11:34 Go to previous message
Benjamin Muskalla is currently offline Benjamin MuskallaFriend
Messages: 338
Registered: July 2009
Senior Member
Sure, just go ahead and add it as a hint to the wiki page.

Regards,
Benny

Lars Fischer wrote:
> Hi Ralf,
>
> On 30.04.2010 11:39, Ralf Sternberg wrote:
>>
>> you could ask on the BIRT newsgroup (eclipse.birt) what the use of this
>> fragment is and maybe file a bug against BIRT. If you do so, it would be
>> nice if you could let us know if there is something to be added to our
>> HOWTO.
>
> I got no response on the BIRT group.
>
> But I could use BIRT together with RAP as described in the HOWTO. The
> only thing to take care of is to _not_ include the org.eclipse.birt.api
> fragment.
> This is working fine for me.
>
> Maybe this could be added as a hint to the WIKI entry?
>
> Regards,
> Lars
>
>


--
Benjamin Muskalla | EclipseSource Karlsruhe
http://www.eclipsesource.com | http://twitter.com/eclipsesource
Previous Topic:TableTree bug
Next Topic:UploadWidget is not working with latest CVS
Goto Forum:
  


Current Time: Mon Dec 06 12:32:43 GMT 2021

Powered by FUDForum. Page generated in 0.02004 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top