Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » M2M (model-to-model transformation) » [ATL] Error loading platform
[ATL] Error loading platform [message #529183] Fri, 23 April 2010 10:23
graa is currently offline graaFriend
Messages: 42
Registered: April 2010
Member
Hello,
when i execute my transformation with ATL i have this error message:

Error loading platform:/resource/transformationKAOSEVENTB/test1.sysml: org.eclipse.emf.ecore.xmi.IllegalValueException: Value 'org.eclipse.emf.ecore.impl.DynamicEObjectImpl@bec063
(eClass: org.eclipse.emf.ecore.impl.EClassImpl@898669 (name: AbstractGoal) (instanceClassName: null) (abstract: false, interface: false))' is not legal. (platform:/resource/transformationKAOSEVENTB/test1.sysml, 3, 106)


I did not understand the problem.

this is my test1.sysml:

<?xml version="1.0" encoding="UTF-8"?>
<uml:Model xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:kaos="http://www.topcased.org/kaos/1" xmlns:uml="http://www.eclipse.org/uml2/3.0.0/UML">
<packagedElement xsi:type="kaos:AbstractGoal" name="AbstractGoal1" clientDependency="#//And1 #//And2"/>

</uml:Model>

[Updated on: Sun, 25 April 2010 16:10]

Report message to a moderator

Previous Topic:Run ATL with a uri in the ressourcetype
Next Topic:[ATL] ATL for Ecore or for KM3 files?
Goto Forum:
  


Current Time: Tue Oct 15 10:55:09 GMT 2019

Powered by FUDForum. Page generated in 0.01812 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top