Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMF (Graphical Modeling Framework) » Problem with compartment
Problem with compartment [message #528911] Thu, 22 April 2010 11:37 Go to next message
Asma is currently offline AsmaFriend
Messages: 41
Registered: February 2010
Member
Hi,
I have a probem when i want to add a compartment to a figure. My purpose is to create a rectangle with several compartments. The problem is tht when i want to generate the .gmfgen file, an this error appears: Validation failed unexpectedly for 'child Reference'. See log for details.

And when i tried to validate the .gmfgraph file, validation succeeded. But when i generate the .gmfgen, same error appears for Child Reference, feature Label Mapping, Mapping and Node Mapping.

Can anyone tell me how to resolve it?

Thanks in advance.
Re: Problem with compartment [message #530027 is a reply to message #528911] Wed, 28 April 2010 08:37 Go to previous messageGo to next message
Dewas is currently offline DewasFriend
Messages: 21
Registered: March 2010
Location: Toulouse (France)
Junior Member
Hello, can you display a sreenshot of your .gmfgraph file?

In the figure descriptor of your figure with compartment, have you add a child access for each compartment?

To add compartment in a figure, you have 3 steps :
- create the compartment figure (e.g. rectanle) inside your main figure
- create the child access in your figure descriptor matching your compartment
- create the compartment into your canvas matching your compartment figure and your child access.

I sugest you this tutorial : http://gmfsamples.tuxfamily.org/wiki/doku.php?id=gmf_tutoria l5

By hoping to have brought a little of help

Albert


DEWAS Albert
Master Degree in the IUP Intelligent Systems
Trainee to Continental Corporation Toulouse
Re: Problem with compartment [message #530447 is a reply to message #530027] Thu, 29 April 2010 16:19 Go to previous message
Asma is currently offline AsmaFriend
Messages: 41
Registered: February 2010
Member
Thank u very much for ur help Smile
Previous Topic:Change icons in diagram editor
Next Topic:Logic Diagram Example not working properly
Goto Forum:
  


Current Time: Mon Sep 28 15:35:18 GMT 2020

Powered by FUDForum. Page generated in 0.01284 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top