Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Test and Performance Tools Platform (TPTP) » Need workaround for XML parser error
Need workaround for XML parser error [message #4724] Wed, 02 February 2005 16:12 Go to next message
No real name is currently offline No real nameFriend
Messages: 1
Registered: July 2009
Junior Member
Hello -

I am running into the same problem reported in Hyades bug 82305. That is,
the byte order mark in the log4j plugin.xml causes a parser error. I
sympathize with the position that this is really an eclipse issue, but I
need to get this tool running if at all possible. Can you help me, please?

I have edited the log4j plugin.xml file to remove the BOM, as the bug
report suggests, and I no longer get the "can't parse this file" error.
But eclipse still encounters errors, and won't offer the profiling
perspective.

The PDE Runtime Plugin Registry view doesn't show any of the Hyades
plugins, while the PDE Plugins view shows about 32 of them. The PDE error
log contains a long list of "Missing required plugin..." for various
Hyades plugins.

What can I do to get this working?

Thanks,

Merlin
Re: Need workaround for XML parser error [message #4794 is a reply to message #4724] Wed, 02 February 2005 16:23 Go to previous message
Paul Slauenwhite is currently offline Paul SlauenwhiteFriend
Messages: 975
Registered: July 2009
Senior Member
Hi Merlin,
After further inspection, the plugin.xml files for the
org.apache.jakarta_log4j_logging_1.2.8 and
org.apache.jakarta_commons_logging_1.0.3 plug-ins were created using an
external textual editor (Microsoft tool) and not the Eclipse plugin.xml
editor. As such, the Byte Order Mark (BOM) was incorrect (EF BB BF) and the
Crimson XML parser that is shipped with the Sun JDK 1.4.2 did not handle
this
corner case.

I will reopen https://bugs.eclipse.org/bugs/show_bug.cgi?id=82305 and
fix the problem accordingly.

PS

"Merlin Vincent" <merlinvincent@wildmail.com> wrote in message
news:ctqu6b$qg4$1@www.eclipse.org...
> Hello -
>
> I am running into the same problem reported in Hyades bug 82305. That is,
> the byte order mark in the log4j plugin.xml causes a parser error. I
> sympathize with the position that this is really an eclipse issue, but I
> need to get this tool running if at all possible. Can you help me, please?
>
> I have edited the log4j plugin.xml file to remove the BOM, as the bug
> report suggests, and I no longer get the "can't parse this file" error.
> But eclipse still encounters errors, and won't offer the profiling
> perspective.
>
> The PDE Runtime Plugin Registry view doesn't show any of the Hyades
> plugins, while the PDE Plugins view shows about 32 of them. The PDE error
> log contains a long list of "Missing required plugin..." for various
> Hyades plugins.
>
> What can I do to get this working?
>
> Thanks,
>
> Merlin
>
Previous Topic:Profiling is very slow
Next Topic:Agent Controller for iSeries
Goto Forum:
  


Current Time: Tue Sep 24 09:21:05 GMT 2019

Powered by FUDForum. Page generated in 0.02049 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top