Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse Startup Error
Eclipse Startup Error [message #525855] Thu, 08 April 2010 01:45 Go to next message
No real name is currently offline No real nameFriend
Messages: 2
Registered: April 2010
Junior Member
Eclipse worked fine last night, but when I tried to start it up today it brings up this error message.

I originally thought that it was the workspace that was configured improperly, but I deleted the workspace (moved it somewhere else) and it still doesn't work.

Any help?
http://img707.imageshack.us/img707/4416/ss20100407181208.png

Here's the log:
!SESSION 2010-04-07 17:58:37.208 -----------------------------------------------
eclipse.buildId=I20080617-2000
java.version=1.6.0_13
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Command-line arguments:  -os win32 -ws win32 -arch x86

!ENTRY org.eclipse.osgi 4 0 2010-04-07 17:58:37.457
!MESSAGE Startup error
!STACK 1
java.lang.NumberFormatException: For input string: ""
at java.lang.NumberFormatException.forInputString(Unknown Source)
at java.lang.Integer.parseInt(Unknown Source)
at java.lang.Integer.parseInt(Unknown Source)
at org.eclipse.osgi.storagemanager.StorageManager.updateTable(StorageManager.java:512)
at org.eclipse.osgi.storagemanager.StorageManager.open(StorageManager.java:694)
at org.eclipse.osgi.internal.baseadaptor.BaseStorage.initFileManager(BaseStorage.java:208)
at org.eclipse.osgi.internal.baseadaptor.BaseStorage.initialize(BaseStorage.java:142)
at org.eclipse.osgi.baseadaptor.BaseAdaptor.initializeStorage(BaseAdaptor.java:124)
at org.eclipse.osgi.framework.internal.core.Framework.initialize(Framework.java:180)
at org.eclipse.osgi.framework.internal.core.Framework.<init>(Framework.java:152)
at org.eclipse.osgi.framework.internal.core.OSGi.createFramework(OSGi.java:90)
at org.eclipse.osgi.framework.internal.core.OSGi.<init>(OSGi.java:31)
at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:286)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:175)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:549)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
at org.eclipse.equinox.launcher.Main.run(Main.java:1236)

Re: Eclipse Startup Error [message #526000 is a reply to message #525855] Thu, 08 April 2010 14:03 Go to previous messageGo to next message
Paul A. Rubin is currently offline Paul A. RubinFriend
Messages: 188
Registered: July 2009
Senior Member
On 4/7/2010 9:45 PM, shreddedcheddar@gmail.com wrote:
> Eclipse worked fine last night, but when I tried to start it up today it
> brings up this error message.
> I originally thought that it was the workspace that was configured
> improperly, but I deleted the workspace (moved it somewhere else) and it
> still doesn't work.
>

Can you launch it with the -clean option?

/Paul
Re: Eclipse Startup Error [message #526013 is a reply to message #525855] Thu, 08 April 2010 14:31 Go to previous messageGo to next message
No real name is currently offline No real nameFriend
Messages: 2
Registered: April 2010
Junior Member
Nope, that's what I tried first.

I also tried adding

-data "C:/newworkspace"

to change the workspace if that was the issue, but I'm not sure I used the command correctly. Also I have Eclipse set to prompt for the workspace on startup anyways.
Re: Eclipse Startup Error [message #526098 is a reply to message #526013] Thu, 08 April 2010 16:40 Go to previous messageGo to next message
Paul A. Rubin is currently offline Paul A. RubinFriend
Messages: 188
Registered: July 2009
Senior Member
On 4/8/2010 10:31 AM, shreddedcheddar@gmail.com wrote:
> Nope, that's what I tried first.
>
> I also tried adding
> -data "C:/newworkspace"
>
> to change the workspace if that was the issue, but I'm not sure I used
> the command correctly. Also I have Eclipse set to prompt for the
> workspace on startup anyways.

<groping in the dark> Under the Eclipse installation directory is a
folder named ...\configuration\.settings. If you move that folder to
some temporary location, will Eclipse start (it'll rebuild the folder
and at least one of the prefs files if it starts)? If yes, you can
experiment to see which prefs file is the culprit.

/Paul
Re: Eclipse Startup Error [message #1753325 is a reply to message #525855] Fri, 03 February 2017 20:43 Go to previous message
Sai Kamal Sreeja Veepuri is currently offline Sai Kamal Sreeja VeepuriFriend
Messages: 2
Registered: February 2017
Junior Member
I have the same error.How did you resolve it?Could you please suggest me a way to resolve it?
Previous Topic:!ENTRY org.eclipse.osgi 4 0 2017-02-03 13:23:15.443 !MESSAGE Startup error !STACK 1 java.lang.Number
Next Topic:Which version of eclipse I have to install
Goto Forum:
  


Current Time: Fri Jul 03 19:23:50 GMT 2020

Powered by FUDForum. Page generated in 0.02909 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top