Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Buckminster » Aggregator eats CPU and runs forever at 5%... with 3 update sites
Aggregator eats CPU and runs forever at 5%... with 3 update sites [message #520046] Wed, 10 March 2010 18:06 Go to next message
Bernhard Merkle is currently offline Bernhard MerkleFriend
Messages: 88
Registered: July 2009
Member
This is a multi-part message in MIME format.
--------------050406000805090807060909
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit

please see the attached aggregator file.

it runs fine if i _only_ enable the gallileo update site. takes about
30min and all plugins are down on my disk.

now if i enable _all_ update sites (means i enable the items and the
polarion site) the aggrator runs forever, eats CPU and stops at 5%
saying "verify config win32, etc..."

whats the problem here ? I just want the additional Xtext and Subversive
stuff to be downloaded. any idea ?
Why does eclipse eat so much cpu in this step ?

thanks,
Bernhard.

--------------050406000805090807060909
Content-Type: text/xml;
name="Aggregator.Eclipse3.5.Gallileo.build"
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment;
filename="Aggregator.Eclipse3.5.Gallileo.build"

<?xml version="1.0" encoding="UTF-8"?>
<aggregator:Aggregator xmi:version="2.0" xmlns:xmi="http://www.omg.org/XMI" xmlns:aggregator="http://www.eclipse.org/buckminster/2009/aggregator" label="Eclipse 3.5 Galieo Target" buildRoot="build.Eclipse3.5">
<configurations/>
<configurations operatingSystem="linux" windowSystem="gtk"/>
<contributions label="Galileo">
<repositories location="http://download.eclipse.org/releases/galileo" categoryPrefix="galileo">
<metadataRepository href=" p2:http://download.eclipse.org/releases/galileo#//@metadataR epository"/>
</repositories>
</contributions>
<contributions label="Xtext">
<repositories location="http://download.itemis.com/updates/releases">
<metadataRepository href=" p2:http://download.itemis.com/updates/releases#//@metadataRe pository"/>
</repositories>
</contributions>
<contributions label="Subversive">
<repositories location=" http://community.polarion.com/projects/subversive/download/e clipse/2.0/galileo-site/">
<metadataRepository href=" p2:http://community.polarion.com/projects/subversive/downloa d/eclipse/2.0/galileo-site#//@metadataRepository"/>
</repositories>
</contributions>
</aggregator:Aggregator>

--------------050406000805090807060909--
Re: Aggregator eats CPU and runs forever at 5%... with 3 update sites [message #520111 is a reply to message #520046] Thu, 11 March 2010 08:25 Go to previous message
Filip Hrbek is currently offline Filip HrbekFriend
Messages: 233
Registered: July 2009
Senior Member
Hi Bernhard,

well the "forever" took about an hour on my machine (Intel Duo Core 2GHz) :-)

Finally I got following problem explanation:
Cannot complete the install because of a conflicting dependency.
Software being installed: all.contributed.content.feature.group 1.0.0
Only one of the following can be installed at once:
Net4j Signalling Platform Runtime 2.0.0.v200906160348 (org.eclipse.net4j.feature.jar 2.0.0.v200906160348)
Net4j 0.7.1.v200610271244 (org.eclipse.net4j.feature.jar 0.7.1.v200610271244)
Cannot satisfy dependency:
From: all.contributed.content.feature.group 1.0.0
To: org.eclipse.emf.cdo.dbgen.feature.group 0.0.0
Cannot satisfy dependency:
From: all.contributed.content.feature.group 1.0.0
To: org.eclipse.net4j.defs.feature.group 0.0.0
Cannot satisfy dependency:
From: CDO DBGen 0.7.1.v200610271316 (org.eclipse.emf.cdo.dbgen.feature.group 0.7.1.v200610271316)
To: org.eclipse.net4j.feature.group [0.7.1,1.0.0)
Cannot satisfy dependency:
From: Net4j Signalling Platform Definitions 2.0.0.v200906160348 (org.eclipse.net4j.defs.feature.group 2.0.0.v200906160348)
To: org.eclipse.net4j.feature.group [2.0.0.v200906160348]
Cannot satisfy dependency:
From: Net4j 0.7.1.v200610271244 (org.eclipse.net4j.feature.group 0.7.1.v200610271244)
To: org.eclipse.net4j.feature.jar [0.7.1.v200610271244]
Cannot satisfy dependency:
From: Net4j Signalling Platform Runtime 2.0.0.v200906160348 (org.eclipse.net4j.feature.group 2.0.0.v200906160348)
To: org.eclipse.net4j.feature.jar [2.0.0.v200906160348]


Once the aggregate cannot be resolved without missing components or conflicts, a human readable explanation is generated.

However, the generation of the explanation eats full CPU (but only one of my two cores!) and does not seem to be very efficient.

Please enter a bugzilla issue so that we wouldn't forget (although I think that it will be more p2 than aggregator problem).

Since the aggregator is now being developed under the EMFT.b3 project, use modelling/EMFT.b3 classification, module aggregator.

Regards,
Filip


Bernhard Merkle wrote:
> please see the attached aggregator file.
>
> it runs fine if i _only_ enable the gallileo update site. takes about
> 30min and all plugins are down on my disk.
>
> now if i enable _all_ update sites (means i enable the items and the
> polarion site) the aggrator runs forever, eats CPU and stops at 5%
> saying "verify config win32, etc..."
>
> whats the problem here ? I just want the additional Xtext and Subversive
> stuff to be downloaded. any idea ?
> Why does eclipse eat so much cpu in this step ?
>
> thanks,
> Bernhard.
>
Previous Topic:Aggregator chooses only newest version ?
Next Topic:Buckminster and fragments and unit tests
Goto Forum:
  


Current Time: Sun Jul 25 08:54:46 GMT 2021

Powered by FUDForum. Page generated in 0.01972 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top