Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » Multiple errors in installing PDT 2.2 + DLTK(Been racking my brain to get it installed...)
Multiple errors in installing PDT 2.2 + DLTK [message #519015] Fri, 05 March 2010 17:16 Go to next message
Greg is currently offline GregFriend
Messages: 3
Registered: July 2009
Junior Member
Sorry to be a pain, but I need a bit of help in installing PDT 2.2 on a fresh install of Galileo. I followed the instructions at http://wiki.eclipse.org/PDT/Installation but it seems that the most recent version of DLTK screwed things up, so whenever I try to open a file, it says that the editor cannot be initialized. Someone opened a bug report for it, and that report points to a StackOverflow thread.

On that thread, the best response is to replace the DLTK core file with an older version. This gets the editor open and basic functionality back, but whenever I try to work with a class, it tosses an error in:

org.eclipse.dltk.core.IMethod.getParameters()[Lorg/eclipse/d ltk/core/IParameter;

So clearly that didn't work either. Another guy on there says to do an install from a nightly build of PDT but that broke the whole thing altogether. Basically, I'm stuck. I thought that maybe updating DLTK to the latest integration build would help, but when I try to point the Install screen to the build dir, it doesn't notice any new versions (that is, the versions it says are 2.0.0.20090707).

Sorry this is so long, but I'm at my wit's end. Has anyone come up with a solution to this?
Re: Multiple errors in installing PDT 2.2 + DLTK [message #519067 is a reply to message #519015] Sat, 06 March 2010 00:57 Go to previous messageGo to next message
rvdavid is currently offline rvdavidFriend
Messages: 2
Registered: March 2010
Junior Member
I was experiencing the same issue. I found that the latest answer in the link you specified in your post worked perfectly.

Basically - it says to download the 2.2 nightly build here: https://build.eclipse.org/hudson/view/Athena%20CBI/job/cbi-p dt-2.2-helios/lastStableBuild/

Expand the "Build Artifacts" link until you find the pdt-Update-N201003021518.zip zip file and download, then use it as a local update site. to install pdt 2.2

I imagine that this build has been adjusted to work with the current DLTK 2.0 packages.

The source to my answer is on the following link:

http://stackoverflow.com/questions/2262758/problems-opening- php-files-in-eclipse

It's the latest answer there at the time I'm posting this reply, but in case that other answers are posted, just look for the answer which I commented on.

HTH.


Web Developer

Blog - http://www.rvdavid.net (Check me out)
Twitter - http://www.twitter.com/rvdavid (Follow me)

[Updated on: Sat, 06 March 2010 01:19]

Report message to a moderator

Re: Multiple errors in installing PDT 2.2 + DLTK [message #519069 is a reply to message #519067] Sat, 06 March 2010 01:21 Go to previous messageGo to next message
Greg is currently offline GregFriend
Messages: 3
Registered: July 2009
Junior Member
RV David wrote on Fri, 05 March 2010 19:57
I was experiencing the same issue. I found that the latest answer in the link you specified in your post worked perfectly.

Basically - it says to download the 2.2 nightly build here: https://build.eclipse.org/hudson/view/Athena%20CBI/job/cbi-p dt-2.2-helios/lastStableBuild/

Expand the "Build Artifacts" link until you find the pdt-Update-N201003021518.zip zip file and download, then use it as a local update site. to install pdt 2.2

I imagine that this build has been adjusted to work with the current DLTK 2.0 packages.

The source to my answer is on the following link:

http://stackoverflow.com/questions/2262758/problems-opening- php-files-in-eclipse

It's the latest answer there at the time I'm posting this reply, but in case that other answers are posted, just look for the answer which I commented on.

HTH.


Did you do this as an update to an older version of PDT 2.2, or did you do a fresh install? I did the former and it broke..
Re: Multiple errors in installing PDT 2.2 + DLTK [message #519070 is a reply to message #519069] Sat, 06 March 2010 01:23 Go to previous messageGo to next message
rvdavid is currently offline rvdavidFriend
Messages: 2
Registered: March 2010
Junior Member
I did both and worked fine for me.

Web Developer

Blog - http://www.rvdavid.net (Check me out)
Twitter - http://www.twitter.com/rvdavid (Follow me)
Re: Multiple errors in installing PDT 2.2 + DLTK [message #519071 is a reply to message #519070] Sat, 06 March 2010 01:39 Go to previous messageGo to next message
Greg is currently offline GregFriend
Messages: 3
Registered: July 2009
Junior Member
rvdavid wrote on Fri, 05 March 2010 20:23
I did both and worked fine for me.


I just did a fresh install and it worked! In case anyone else is looking for this, here's what I did. This is for Windows:

- Download eclipse-java-galileo-SR2-win32.zip and extract it to a folder
- Go to https://build.eclipse.org/hudson/view/Athena%20CBI/job/cbi-p dt-2.2-helios/lastStableBuild/, search through for pdt-Update-N201003021518.zip, download and extract it to a folder
- Run eclipse
- Help menu, Install new software
- Add the DLTK location: http://download.eclipse.org/technology/dltk/updates-dev/2.0/
- Add the extracted folder from pdt-Update-N201003021518.zip as a local archive
- Install the PDT 2.2 runtime from the extracted folder section and step through as per normal

That worked for me. Thanks to rvdavid for the help!
Re: Multiple errors in installing PDT 2.2 + DLTK [message #519072 is a reply to message #519015] Sat, 06 March 2010 01:41 Go to previous messageGo to next message
Toshihiro Izumi is currently offline Toshihiro IzumiFriend
Messages: 360
Registered: July 2009
Location: Japan
Senior Member
Try latest build, you can get it from cbi-pdt-2.2-helios [Hudson]
Re: Multiple errors in installing PDT 2.2 + DLTK [message #519073 is a reply to message #519072] Sat, 06 March 2010 01:43 Go to previous message
Toshihiro Izumi is currently offline Toshihiro IzumiFriend
Messages: 360
Registered: July 2009
Location: Japan
Senior Member
oops, sorry late response Wink
Previous Topic:Short tags and autocompletion
Next Topic:can't debug, or even view, my project in Eclipse
Goto Forum:
  


Current Time: Mon May 17 20:36:54 GMT 2021

Powered by FUDForum. Page generated in 0.02235 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top