Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Buckminster dev » eclemma version
eclemma version [message #518138] Wed, 03 March 2010 04:04 Go to next message
Thomas Hallgren is currently offline Thomas HallgrenFriend
Messages: 3240
Registered: July 2009
Senior Member
Our org.eclipse.buckminster.emma bundle has dependency constraint on eclemma.core that prevents it from using the latest
1.4.3. Is that deliberate (IP related) or is it for other reasons?

If it's IP related, is it time for a new CQ?

Regards,
Thomas Hallgren
Re: eclemma version [message #518338 is a reply to message #518138] Wed, 03 March 2010 20:23 Go to previous messageGo to next message
Achim Demelt is currently offline Achim DemeltFriend
Messages: 160
Registered: July 2009
Senior Member
That's IP related. I though "Better safe than sorry," so I restricted the
version to the one that has been approved. Given that there's only been one
fix in 1.4.3 [1] I'm not sure if we should push for a new CQ. Let's not
waste the precious IP resources at the foundation and wait until there's
either

a) significant benefit in upgrading to a new version
b) a serious bugfix that we need to pass on to our users.

Cheers,
Achim

[1] http://www.eclemma.org/changes.html


Thomas Hallgren wrote:

> Our org.eclipse.buckminster.emma bundle has dependency constraint on
> eclemma.core that prevents it from using the latest 1.4.3. Is that
> deliberate (IP related) or is it for other reasons?
>
> If it's IP related, is it time for a new CQ?
>
> Regards,
> Thomas Hallgren
Re: eclemma version [message #518371 is a reply to message #518338] Wed, 03 March 2010 17:28 Go to previous messageGo to next message
Thomas Hallgren is currently offline Thomas HallgrenFriend
Messages: 3240
Registered: July 2009
Senior Member
Hi Achim,

On 03/03/2010 09:23 PM, Achim Demelt wrote:
> That's IP related. I though "Better safe than sorry," so I restricted the
> version to the one that has been approved.

I think that might be a tad to restrictive. The IP controls what we can deliver from our update site but that doesn't
mean that we must restrict the version range. I think we can control that using the releng cquery.

If eclemma uses version semantics similar to ours (API remains stable unless major or minor number changes), then I
suggest we use the range [1.4.0,1.5.0) to avoid conflicts as much as possible.

My concern is that we don't provide the full eclemma from our update site. If someone installs eclemma with ui and all
into their IDE, they will get 1.4.3. Subsequent attempts to install Buckminster will then fail (as I just experienced).

> Given that there's only been one
> fix in 1.4.3 [1] I'm not sure if we should push for a new CQ. Let's not
> waste the precious IP resources at the foundation and wait until there's
> either
>
> a) significant benefit in upgrading to a new version
> b) a serious bugfix that we need to pass on to our users.
>
> Cheers,
> Achim
>
> [1] http://www.eclemma.org/changes.html
>
I agree that this fix doesn't motivate a new CQ.

- thomas
Re: eclemma version [message #518692 is a reply to message #518371] Thu, 04 March 2010 18:37 Go to previous message
Achim Demelt is currently offline Achim DemeltFriend
Messages: 160
Registered: July 2009
Senior Member
Hi Thomas,

Okay, I was under the impression that this dependency declaration also
controls what we're providing in our p2 repo. If you can make sure that we
don't violate IP by erroneously including 1.4.3 in our repo, please feel
free to adjust the dependency declaration to [1.4.2,1.5.0). Even
[1.4.2,2.0.0) should work.

Thanks,
Achim

Thomas Hallgren wrote:

> Hi Achim,
>
> On 03/03/2010 09:23 PM, Achim Demelt wrote:
>> That's IP related. I though "Better safe than sorry," so I restricted the
>> version to the one that has been approved.
>
> I think that might be a tad to restrictive. The IP controls what we can
> deliver from our update site but that doesn't mean that we must restrict
> the version range. I think we can control that using the releng cquery.
>
> If eclemma uses version semantics similar to ours (API remains stable
> unless major or minor number changes), then I suggest we use the range
> [1.4.0,1.5.0) to avoid conflicts as much as possible.
>
> My concern is that we don't provide the full eclemma from our update site.
> If someone installs eclemma with ui and all into their IDE, they will get
> 1.4.3. Subsequent attempts to install Buckminster will then fail (as I
> just experienced).
>
>> Given that there's only been one
>> fix in 1.4.3 [1] I'm not sure if we should push for a new CQ. Let's not
>> waste the precious IP resources at the foundation and wait until there's
>> either
>>
>> a) significant benefit in upgrading to a new version
>> b) a serious bugfix that we need to pass on to our users.
>>
>> Cheers,
>> Achim
>>
>> [1] http://www.eclemma.org/changes.html
>>
> I agree that this fix doesn't motivate a new CQ.
>
> - thomas
Previous Topic:Re: [buckminster-dev] Downloading source jars
Next Topic:[buckminster-dev] Project meta data is out of date for tools.buckminster
Goto Forum:
  


Current Time: Wed Sep 19 22:57:21 GMT 2018

Powered by FUDForum. Page generated in 0.01618 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top