|Re: eclemma version [message #518692 is a reply to message #518371]
||Thu, 04 March 2010 18:37
| Achim Demelt
Registered: July 2009
Okay, I was under the impression that this dependency declaration also
controls what we're providing in our p2 repo. If you can make sure that we
don't violate IP by erroneously including 1.4.3 in our repo, please feel
free to adjust the dependency declaration to [1.4.2,1.5.0). Even
[1.4.2,2.0.0) should work.
Thomas Hallgren wrote:
> Hi Achim,
> On 03/03/2010 09:23 PM, Achim Demelt wrote:
>> That's IP related. I though "Better safe than sorry," so I restricted the
>> version to the one that has been approved.
> I think that might be a tad to restrictive. The IP controls what we can
> deliver from our update site but that doesn't mean that we must restrict
> the version range. I think we can control that using the releng cquery.
> If eclemma uses version semantics similar to ours (API remains stable
> unless major or minor number changes), then I suggest we use the range
> [1.4.0,1.5.0) to avoid conflicts as much as possible.
> My concern is that we don't provide the full eclemma from our update site.
> If someone installs eclemma with ui and all into their IDE, they will get
> 1.4.3. Subsequent attempts to install Buckminster will then fail (as I
> just experienced).
>> Given that there's only been one
>> fix in 1.4.3  I'm not sure if we should push for a new CQ. Let's not
>> waste the precious IP resources at the foundation and wait until there's
>> a) significant benefit in upgrading to a new version
>> b) a serious bugfix that we need to pass on to our users.
>>  http://www.eclemma.org/changes.html
> I agree that this fix doesn't motivate a new CQ.
> - thomas
Powered by FUDForum
. Page generated in 0.01618 seconds