Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Issue with menu bar and business theme (rap 1.2.2)
Issue with menu bar and business theme (rap 1.2.2) [message #517738] Mon, 01 March 2010 21:45 Go to next message
Bryce is currently offline BryceFriend
Messages: 4
Registered: March 2010
Junior Member
When using the Business theme, the first time you open a menu and click one of its options, the menu closes but the action does not happen.

For example, rap demo with business theme from within Eclipse IDE:
- if already running RAP Workbench Demo, stop it
- launch RAP Workbench Demo
- Go to: http://localhost:[port]/business
- Click on Window menu, Click on "Show View". Menu closes, nothing happens
- Click on Window menu again, Click on "Show View" again, Click on "Other...". Menu closes, nothing happens.
- Click on Window menu again, click on "Show View" again, Click on "Other..." again, now the "Show View" window appears.

Same thing happens with other menus, such as File menu:
- Click on File menu, click "Exit". Menu closes, nothing happens.
- Click on File menu again, click "Exit". Now the exit is processed.

It seems that the first time a menu opens with the business theme, its not properly initialized. But when the menu is opened subsequently, then it seems to work fine.

The menus work properly without the Business theme (http://localhost:[port]/rap)

observed in Eclipse's internal browser, Firefox 3.5.8, IE 7

Any suggestions?
Re: Issue with menu bar and business theme (rap 1.2.2) [message #517746 is a reply to message #517738] Mon, 01 March 2010 22:16 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2359
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi,

maybe you ran into this bug:
279130: [Design] Design seldom misses menu clicks
https://bugs.eclipse.org/bugs/show_bug.cgi?id=279130
which has been fixed in 1.3 M5. You can try to work against 1.3 M5 or
CVS HEAD.

Best,
Ivan

On 3/1/2010 11:45 PM, ba_harward@yahoo.com wrote:
> When using the Business theme, the first time you open a menu and
> click one of its options, the menu closes but the action does not happen.
>
> For example, rap demo with business theme from within Eclipse IDE:
> - if already running RAP Workbench Demo, stop it
> - launch RAP Workbench Demo
> - Go to: http://localhost:[port]/business
> - Click on Window menu, Click on "Show View". Menu closes, nothing
> happens
> - Click on Window menu again, Click on "Show View" again, Click on
> "Other...". Menu closes, nothing happens.
> - Click on Window menu again, click on "Show View" again, Click on
> "Other..." again, now the "Show View" window appears.
>
> Same thing happens with other menus, such as File menu:
> - Click on File menu, click "Exit". Menu closes, nothing happens.
> - Click on File menu again, click "Exit". Now the exit is processed.
>
> It seems that the first time a menu opens with the business theme, its
> not properly initialized. But when the menu is opened subsequently,
> then it seems to work fine.
>
> The menus work properly without the Business theme
> (http://localhost:[port]/rap)
>
> observed in Eclipse's internal browser, Firefox 3.5.8, IE 7
>
> Any suggestions?
Re: Issue with menu bar and business theme (rap 1.2.2) [message #517752 is a reply to message #517746] Mon, 01 March 2010 22:31 Go to previous messageGo to next message
Bryce is currently offline BryceFriend
Messages: 4
Registered: March 2010
Junior Member
Sorry I missed that. I'll try with 1.3M5 and report back. Thanks!!!
Re: Issue with menu bar and business theme (rap 1.2.2) [message #517760 is a reply to message #517752] Mon, 01 March 2010 23:18 Go to previous message
Bryce is currently offline BryceFriend
Messages: 4
Registered: March 2010
Junior Member
I can confirm that 1.3 M5 solves the problem.

Thank you for your help!!!
Previous Topic:WAR File Creation
Next Topic:CSS Stylable Widgets
Goto Forum:
  


Current Time: Sun Dec 05 21:43:41 GMT 2021

Powered by FUDForum. Page generated in 0.02390 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top