Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Buckminster » headless buckminster and silent fail
headless buckminster and silent fail [message #516281] Tue, 23 February 2010 13:41 Go to next message
Bernhard Merkle is currently offline Bernhard MerkleFriend
Messages: 88
Registered: July 2009
Member
Hi again,

during setup my headless buckminster i stumbled over a "feature".

I forgot to install the command for headless PDE build.
However if I invoke buckminster clean or buckminster build I get NO warning/that there is no target in my workspace.

Only after installing the PDE build command in bucky headless the build/clean worked as expected.

IMO it would be nice if bucky shouts out: no target found or something like that. Failing silently is unconvenient in most cases.

Should I open a bugzilla for that ? (if you consider this a usefull behaviour ?)

thanks,
Bernhard.
Re: headless buckminster and silent fail [message #516306 is a reply to message #516281] Tue, 23 February 2010 15:02 Go to previous message
Henrik Lindberg is currently offline Henrik LindbergFriend
Messages: 2509
Registered: July 2009
Senior Member
I guess the question is, how buckminster could even know that it was
supposed to do something with PDE when it has no support for PDE
installed :)

It would be nice to get a warning like:
Workspace contains projects of natures/types for which support has not
been installed...

Having a configuration where everything in the workspace is not being
built is valid, so I think it should be a warning and not a hard error.

Please file an enhancement request in bugzilla.

Regards
- henrik

On 2/23/10 2:41 PM, Bernhard Merkle wrote:
> Hi again,
>
> during setup my headless buckminster i stumbled over a "feature".
>
> I forgot to install the command for headless PDE build.
> However if I invoke buckminster clean or buckminster build I get NO
> warning/that there is no target in my workspace.
>
> Only after installing the PDE build command in bucky headless the
> build/clean worked as expected.
>
> IMO it would be nice if bucky shouts out: no target found or something
> like that. Failing silently is unconvenient in most cases.
>
> Should I open a bugzilla for that ? (if you consider this a usefull
> behaviour ?)
>
> thanks,
> Bernhard.
>
Previous Topic:Custom zip filename in CSPECX
Next Topic:junit command fails with 'Process {0} terminated with exit status {1}' for 'Junit Plug-in Test'
Goto Forum:
  


Current Time: Wed Jul 28 21:30:24 GMT 2021

Powered by FUDForum. Page generated in 0.01718 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top