Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Remote debugging into Tomcat/Linux/x64 from Win7 x64(Getting "timeout exception" errors)
Remote debugging into Tomcat/Linux/x64 from Win7 x64 [message #513489] Wed, 10 February 2010 11:44
Richard Gaywood is currently offline Richard GaywoodFriend
Messages: 3
Registered: February 2010
Junior Member
Can anyone help me resolve this? I think the problem might lie in the underlying platforms I'm using.

I have an x64 Linux instance running Tomcat 5.0.28 under Java 1.6.0_16 (this is a dupe of our production install, so I can't change those software versions). It's actually a VM, although I doubt that matters. My workstation is running Windows 7 x64, JDK 1.6.0_18 x64, and Eclipse 3.5.1 and I want to remote debug the Tomcat server. I can connect JSwat running on my workstation to Tomcat on the Linux server and can hit breakpoints, so I can't have any network, firewall, or Tomcat config issues (I think). However, when I fire Eclipse up, it fails with the following message under workspace/.metadata/log:

!ENTRY org.eclipse.jdt.launching 4 113 2010-02-10 11:29:49.106
!MESSAGE Failed to connect to remote VM. Connection timed out.
	at org.eclipse.jdi.internal.connect.SocketTransportService.attach(
	at org.eclipse.jdi.internal.connect.SocketTransportImpl.attach(
	at org.eclipse.jdi.internal.connect.SocketAttachingConnectorImpl.attach(
	at org.eclipse.jdt.internal.launching.SocketAttachConnector.connect(
	at org.eclipse.jdt.internal.launching.JavaRemoteApplicationLaunchConfigurationDelegate.launch(
	at org.eclipse.debug.internal.core.LaunchConfiguration.launch(
	at org.eclipse.debug.internal.core.LaunchConfiguration.launch(
	at org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch(
	at org.eclipse.debug.internal.ui.DebugUIPlugin$

Tomcat is running with the following debug command line parameters:
-Xdebug -Xrunjdwp:transport=dt_socket,address=1044,server=y,suspend= n

In Eclipse, I have configured a Debug Configuration with connection type "standard (socket attach)", host IP and port number defined correctly.

I started with eclipse-jee-galileo-SR1-win32, then I tried a trick from here -bit/; where I unzipped eclipse-SDK-3.5.1-win32-x86_64 over the top of it (should give me a working x64 JEE Eclipse instance). I get the same error with all those versions.

What am I missing?
Previous Topic:Customizing tooltip for Eclipse perspective
Next Topic:BeanInfo Registry
Goto Forum:

Current Time: Sat May 25 14:44:06 GMT 2024

Powered by FUDForum. Page generated in 0.02762 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top