Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMF (Graphical Modeling Framework) » Editor not getting dirty from property view when same file for diagram and model(Editor not getting dirty from property view when same file for diagram and model)
Editor not getting dirty from property view when same file for diagram and model [message #513172] Tue, 09 February 2010 08:50 Go to next message
Vikas Goyal is currently offline Vikas GoyalFriend
Messages: 34
Registered: July 2009
Member
Hello,

I am using galileo with gmf 2.2. I am using mindmap example (provided by gmf) with Same File For Diagram And Model. In this application using property view when I change the attrbute of any of my element on the editor , editor is not getting marked dirty and I cant save the changes I made. If I move some element on the editor and save it , then my changes also gets save. Can Some one help me how to resolve this problem? If I use diffrent file for Diagram And Model then it works well.

Thanks in advance
Vikas
Re: Editor not getting dirty from property view when same file for diagram and model [message #513600 is a reply to message #513172] Wed, 10 February 2010 16:41 Go to previous message
Fernando Herrera is currently offline Fernando HerreraFriend
Messages: 49
Registered: January 2010
Member
Vikas I had a similar problem. I couldn't see the properties view of my elements in the editor so I regenerate the emf plugins and after the diagram plugin and solve the problem. That is one option but maybe the problem is in the gmfmap definition do you check the correct behavior of the editor with both model and diagram file?
Previous Topic:MindMap tutorial with GMF 2.2
Next Topic:[Announce] Eclipse/OMG Symposium 2010
Goto Forum:
  


Current Time: Thu Apr 15 03:18:00 GMT 2021

Powered by FUDForum. Page generated in 0.02246 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top